]> git.pld-linux.org Git - packages/edje.git/blob - edje.spec
feeca39b3b2a0aad1f9a6ff2497898fea07b4670
[packages/edje.git] / edje.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       1.0.0
6 %define         eet_ver         1.4.0
7 %define         embryo_ver      1.0.0
8 %define         evas_ver        1.0.0
9 Summary:        Complex Graphical Design/Layout Engine
10 Summary(pl.UTF-8):      Złożony silnik graficznego projektowania/planowania
11 Name:           edje
12 Version:        1.0.1
13 Release:        1
14 License:        BSD
15 Group:          X11/Libraries
16 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
17 # Source0-md5:  36e5f22e76304ada5d19baee2a38a61a
18 URL:            http://trac.enlightenment.org/e/wiki/Edje
19 BuildRequires:  autoconf >= 2.52
20 BuildRequires:  automake >= 1.6
21 BuildRequires:  ecore-devel >= %{ecore_ver}
22 BuildRequires:  ecore-evas-devel >= %{ecore_ver}
23 BuildRequires:  ecore-file-devel >= %{ecore_ver}
24 BuildRequires:  ecore-imf-devel >= %{ecore_ver}
25 BuildRequires:  ecore-imf-evas-devel >= %{ecore_ver}
26 BuildRequires:  eet-devel >= %{eet_ver}
27 BuildRequires:  embryo-devel >= %{embryo_ver}
28 BuildRequires:  evas-devel >= %{evas_ver}
29 BuildRequires:  libtool
30 BuildRequires:  lua51 >= 5.1.0
31 BuildRequires:  pkgconfig >= 1:0.22
32 BuildRequires:  python >= 1:2.5
33 Requires:       %{name}-libs = %{version}-%{release}
34 Requires:       cpp
35 Requires:       evas-engine-buffer >= %{evas_ver}
36 Requires:       evas-loader-png >= %{evas_ver}
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %undefine       __cxx
40 %define         specflags_x86_64        -mfpmath=387
41 %define         specflags_amd64         -mfpmath=387
42
43 %description
44 Edje is a complex graphical design and layout engine. It provides a
45 mechanism for allowing configuration data to define visual elements in
46 terms of layout, behavior, and appearance. Edje allows for multiple
47 collections of layouts in one file, allowing a complete set of images,
48 animations, and controls to exist as a unified whole.
49
50 Edje separates the arrangement, appearance, and behavior logic into
51 distinct independent entities. This allows visual objects to share
52 image data and configuration information without requiring them to do
53 so. This separation and simplistic event driven style of programming
54 can produce almost any look and feel one could want for basic visual
55 elements. Anything more complex is likely the domain of an application
56 or widget set that may use Edje as a convenient way of being able to
57 configure parts of the display.
58
59 %description -l pl.UTF-8
60 Edje to złożony silnik graficznego projektowania i planowania.
61 Dostarcza mechanizm pozwalający na definiowanie elementów graficznych
62 za pomocą danych konfiguracyjnych poprzez rozmieszczenie, zachowanie i
63 wygląd. Edje pozwala na wiele kolekcji projektów w jednym pliku,
64 zezwalając na istnienie pełnego zbioru obrazów, animacji i kontrolek
65 jako całości.
66
67 Edje oddziela rozmieszczenie, wygląd i logikę zachowania na różne,
68 niezależne elementy. Pozwala to na współdzielenie danych obrazów i
69 informacji o konfiguracji elementów graficznych bez wymagania tego.
70 Rozdzielenie to i uproszczony model programowania sterowanego
71 zdarzeniami może stworzyć prawie dowolny wygląd i zachowanie
72 podstawowych elementów graficznych. Wszystko bardziej złożone jest
73 raczej domeną aplikacji lub zbioru widgetów, które mogą używać Edje
74 jako wygodnego sposobu konfigurowania części ekranu.
75
76 %package libs
77 Summary:        Edje library
78 Summary(pl.UTF-8):      Biblioteka edje
79 Group:          X11/Libraries
80 Requires:       ecore >= %{ecore_ver}
81 Requires:       ecore-file >= %{ecore_ver}
82 Requires:       ecore-imf >= %{ecore_ver}
83 Requires:       ecore-imf-evas >= %{ecore_ver}
84 Requires:       eet >= %{eet_ver}
85 Requires:       embryo >= %{embryo_ver}
86 Requires:       evas >= %{evas_ver}
87
88 %description libs
89 Edje library.
90
91 %description libs -l pl.UTF-8
92 Biblioteka edje.
93
94 %package devel
95 Summary:        Edje header files
96 Summary(pl.UTF-8):      Pliki nagłówkowe Edje
97 Group:          Development/Libraries
98 Requires:       %{name}-libs = %{version}-%{release}
99 Requires:       ecore-devel >= %{ecore_ver}
100 Requires:       ecore-file-devel >= %{ecore_ver}
101 Requires:       ecore-imf-devel >= %{ecore_ver}
102 Requires:       ecore-imf-evas-devel >= %{ecore_ver}
103 Requires:       eet-devel >= %{eet_ver}
104 Requires:       embryo-devel >= %{embryo_ver}
105 Requires:       evas-devel >= %{evas_ver}
106
107 %description devel
108 Header files for Edje.
109
110 %description devel -l pl.UTF-8
111 Pliki nagłówkowe Edje.
112
113 %package static
114 Summary:        Static Edje library
115 Summary(pl.UTF-8):      Statyczna biblioteka Edje
116 Group:          Development/Libraries
117 Requires:       %{name}-devel = %{version}-%{release}
118
119 %description static
120 Static Edje library.
121
122 %description static -l pl.UTF-8
123 Statyczna biblioteka Edje.
124
125 %package -n vim-syntax-edc
126 Summary:        EDC syntax support for Vim
127 Summary(pl.UTF-8):      Obsługa składni EDC dla Vima
128 Group:          Applications/Editors/Vim
129 Requires:       vim-rt
130
131 %description -n vim-syntax-edc
132 EDC syntax support for Vim.
133
134 %description -n vim-syntax-edc -l pl.UTF-8
135 Obsługa składni EDC dla Vima.
136
137 %prep
138 %setup -q
139
140 %build
141 %{__libtoolize}
142 %{__aclocal} -I m4
143 %{__autoconf}
144 %{__autoheader}
145 %{__automake}
146 %configure \
147         --disable-silent-rules \
148         %{!?with_static_libs:--disable-static} \
149         --enable-edje-cc \
150         --with-vim=/usr/share/vim/vimfiles
151 %{__make}
152
153 %install
154 rm -rf $RPM_BUILD_ROOT
155
156 %{__make} install \
157         DESTDIR=$RPM_BUILD_ROOT
158
159 install -d $RPM_BUILD_ROOT%{_libdir}/edje
160 install -D data/edc.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/edc.vim
161
162 %clean
163 rm -rf $RPM_BUILD_ROOT
164
165 %post   libs -p /sbin/ldconfig
166 %postun libs -p /sbin/ldconfig
167
168 %files
169 %defattr(644,root,root,755)
170 %doc AUTHORS COPYING ChangeLog README
171 %attr(755,root,root) %{_bindir}/edje_cc
172 %attr(755,root,root) %{_bindir}/edje_decc
173 %attr(755,root,root) %{_bindir}/edje_external_inspector
174 %attr(755,root,root) %{_bindir}/edje_inspector
175 %attr(755,root,root) %{_bindir}/edje_player
176 %attr(755,root,root) %{_bindir}/edje_recc
177 %attr(755,root,root) %{_bindir}/inkscape2edc
178 %dir %{_libdir}/%{name}
179 %{_datadir}/%{name}
180 %{_datadir}/mime/packages/edje.xml
181
182 %files libs
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/libedje.so.*.*.*
185 %attr(755,root,root) %ghost %{_libdir}/libedje.so.1
186
187 %files devel
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_libdir}/libedje.so
190 %{_libdir}/libedje.la
191 %{_includedir}/edje-1
192 %{_pkgconfigdir}/edje.pc
193
194 %if %{with static_libs}
195 %files static
196 %defattr(644,root,root,755)
197 %{_libdir}/libedje.a
198 %endif
199
200 %files -n vim-syntax-edc
201 %defattr(644,root,root,755)
202 %{_datadir}/vim/vimfiles/syntax/edc.vim
This page took 0.234818 seconds and 2 git commands to generate.