]> git.pld-linux.org Git - packages/edje.git/blob - edje.spec
c3013811d7afa01abe0d97526350a508312d74ec
[packages/edje.git] / edje.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_with     remix           # remix support (not used now as multisense is disabled)
5 #
6 %define         ecore_ver       1.7.9
7 %define         eet_ver         1.7.9
8 %define         eina_ver        1.7.9
9 %define         eio_ver         1.7.9
10 %define         embryo_ver      1.7.9
11 %define         evas_ver        1.7.9
12 Summary:        Complex Graphical Design/Layout Engine
13 Summary(pl.UTF-8):      Złożony silnik graficznego projektowania/planowania
14 Name:           edje
15 Version:        1.7.9
16 Release:        1
17 License:        BSD
18 Group:          X11/Libraries
19 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
20 # Source0-md5:  4486344a8c0cd7518148ee635db45820
21 Patch0:         %{name}-deps.patch
22 URL:            http://trac.enlightenment.org/e/wiki/Edje
23 # for alsa_snd_player plugin for remix
24 %{?with_remix:BuildRequires:    alsa-lib-devel >= 1.0.21}
25 BuildRequires:  autoconf >= 2.52
26 BuildRequires:  automake >= 1.6
27 BuildRequires:  ecore-devel >= %{ecore_ver}
28 BuildRequires:  ecore-evas-devel >= %{ecore_ver}
29 BuildRequires:  ecore-file-devel >= %{ecore_ver}
30 BuildRequires:  ecore-imf-devel >= %{ecore_ver}
31 BuildRequires:  ecore-imf-evas-devel >= %{ecore_ver}
32 BuildRequires:  eina-devel >= %{eina_ver}
33 BuildRequires:  eio-devel >= %{eio_ver}
34 BuildRequires:  eet-devel >= %{eet_ver}
35 BuildRequires:  embryo-devel >= %{embryo_ver}
36 BuildRequires:  evas-devel >= %{evas_ver}
37 BuildRequires:  flac-devel >= 1.2.1
38 BuildRequires:  libogg-devel >= 1:1.1.4
39 BuildRequires:  libsndfile-devel >= 1.0.21
40 BuildRequires:  libvorbis-devel >= 1:1.2.3
41 BuildRequires:  libtool
42 BuildRequires:  lua51 >= 5.1.0
43 BuildRequires:  pkgconfig >= 1:0.22
44 BuildRequires:  python >= 1:2.5
45 %{?with_remix:BuildRequires:    remix-devel >= 0.2.4}
46 %{?with_remix:Requires: alsa-lib >= 1.0.21}
47 Requires:       %{name}-libs = %{version}-%{release}
48 Requires:       evas-engine-buffer >= %{evas_ver}
49 Requires:       evas-loader-png >= %{evas_ver}
50 Requires:       flac >= 1.2.1
51 Requires:       libogg >= 1:1.1.4
52 Requires:       libvorbis >= 1:1.2.3
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %undefine       __cxx
56 %define         specflags_x86_64        -mfpmath=387
57 %define         specflags_amd64         -mfpmath=387
58
59 %description
60 Edje is a complex graphical design and layout engine. It provides a
61 mechanism for allowing configuration data to define visual elements in
62 terms of layout, behavior, and appearance. Edje allows for multiple
63 collections of layouts in one file, allowing a complete set of images,
64 animations, and controls to exist as a unified whole.
65
66 Edje separates the arrangement, appearance, and behavior logic into
67 distinct independent entities. This allows visual objects to share
68 image data and configuration information without requiring them to do
69 so. This separation and simplistic event driven style of programming
70 can produce almost any look and feel one could want for basic visual
71 elements. Anything more complex is likely the domain of an application
72 or widget set that may use Edje as a convenient way of being able to
73 configure parts of the display.
74
75 %description -l pl.UTF-8
76 Edje to złożony silnik graficznego projektowania i planowania.
77 Dostarcza mechanizm pozwalający na definiowanie elementów graficznych
78 za pomocą danych konfiguracyjnych poprzez rozmieszczenie, zachowanie i
79 wygląd. Edje pozwala na wiele kolekcji projektów w jednym pliku,
80 zezwalając na istnienie pełnego zbioru obrazów, animacji i kontrolek
81 jako całości.
82
83 Edje oddziela rozmieszczenie, wygląd i logikę zachowania na różne,
84 niezależne elementy. Pozwala to na współdzielenie danych obrazów i
85 informacji o konfiguracji elementów graficznych bez wymagania tego.
86 Rozdzielenie to i uproszczony model programowania sterowanego
87 zdarzeniami może stworzyć prawie dowolny wygląd i zachowanie
88 podstawowych elementów graficznych. Wszystko bardziej złożone jest
89 raczej domeną aplikacji lub zbioru widgetów, które mogą używać Edje
90 jako wygodnego sposobu konfigurowania części ekranu.
91
92 %package libs
93 Summary:        Edje library
94 Summary(pl.UTF-8):      Biblioteka edje
95 Group:          X11/Libraries
96 Requires:       ecore >= %{ecore_ver}
97 Requires:       ecore-file >= %{ecore_ver}
98 Requires:       ecore-imf >= %{ecore_ver}
99 Requires:       ecore-imf-evas >= %{ecore_ver}
100 Requires:       eina >= %{eina_ver}
101 Requires:       eio >= %{eio_ver}
102 Requires:       eet >= %{eet_ver}
103 Requires:       embryo >= %{embryo_ver}
104 Requires:       evas >= %{evas_ver}
105 Requires:       libsndfile >= 1.0.21
106 %{?with_remix:Requires: remix >= 0.2.4}
107
108 %description libs
109 Edje library.
110
111 %description libs -l pl.UTF-8
112 Biblioteka edje.
113
114 %package devel
115 Summary:        Edje header files
116 Summary(pl.UTF-8):      Pliki nagłówkowe Edje
117 Group:          Development/Libraries
118 Requires:       %{name}-libs = %{version}-%{release}
119 Requires:       ecore-devel >= %{ecore_ver}
120 Requires:       ecore-file-devel >= %{ecore_ver}
121 Requires:       ecore-imf-devel >= %{ecore_ver}
122 Requires:       ecore-imf-evas-devel >= %{ecore_ver}
123 Requires:       eet-devel >= %{eet_ver}
124 Requires:       eio-devel >= %{eio_ver}
125 Requires:       embryo-devel >= %{embryo_ver}
126 Requires:       evas-devel >= %{evas_ver}
127 Requires:       libsndfile-devel >= 1.0.21
128 %{?with_remix:Requires: remix-devel >= 0.2.4}
129
130 %description devel
131 Header files for Edje.
132
133 %description devel -l pl.UTF-8
134 Pliki nagłówkowe Edje.
135
136 %package static
137 Summary:        Static Edje library
138 Summary(pl.UTF-8):      Statyczna biblioteka Edje
139 Group:          Development/Libraries
140 Requires:       %{name}-devel = %{version}-%{release}
141
142 %description static
143 Static Edje library.
144
145 %description static -l pl.UTF-8
146 Statyczna biblioteka Edje.
147
148 %package -n vim-syntax-edc
149 Summary:        EDC syntax support for Vim
150 Summary(pl.UTF-8):      Obsługa składni EDC dla Vima
151 Group:          Applications/Editors/Vim
152 Requires:       vim-rt
153
154 %description -n vim-syntax-edc
155 EDC syntax support for Vim.
156
157 %description -n vim-syntax-edc -l pl.UTF-8
158 Obsługa składni EDC dla Vima.
159
160 %prep
161 %setup -q
162 %patch0 -p1
163
164 %build
165 %{__libtoolize}
166 %{__aclocal} -I m4
167 %{__autoconf}
168 %{__autoheader}
169 %{__automake}
170 %configure \
171         --disable-silent-rules \
172         %{!?with_remix:--disable-remix} \
173         %{!?with_static_libs:--disable-static} \
174         --enable-edje-cc \
175         --with-vim=/usr/share/vim/vimfiles
176 %{__make}
177
178 %install
179 rm -rf $RPM_BUILD_ROOT
180
181 %{__make} install \
182         DESTDIR=$RPM_BUILD_ROOT
183
184 install -d $RPM_BUILD_ROOT%{_libdir}/edje/modules
185 install -D data/edc.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/edc.vim
186
187 %if %{with remix}
188 %{__rm} $RPM_BUILD_ROOT%{_libdir}/remix/*.la
189 %endif
190
191 %clean
192 rm -rf $RPM_BUILD_ROOT
193
194 %post   libs -p /sbin/ldconfig
195 %postun libs -p /sbin/ldconfig
196
197 %files
198 %defattr(644,root,root,755)
199 %doc AUTHORS COPYING ChangeLog NEWS README
200 %attr(755,root,root) %{_bindir}/edje_cc
201 %attr(755,root,root) %{_bindir}/edje_decc
202 %attr(755,root,root) %{_bindir}/edje_external_inspector
203 %attr(755,root,root) %{_bindir}/edje_inspector
204 %attr(755,root,root) %{_bindir}/edje_player
205 %attr(755,root,root) %{_bindir}/edje_recc
206 %attr(755,root,root) %{_bindir}/edje_watch
207 %attr(755,root,root) %{_bindir}/inkscape2edc
208 %dir %{_libdir}/%{name}/utils
209 %attr(755,root,root) %dir %{_libdir}/%{name}/utils/epp
210 %{_datadir}/%{name}
211 %{_datadir}/mime/packages/edje.xml
212
213 %files libs
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{_libdir}/libedje.so.*.*.*
216 %attr(755,root,root) %ghost %{_libdir}/libedje.so.1
217 %dir %{_libdir}/%{name}
218 %dir %{_libdir}/%{name}/modules
219 %if %{with remix}
220 %attr(755,root,root) %{_libdir}/remix/libalsa_snd_player.so
221 %attr(755,root,root) %{_libdir}/remix/libeet_sndfile_reader.so
222 %endif
223
224 %files devel
225 %defattr(644,root,root,755)
226 %attr(755,root,root) %{_libdir}/libedje.so
227 %{_libdir}/libedje.la
228 %{_includedir}/edje-1
229 %{_pkgconfigdir}/edje.pc
230
231 %if %{with static_libs}
232 %files static
233 %defattr(644,root,root,755)
234 %{_libdir}/libedje.a
235 %endif
236
237 %files -n vim-syntax-edc
238 %defattr(644,root,root,755)
239 %{_datadir}/vim/vimfiles/syntax/edc.vim
This page took 0.621537 seconds and 2 git commands to generate.