]> git.pld-linux.org Git - packages/edb.git/commitdiff
- updated for 1.0.3.
authorkloczek <kloczek@pld-linux.org>
Sat, 10 Aug 2002 09:27:42 +0000 (09:27 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    edb-ac_fix.patch -> 1.2

edb-ac_fix.patch

index 1c652e3b6fd20e2f2c78159ee460612fb32e01ee..ebdb6e653c4ded188e56af7abae01f975e465b96 100644 (file)
@@ -1,23 +1,83 @@
---- edb-1.0.2/configure.in.wiget       Mon Oct 23 20:44:55 2000
-+++ edb-1.0.2/configure.in     Fri Aug  9 17:58:08 2002
-@@ -1,5 +1,6 @@
+--- edb-1.0.3/configure.in.orig        Fri Sep 21 19:36:06 2001
++++ edb-1.0.3/configure.in     Fri Aug  9 20:21:54 2002
+@@ -1,5 +1,5 @@
 -AC_INIT(src/Edb.h)
 -AM_CONFIG_HEADER(config.h)
-+AC_INIT
-+AC_CONFIG_SRCDIR([src/Edb.h])
-+AC_CONFIG_HEADERS([config.h])
- AM_INIT_AUTOMAKE(edb, 1.0.2)
++AC_INIT([src/Edb.h])
++AM_CONFIG_HEADER([config.h])
+ AM_INIT_AUTOMAKE(edb, 1.0.3)
  AC_PROG_CC
  AM_PROG_CC_STDC
-@@ -74,7 +75,6 @@
-               CXXFLAGS="-fhandle-exceptions $CXXFLAGS"
-       fi
+@@ -17,66 +17,11 @@
  
--      LIBOBJS="$LIBOBJS \$(COBJS)"
- fi
+ ##################### DB stuff
+-AC_PROG_INSTALL()
++AC_PROG_INSTALL
+ AC_CANONICAL_HOST
+-AC_ARG_PROGRAM()
+-
+-dnl This is where we handle stuff that autoconf can't handle: compiler,
+-dnl preprocessor and load flags, libraries that the standard tests don't
+-dnl look for.  The default optimization is -O.
+-dnl
+-dnl XXX
+-dnl Don't override anything if it's already set from the environment.
+-AC_SUBST(CFLAGS)
+-AC_SUBST(CPPFLAGS)
+-AC_SUBST(CXX)
+-AC_SUBST(CXXFLAGS)
+-AC_SUBST(LDFLAGS)
+-case "$host_os" in
+-aix4.1*)   CFLAGS=${CFLAGS-"-O3"};;
+-bsd4.4)    CFLAGS=${CFLAGS-"-O2"};;
+-bsdi4*)          CFLAGS=${CFLAGS-"-O2"};;
+-bsdi*)           CC=${CC-"shlicc2"}
+-         CFLAGS=${CFLAGS-"-O2"}
+-         LIBS="-lipc $LIBS";;
+-irix*)           CFLAGS=${CFLAGS-"-O2"};;
+-nextstep3) CFLAGS=${CFLAGS-"-O2"};;
+-linux*)          CFLAGS=${CFLAGS-"-O2"};;
+-mpeix*)          CPPFLAGS="-D_POSIX_SOURCE -D_SOCKET_SOURCE $CPPFLAGS"
+-         LIBS="-lsocket -lsvipc $LIBS";;
+-sco*)    CFLAGS="$CFLAGS -b elf"
+-         LIBS="-lsocket -lnsl $LIBS";;
+-*)       CFLAGS=${CFLAGS-"-O"};;
+-esac
+-CXXFLAGS=${CXXFLAGS-"$CFLAGS"}
+-
+-dnl The default compiler is cc (NOT gcc), the default CFLAGS is as specified
+-dnl above, NOT what is set by AC_PROG_CC, as it won't set optimization flags.
+-dnl We still call AC_PROG_CC so that we get the other side-effects.
+-AC_CHECK_PROG(CC, cc, cc)
+-AC_CHECK_PROG(CC, gcc, gcc)
++AC_ARG_PROGRAM
+ AC_PROG_CC
  
+-dnl Optional C++ API..
+-dnl
+-dnl XXX
+-dnl Versions of GCC up to 2.8.0 required -fhandle-exceptions, but it is
+-dnl the default in versions 2.8.0 and after.
+-AC_MSG_CHECKING(if --enable-cxx option specified)
+-AC_ARG_ENABLE(cxx,
+-      [  --enable-cxx            Provide C++ interfaces.],
+-      [db_cv_cxx="$enable_cxx"], [db_cv_cxx="no"])
+-AC_MSG_RESULT($db_cv_cxx)
+-if test "$db_cv_cxx" = "yes"; then
+-      AC_PROG_CXX
+-
+-      if test "$GXX" = "yes"; then
+-              CXXFLAGS="-fhandle-exceptions $CXXFLAGS"
+-      fi
+-
+-      LIBOBJS="$LIBOBJS \$(COBJS)"
+-fi
+-
  dnl There are additional libraries we need for some compiler/architecture
-@@ -88,7 +88,7 @@
+ dnl combinations.
+ AC_SUBST(LIBS)
+@@ -88,7 +33,7 @@
        [db_cv_compat185="$enable_compat185"], [db_cv_compat185="no"])
  AC_MSG_RESULT($db_cv_compat185)
  if test "$db_cv_compat185" = "yes"; then
@@ -26,7 +86,7 @@
  fi
  
  dnl Optional utilities.
-@@ -137,7 +137,15 @@
+@@ -137,7 +82,15 @@
  AC_CHECK_TYPE(ssize_t, int)
  AC_C_BIGENDIAN
  AC_C_CONST
  AC_HEADER_STAT
  AC_TYPE_MODE_T
  AC_TYPE_OFF_T
-@@ -163,7 +171,9 @@
+@@ -163,7 +116,9 @@
  
  dnl A/UX has a broken getopt(3).
  case "$host_os" in
  esac
  
  dnl Checks for system functions for which we don't have replacements.
-@@ -453,7 +463,8 @@
+@@ -453,7 +408,8 @@
        AC_DEFINE(HAVE_ASSEM_UTS4_CC)
        mutex_align="sizeof(int)"
        spin_line1="typedef int tsl_t;"
  x86/gcc)
        AC_DEFINE(HAVE_ASSEM_X86_GCC)
        mutex_align="1"
-@@ -647,15 +658,15 @@
+@@ -647,15 +603,15 @@
  fi
  AC_MSG_RESULT($gtk_ok)
  
  AM_CONDITIONAL(EDB_GTK_ED, test "$gtk_ok" = yes)
  
 -AC_OUTPUT([
-+AC_CONFIG_FILES([
++AC_OUTPUT([
  Makefile
  src/Makefile
  tools/Makefile
-@@ -663,7 +674,8 @@
- src/db.h
- src/db_int.h
- src/db_185.h
+@@ -665,7 +621,6 @@
+ src/edb_int.h
+ src/edb_185.h
+ debian/Makefile
 -edb-config],
 -[
-+edb-config])
-+AC_CONFIG_COMMANDS([default],[[
- chmod +x edb-config
+-chmod +x edb-config
 -])
-+]],[[]])
-+AC_OUTPUT
++edb-config])
++AC_CONFIG_COMMANDS([default],
++      [chmod +x edb-config])
This page took 0.079408 seconds and 4 git commands to generate.