]> git.pld-linux.org Git - packages/ecryptfs-utils.git/blob - ecryptfs-utils.spec
b948b581dfe1746ea204ad07c592fa468b2394e3
[packages/ecryptfs-utils.git] / ecryptfs-utils.spec
1 #
2 # Conditional build:
3 %bcond_with     gui     # GTK+ GUI components (non-existing as of 104)
4 #
5 Summary:        The eCryptfs mount helper and support libraries
6 Summary(pl.UTF-8):      Narzędzie pomocnicze i biblioteki do montowania eCryptfs
7 Name:           ecryptfs-utils
8 Version:        106
9 Release:        1
10 License:        GPL v2+
11 Group:          Base
12 #Source0Download: https://launchpad.net/ecryptfs/+download
13 Source0:        https://launchpad.net/ecryptfs/trunk/%{version}/+download/%{name}_%{version}.orig.tar.gz
14 # Source0-md5:  bff8052636f6be642f15c6be45a14ea3
15 Patch0:         %{name}-sh.patch
16 Patch1:         %{name}-83-fixsalt.patch
17 Patch2:         %{name}-83-splitnss.patch
18 Patch3:         %{name}-84-fixsigness.patch
19 URL:            http://ecryptfs.org/
20 BuildRequires:  autoconf >= 2.59
21 BuildRequires:  automake
22 BuildRequires:  gettext-tools
23 BuildRequires:  glib2-devel >= 2.0
24 BuildRequires:  gpgme-devel
25 %{?with_gui:BuildRequires:      gtk+2-devel >= 2.0}
26 BuildRequires:  intltool >= 0.41.0
27 BuildRequires:  keyutils-devel >= 1.0
28 BuildRequires:  libtool
29 BuildRequires:  nss-devel >= 3
30 BuildRequires:  openssl-devel >= 0.9.7
31 BuildRequires:  pam-devel
32 BuildRequires:  perl-tools-pod
33 BuildRequires:  pkcs11-helper-devel >= 1.04
34 BuildRequires:  pkgconfig
35 BuildRequires:  python-devel >= 1:2.5
36 BuildRequires:  python-modules >= 1:2.5
37 BuildRequires:  rpm-pythonprov
38 BuildRequires:  rpmbuild(macros) >= 1.219
39 BuildRequires:  swig >= 1.3.31
40 BuildRequires:  swig-python >= 1.3.31
41 BuildRequires:  trousers-devel
42 Requires:       uname(release) >= 2.6.19
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 # python module
46 %define         skip_post_check_so      _libecryptfs.so.0.0.0
47
48 %description
49 eCryptfs is a stacked cryptographic filesystem that ships in Linux
50 kernel versions 2.6.19 and above. This package provides the mount
51 helper and supporting libraries to perform key management and mount
52 functions.
53
54 Install ecryptfs-utils if you would like to mount eCryptfs.
55
56 %description -l pl.UTF-8
57 eCryptfs to stakowalny kryptograficzny system plików dostępny w jądrze
58 Linuksa od wersji 2.6.19. Ten pakiet udostępnia narzędzie pomocnicze
59 dla programu mount oraz wspierające je biblioteki wykonujące
60 zarządzanie kluczami i funkcje związane z montowaniem.
61
62 Pakiet ecryptfs-utils należy zainstalować, aby montować eCryptfs.
63
64 %package devel
65 Summary:        The eCryptfs userspace development package
66 Summary(pl.UTF-8):      Pakiet programistyczny przestrzeni użytkownika dla eCryptfs
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69 Requires:       keyutils-devel >= 1.0
70 Requires:       nss-devel >= 3
71
72 %description devel
73 Userspace development files for eCryptfs.
74
75 %description devel -l pl.UTF-8
76 Pliki programistyczne przestrzeni użytkownika dla eCryptfs.
77
78 %package static
79 Summary:        Static eCryptfs library
80 Summary(pl.UTF-8):      Statyczna biblioteka eCryptfs
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{version}-%{release}
83
84 %description static
85 Static eCryptfs library.
86
87 %description static -l pl.UTF-8
88 Statyczna biblioteka eCryptfs.
89
90 %package -n pam-pam_ecryptfs
91 Summary:        eCryptfs PAM module
92 Summary(pl.UTF-8):      Moduł PAM eCryptfs
93 Group:          Base
94 Requires:       %{name} = %{version}-%{release}
95
96 %description -n pam-pam_ecryptfs
97 eCryptfs PAM module.
98
99 %description -n pam-pam_ecryptfs -l pl.UTF-8
100 Moduł PAM eCryptfs.
101
102 %package -n python-ecryptfs
103 Summary:        Python bindings for the eCryptfs utils
104 Summary(pl.UTF-8):      Wiązania Pythona do narzędzi eCryptfs
105 Group:          Libraries/Python
106 Requires:       %{name} = %{version}-%{release}
107 Obsoletes:      ecryptfs-utils-python
108
109 %description -n python-ecryptfs
110 This package contains a module that permits applications written in
111 the Python programming language to use the interface supplied by the
112 ecryptfs-utils library.
113
114 %description -n python-ecryptfs -l pl.UTF-8
115 Ten pakiet zawiera moduł pozwalający aplikacjom napisanym w Pythonie
116 na korzystanie z interfejsu dostarczanego przez bibliotekę
117 ecryptfs-utils.
118
119 %prep
120 %setup -q
121 %patch0 -p1
122 %patch1 -p1
123 %patch2 -p1
124 %patch3 -p1
125
126 %build
127 %{__libtoolize}
128 %{__aclocal} -I m4
129 %{__autoconf}
130 %{__autoheader}
131 %{__automake}
132 %configure \
133         --enable-gpg \
134         %{?with_gui:--enable-gui} \
135         --enable-nss \
136         --enable-openssl \
137         --enable-pam \
138         --enable-pkcs11-helper \
139         --enable-tspi \
140         --enable-static
141
142 %{__make}
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146
147 %{__make} -j1 install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/%{name}/_libecryptfs.{la,a}
151 %py_postclean
152
153 %find_lang %{name}
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %pre
159 %groupadd -g 260 ecryptfs
160
161 %postun
162 /sbin/ldconfig
163 if [ "$1" = "0" ]; then
164         %groupremove ecryptfs
165 fi
166
167 %post   -p /sbin/ldconfig
168
169 %files -f %{name}.lang
170 %defattr(644,root,root,755)
171 %doc AUTHORS ChangeLog NEWS README THANKS doc/{ecryptfs-faq.html,ecryptfs-pkcs11-helper-doc.txt}
172 %attr(755,root,root) /sbin/mount.ecryptfs
173 %attr(4754,root,ecryptfs) /sbin/mount.ecryptfs_private
174 %attr(755,root,root) /sbin/umount.ecryptfs_private
175 %attr(755,root,root) /sbin/umount.ecryptfs
176 %attr(755,root,root) %{_bindir}/ecryptfs-*
177 %attr(755,root,root) %{_bindir}/ecryptfsd
178 %attr(755,root,root) %{_libdir}/libecryptfs.so.*.*.*
179 %attr(755,root,root) %ghost %{_libdir}/libecryptfs.so.1
180 %dir %{_libdir}/ecryptfs
181 %attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_gpg.so
182 %attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_openssl.so
183 %attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_passphrase.so
184 %attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_pkcs11_helper.so
185 %attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_tspi.so
186 %{_datadir}/%{name}
187 %{_mandir}/man1/ecryptfs-*.1*
188 %{_mandir}/man1/mount.ecryptfs_private.1*
189 %{_mandir}/man1/umount.ecryptfs_private.1*
190 %{_mandir}/man7/ecryptfs.7*
191 %{_mandir}/man8/ecryptfs-*.8*
192 %{_mandir}/man8/ecryptfsd.8*
193 %{_mandir}/man8/mount.ecryptfs.8*
194 %{_mandir}/man8/umount.ecryptfs.8*
195
196 %files devel
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_libdir}/libecryptfs.so
199 %{_libdir}/libecryptfs.la
200 %{_includedir}/ecryptfs.h
201 %{_pkgconfigdir}/libecryptfs.pc
202
203 %files static
204 %defattr(644,root,root,755)
205 %{_libdir}/libecryptfs.a
206
207 %files -n pam-pam_ecryptfs
208 %defattr(644,root,root,755)
209 %attr(755,root,root) /%{_lib}/security/pam_ecryptfs.so
210 %{_mandir}/man8/pam_ecryptfs.8*
211
212 %files -n python-ecryptfs
213 %defattr(644,root,root,755)
214 %dir %{py_sitedir}/%{name}
215 %attr(755,root,root) %{py_sitedir}/%{name}/_libecryptfs.so*
216 %dir %{py_sitescriptdir}/%{name}
217 %{py_sitescriptdir}/%{name}/*.py[co]
This page took 0.058643 seconds and 2 git commands to generate.