]> git.pld-linux.org Git - packages/eclipse.git/blob - eclipse.spec
- added descriptions (from URL), use standard glob exclusion
[packages/eclipse.git] / eclipse.spec
1 # TODO:
2 #       - conditional build with motif
3 #       - .so binaries should be removed and linked with PLD one...
4 #         (we really need them here?)
5
6 %define         _buildid        200307181617
7 %define         _ver            3.0
8 %define         _milestone      M2
9 %define         _buildname      %{_ver}%{_milestone}
10
11 Summary:        eclipse - an open extensible IDE
12 Summary(pl):    eclipse - otwarte, rozszerzalne ¶rodowisko programistyczne
13 Name:           eclipse
14 Version:        %{_ver}
15 Release:        0.%{_milestone}.1
16 License:        Common Public Licence
17 Group:          Development/Tools
18 Source0:        http://www.eclipse.ps.pl/downloads/drops/S-%{_buildname}-%{_buildid}/eclipse-sourceBuild-srcIncluded-%{_buildname}.zip
19 # Source0-md5:  12c9b31cf8605e58cf857715ac6ff5c3
20 Source1:        %{name}.desktop
21 URL:            http://www.eclipse.org/
22 BuildRequires:  jdk
23 BuildRequires:  unzip
24 BuildRequires:  jakarta-ant >= 1.4
25 BuildRequires:  gtk+2-devel
26 Requires:       jdk
27 Requires:       jakarta-ant
28 Obsoletes:      eclipse-SDK
29 #BuildArch:     noarch
30 ExclusiveArch:  %{ix86}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _javalibdir     /usr/share/java
34
35 %description
36 Eclipse is a kind of universal tool platform - an open extensible IDE
37 for anything and nothing in particular.
38
39 %description -l pl
40 Eclipse to rodzaj uniwersalnej platformy narzêdziowej - otwarte,
41 rozszerzalne IDE (zintegrowane ¶rodowisko programistyczne) do
42 wszystkiego i niczego w szczególno¶ci.
43
44 %prep
45 %setup -q -c
46
47 %build
48 JAVA_HOME=/usr/lib/java
49 export JAVA_HOME
50 ./build -os linux -ws gtk -arch x86 -target compile
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_bindir},%{_datadir}/%{name}}
55
56 ./build -os linux -ws gtk -arch x86 -target install
57
58 unzip result/linux-gtk-x86-sdk.zip -d $RPM_BUILD_ROOT%{_datadir}
59 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
60
61 #wrapper
62 install -d $RPM_BUILD_ROOT%{_bindir}
63 cat > $RPM_BUILD_ROOT%{_bindir}/eclipse << EOF
64 #!/bin/sh
65 exec %{_datadir}/%{name}/eclipse \$*
66 EOF
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %attr(755,root,root) %{_bindir}/eclipse
74 %attr(755,root,root) %{_datadir}/%{name}/eclipse
75 %{_desktopdir}/eclipse.desktop
76 %dir %{_datadir}/%{name}
77 %{_datadir}/%{name}/.[!.]*
78 %{_datadir}/%{name}/[!e]*
This page took 0.113633 seconds and 4 git commands to generate.