]> git.pld-linux.org Git - packages/eclipse.git/blob - eclipse.spec
- up to 3.0M2
[packages/eclipse.git] / eclipse.spec
1
2 # TODO:
3 #       - conditional build with motiff
4 #       - .so binaries should be removed and linked with PLD one...
5 #         (we really need them here?)
6
7 %define         _buildid        200307181617
8
9 %define         _ver            3.0
10 %define         _milestone      M2
11 %define         _buildname      %{_ver}%{_milestone}
12
13 Summary:        eclipse
14 Summary(pl):    eclipse
15 Name:           eclipse
16 Version:        %{_ver}
17 Release:        0.%{_milestone}.1
18 License:        Apache
19 Group:          Development/Languages/Java
20 Source0:        http://www.eclipse.ps.pl/downloads/drops/S-%{_buildname}-%{_buildid}/eclipse-sourceBuild-srcIncluded-%{_buildname}.zip
21 # Source0-md5:  12c9b31cf8605e58cf857715ac6ff5c3
22 URL:            http://www.eclipse.org/
23 Obsoletes:      eclipse-SDK
24 BuildRequires:  jdk
25 BuildRequires:  unzip
26 BuildRequires:  jakarta-ant >= 1.4
27 BuildRequires:  gtk+2-devel
28 Requires:       jdk
29 #BuildArch:     noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _javalibdir     /usr/share/java
33
34 %description
35
36 %description -l pl
37
38 %prep
39 %setup -q -c -n %{name}-%{version}
40
41
42 %build
43 JAVA_HOME=/usr/lib/java
44 export JAVA_HOME
45 ./build -os linux -ws gtk -arch x86 -target compile
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 ./build -os linux -ws gtk -arch x86 -target install
51
52 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
53 unzip result/linux-gtk-x86-sdk.zip -d $RPM_BUILD_ROOT%{_datadir}
54
55
56 # desktop file
57 install -d $RPM_BUILD_ROOT%{_desktopdir}
58 cat > $RPM_BUILD_ROOT%{_desktopdir}/eclipse.desktop << EOF
59 [Desktop Entry]
60 Name=Eclipse
61 Comment=Eclipse
62 Comment[pl]=Eclipse
63 Exec=eclipse
64 Icon=%{_datadir}/%{name}/icon.xpm
65 Terminal=false
66 MultipleArgs=false
67 Type=Application
68 Categories=Application;Development;
69 # vi: encoding=utf-8
70 EOF
71
72 #wrapper
73 install -d $RPM_BUILD_ROOT%{_bindir}
74 cat > $RPM_BUILD_ROOT%{_bindir}/eclipse << EOF
75 #!/bin/sh
76 %{_datadir}/%{name}/eclipse 
77 EOF
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %attr(755,root,root) %{_bindir}/eclipse
85 %attr(755,root,root) %{_datadir}/%{name}/eclipse
86 %{_desktopdir}/eclipse.desktop
87
88 %{_datadir}/%{name}
This page took 0.136895 seconds and 4 git commands to generate.