]> git.pld-linux.org Git - packages/eclipse.git/blob - eclipse.spec
- BR: fixed.
[packages/eclipse.git] / eclipse.spec
1 # TODO:
2 #       - conditional build with motif
3 #       - .so binaries should be removed and linked with PLD one...
4 #         (we really need them here?)
5
6 %define         _buildid        200406251208
7 %define         _ver            3.0
8 %define         _buildname      %{_ver}
9
10 Summary:        eclipse - an open extensible IDE
11 Summary(pl):    eclipse - otwarte, rozszerzalne ¶rodowisko programistyczne
12 Name:           eclipse
13 Version:        %{_ver}
14 Release:        1
15 License:        Common Public Licence
16 Group:          Development/Tools
17 Source0:        http://download2.eclipse.org/downloads/drops/R-%{_buildname}-%{_buildid}/eclipse-sourceBuild-srcIncluded-%{_buildname}.zip
18 # Source0-md5:  962a41fe062f0ddc809ca956687c7e01
19 Source1:        %{name}.desktop
20 URL:            http://www.eclipse.org/
21 BuildRequires:  jakarta-ant >= 1.6.1
22 BuildRequires:  jdk >= 1.4
23 BuildRequires:  gtk+2-devel
24 BuildRequires:  unzip
25 BuildRequires:  zip
26 Requires:       jakarta-ant
27 Requires:       jdk
28 Obsoletes:      eclipse-SDK
29 ExclusiveArch:  %{ix86} ppc amd64
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _javalibdir     /usr/share/java
33
34 %description
35 Eclipse is a kind of universal tool platform - an open extensible IDE
36 for anything and nothing in particular.
37
38 %description -l pl
39 Eclipse to rodzaj uniwersalnej platformy narzêdziowej - otwarte,
40 rozszerzalne IDE (zintegrowane ¶rodowisko programistyczne) do
41 wszystkiego i niczego w szczególno¶ci.
42
43 %prep
44 %setup -q -c
45
46 %build
47 JAVA_HOME=/usr/lib/java
48 export JAVA_HOME
49 ./build -os linux -ws gtk -arch x86 -target compile
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_bindir},%{_datadir}/%{name}}
54
55 ./build -os linux -ws gtk -arch x86 -target install
56
57 unzip result/linux-gtk-x86-sdk.zip -d $RPM_BUILD_ROOT%{_datadir}
58 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
59
60 #wrapper
61 install -d $RPM_BUILD_ROOT%{_bindir}
62 cat > $RPM_BUILD_ROOT%{_bindir}/eclipse << EOF
63 #!/bin/sh
64 exec %{_datadir}/%{name}/eclipse \$*
65 EOF
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %attr(755,root,root) %{_bindir}/eclipse
73 %attr(755,root,root) %{_datadir}/%{name}/eclipse
74 %{_desktopdir}/eclipse.desktop
75 %dir %{_datadir}/%{name}
76 %{_datadir}/%{name}/.[!.]*
77 %{_datadir}/%{name}/[!e]*
This page took 0.292441 seconds and 3 git commands to generate.