]> git.pld-linux.org Git - packages/eclipse.git/blob - eclipse.spec
- minor build fix, TODO updated.
[packages/eclipse.git] / eclipse.spec
1 # TODO:
2 #       - conditional build with motif (really needed?)
3 #       http://www.eclipse.ps.pl/downloads/drops/
4 #               R-3.0-200406251208/srcIncludedBuildInstructions.html#build_platforms
5 #
6 #       linux   gtk     x86
7 #       linux   gtk     ppc
8 #       linux   gtk     amd64
9 #       linux   motif   x86
10 #
11 #       - .so binaries should be removed and linked with PLD one...
12 #         (we really need them here?)
13 #
14 %define         _buildid        200406251208
15 %define         _ver            3.0
16 %define         _buildname      %{_ver}
17 #
18 Summary:        eclipse - an open extensible IDE
19 Summary(pl):    eclipse - otwarte, rozszerzalne ¶rodowisko programistyczne
20 Name:           eclipse
21 Version:        %{_ver}
22 Release:        1
23 License:        Common Public Licence
24 Group:          Development/Tools
25 Source0:        http://download2.eclipse.org/downloads/drops/R-%{_buildname}-%{_buildid}/eclipse-sourceBuild-srcIncluded-%{_buildname}.zip
26 # Source0-md5:  962a41fe062f0ddc809ca956687c7e01
27 Source1:        %{name}.desktop
28 URL:            http://www.eclipse.org/
29 BuildRequires:  jakarta-ant >= 1.6.1
30 BuildRequires:  jdk >= 1.4
31 BuildRequires:  gtk+2-devel
32 BuildRequires:  unzip
33 BuildRequires:  zip
34 Requires:       jakarta-ant
35 Requires:       jdk
36 Obsoletes:      eclipse-SDK
37 ExclusiveArch:  %{ix86} ppc amd64
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _javalibdir     /usr/share/java
41 %define         _eclipse_arch   %(echo %{_target_cpu} | sed 's/i.86/x86/;s/athlon/x86/;s/pentium./x86/')
42
43 %description
44 Eclipse is a kind of universal tool platform - an open extensible IDE
45 for anything and nothing in particular.
46
47 %description -l pl
48 Eclipse to rodzaj uniwersalnej platformy narzêdziowej - otwarte,
49 rozszerzalne IDE (zintegrowane ¶rodowisko programistyczne) do
50 wszystkiego i niczego w szczególno¶ci.
51
52 %prep
53 %setup -q -c
54
55 %build
56 JAVA_HOME=/usr/lib/java
57 export JAVA_HOME
58 ./build -os linux -ws gtk -arch %{_eclipse_arch} -target compile
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_bindir},%{_datadir}/%{name}}
63
64 ./build -os linux -ws gtk -arch %{_eclipse_arch} -target install
65
66 unzip result/linux-gtk-%{_eclipse_arch}-sdk.zip -d $RPM_BUILD_ROOT%{_datadir}
67 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
68
69 #wrapper
70 install -d $RPM_BUILD_ROOT%{_bindir}
71 cat > $RPM_BUILD_ROOT%{_bindir}/eclipse << EOF
72 #!/bin/sh
73 exec %{_datadir}/%{name}/eclipse \$*
74 EOF
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %attr(755,root,root) %{_bindir}/eclipse
82 %attr(755,root,root) %{_datadir}/%{name}/eclipse
83 %{_desktopdir}/eclipse.desktop
84 %dir %{_datadir}/%{name}
85 %{_datadir}/%{name}/.[!.]*
86 %{_datadir}/%{name}/[!e]*
This page took 0.086036 seconds and 3 git commands to generate.