]> git.pld-linux.org Git - packages/eclipse-plugin-google.git/blob - eclipse-plugin-google.spec
e0cd07519a775d1ce0be1979660c62dc821768fa
[packages/eclipse-plugin-google.git] / eclipse-plugin-google.spec
1 # TODO:
2 # - com.google.appengine.eclipse.sdkbundle_1.2.1.v200905131156/
3 # - com.google.gwt.eclipse.sdkbundle.linux_1.6.4.v200904062254 is x86 centric (build from source?)
4 %define         pluginver       1.0.1
5 %define         appengver       1.2.1
6 %define         gwtver          1.6.4
7 %include        /usr/lib/rpm/macros.java
8 Summary:        Google Plugin for Eclipse
9 Name:           eclipse-plugin-google
10 Version:        %{pluginver}
11 Release:        0.4
12 License:        Apache License, v2.0
13 Group:          Development/Tools
14 URL:            http://code.google.com/eclipse/
15 # http://code.google.com/eclipse/docs/install-from-zip.html
16 Source0:        http://dl.google.com/eclipse/plugin/3.3/zips/gpe-e33-latest.zip
17 # Source0-md5:  955d207982a0ec954b1c067019c33694
18 Source1:        http://dl.google.com/eclipse/plugin/3.3/features/com.google.appengine.eclipse.sdkbundle.e33.feature_%{appengver}.v200905131156.jar
19 # Source1-md5:  44dbeb0e33c1458658b1626b86efd677
20 Source2:        http://dl.google.com/eclipse/plugin/3.3/plugins/com.google.appengine.eclipse.sdkbundle_%{appengver}.v200905131156.jar
21 # Source2-md5:  ebc7c16b7291830497a24312980919c6
22 Source3:        http://dl.google.com/eclipse/plugin/3.3/features/com.google.gwt.eclipse.sdkbundle.e33.feature_%{gwtver}.v200904062254.jar
23 # Source3-md5:  8de9b4a53690e36e4af4fdd0e02f1528
24 Source4:        http://dl.google.com/eclipse/plugin/3.3/plugins/com.google.gwt.eclipse.sdkbundle.linux_%{gwtver}.v200904062254.jar
25 # Source4-md5:  9fe86bcde62ab891569b96fdb6fc0752
26 BuildRequires:  rpm-javaprov
27 Requires:       eclipse >= 3.3
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         eclipsedir      %{_datadir}/eclipse
32
33 %description
34 The Google Plugin for Eclipse is the fastest way to start developing
35 Google Web Toolkit and App Engine applications, allowing you to go
36 from installing the plugin to deploying an Ajax "Hello World" in a
37 matter of minutes. Simply install the plugin and get started. If you
38 don't have the GWT and App Engine SDKs installed, the plugin can take
39 care of that for you.
40
41 The plugin currently supports Google App Engine and Google Web Toolkit
42 development.
43
44 %package appengine
45 Summary:        Google App Engine for Java SDK Bundle for Eclipse
46 Version:        %{appengver}
47 Group:          Development/Tools
48 Requires:       %{name} = %{pluginver}-%{release}
49
50 %description appengine
51 Google App Engine for Java SDK Bundle for Eclipse.
52
53 %package gwt
54 Summary:        Google Web Toolkit SDK Bundle for Eclipse
55 Version:        %{gwtver}
56 Group:          Development/Tools
57 Requires:       %{name} = %{pluginver}-%{release}
58
59 %description gwt
60 Google Web Toolkit SDK Bundle for Eclipse.
61
62 %prep
63 %setup -qc
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT%{eclipsedir}/{features,plugins}
68 cp -a features/* $RPM_BUILD_ROOT%{eclipsedir}/features
69 cp -a plugins/* $RPM_BUILD_ROOT%{eclipsedir}/plugins
70
71 # appengine sdkbundle
72 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{eclipsedir}/features
73 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{eclipsedir}/plugins
74 # gwt sdkbundle
75 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{eclipsedir}/features
76 cp -a %{SOURCE4} $RPM_BUILD_ROOT%{eclipsedir}/plugins
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %{eclipsedir}/features/com.google.gdt.eclipse.suite.e33.feature_*
84 %{eclipsedir}/plugins/com.google.appengine.eclipse.core_*.jar
85 %{eclipsedir}/plugins/com.google.gdt.eclipse.core_*.jar
86 %{eclipsedir}/plugins/com.google.gdt.eclipse.suite_*.jar
87 %{eclipsedir}/plugins/com.google.gwt.eclipse.core_*.jar
88
89 %files appengine
90 %defattr(644,root,root,755)
91 %{eclipsedir}/features/com.google.appengine.eclipse.sdkbundle.e33.feature_*.jar
92 %{eclipsedir}/plugins/com.google.appengine.eclipse.sdkbundle_*.jar
93
94 %files gwt
95 %defattr(644,root,root,755)
96 %{eclipsedir}/features/com.google.gwt.eclipse.sdkbundle.e33.feature_*.jar
97 # XXX: ix86 mozilla inside
98 %{eclipsedir}/plugins/com.google.gwt.eclipse.sdkbundle.linux_*.jar
This page took 0.085254 seconds and 2 git commands to generate.