]> git.pld-linux.org Git - packages/ecasound.git/blob - ecasound.spec
- release 3
[packages/ecasound.git] / ecasound.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # without ALSA support (implies without JACK)
4 %bcond_without  jack            # without JACK support
5 %bcond_without  ruby            # without ruby support
6 %bcond_with     arts            # with aRts support
7 #
8 Summary:        Software package for multitrack audio processing
9 Summary(pl.UTF-8):      Oprogramowanie do wielościeżkowego przetwarzania dźwięku
10 Name:           ecasound
11 Version:        2.6.0
12 Release:        3
13 License:        GPL v2+
14 Group:          Applications/Sound
15 Source0:        http://ecasound.seul.org/download/%{name}-%{version}.tar.gz
16 # Source0-md5:  41f9445b9a9c0cde141831cb53d1ef8f
17 Patch0:         %{name}-link.patch
18 Patch1:         %{name}-acam.patch
19 URL:            http://ecasound.seul.org/
20 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9.0}
21 %{?with_arts:BuildRequires:     arts-devel}
22 BuildRequires:  autoconf >= 2.50
23 BuildRequires:  automake >= 1.6.1
24 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
25 BuildRequires:  ladspa-devel
26 BuildRequires:  libsamplerate-devel
27 BuildRequires:  libsndfile-devel >= 1.0.12
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libtool >= 2:1.4d
30 BuildRequires:  python-devel >= 2.2
31 BuildRequires:  python-modules >= 2.2
32 BuildRequires:  readline-devel >= 5.0
33 BuildRequires:  rpm-pythonprov
34 %if %{with ruby}
35 BuildRequires:  rpmbuild(macros) >= 1.277
36 BuildRequires:  ruby-devel
37 %endif
38 Obsoletes:      libecasound
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Ecasound is a software package designed for multitrack audio
43 processing. It can be used for simple tasks like audio playback,
44 recording and format conversions, as well as for multitrack effect
45 processing, mixing, recording and signal recycling. Ecasound supports
46 a wide range of audio inputs, outputs and effect algorithms. Several
47 open-source audio packages, like for instance ALSA, OSS, mpg123, lame
48 and MikMod, are directly supported. One of the advantages of
49 ecasound's chain-based design is that effects can easily be combined
50 both in series and in parallel. Oscillators and MIDI-CCs can be used
51 for controlling effect parameters. Included user-interfaces are
52 ecasound - a versatile console mode interface, ecawave - a Qt-based
53 X-interface and various command-line utils suitable for batch
54 processing.
55
56 %description -l pl.UTF-8
57 Ecasound jest programem do wielościeżkowej edycji dźwięku, który może
58 być używany tak do prostych zadań typu odtwarzanie i nagrywanie muzyki
59 czy też konwersji pomiędzy formatami plików muzycznych jak i do
60 wielościeżkowego nakładania efektów, miksowania (przenikania,
61 wyciszania), nagrywania i odzyskiwania (w domyśle odszumiania lub
62 wyrzucania zniekształceń) sygnału.
63
64 Ecasound wspiera szeroką gamę źródeł i wyjść dźwięku oraz algorytmów
65 do jego przetwarzania. Ecasound wspiera wiele wolnych (open source)
66 projektów, takich jak ALSA, OSS, mpg123, lame czy też MikMod. Jedną z
67 zalet programu ecasound jest możliwość łańcuchowego (szeregowego) lub
68 równoległego łączenia efektów, które mogą być kontrolowane poprzez
69 oscylatory lub MIDI-CC. Pakiet ten zawiera tekstowy interfejs
70 użytkownika oraz kilka innych narzędzi nadających się do przetwarzania
71 wsadowego. Dostępny jest także graficzny, oparty na Qt interfejs
72 użytkownika - ecawave.
73
74 %package devel
75 Summary:        Header files for ecasound libraries
76 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek ecasound
77 Group:          Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79 %{?with_alsa:Requires:  alsa-lib-devel}
80 %{?with_arts:Requires:  arts-devel}
81 %{?with_jack:Requires:  jack-audio-connection-kit-devel}
82 Requires:       libsamplerate-devel
83 Requires:       libsndfile-devel
84 Requires:       libstdc++-devel
85 Obsoletes:      libecasound-devel
86
87 %description devel
88 Header files for ecasound libraries.
89
90 %description devel -l pl.UTF-8
91 Pliki nagłówkowe bibliotek ecasound.
92
93 %package static
94 Summary:        Static ecasound libraries
95 Summary(pl.UTF-8):      Statyczne biblioteki ecasound
96 Group:          Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98 Obsoletes:      libecasound-static
99
100 %description static
101 Static ecasound libraries.
102
103 %description static -l pl.UTF-8
104 Statyczne biblioteki ecasound.
105
106 %package -n python-%{name}
107 Summary:        Python module for Ecasound
108 Summary(pl.UTF-8):      Moduł języka Python dla programu ecasound
109 Group:          Libraries/Python
110 Requires:       %{name} = %{version}-%{release}
111 %pyrequires_eq  python-modules
112
113 %description -n python-%{name}
114 Python module for Ecasound.
115
116 %description -n python-%{name} -l pl.UTF-8
117 Moduł języka Python dla programu ecasound.
118
119 %package -n ruby-%{name}
120 Summary:        Ruby module for Ecasound
121 Summary(pl.UTF-8):      Moduł języka Ruby dla programu ecasound
122 Group:          Libraries
123 Requires:       %{name} = %{version}-%{release}
124 %{?ruby_mod_ver_requires_eq}
125
126 %description -n ruby-%{name}
127 Ruby module for Ecasound.
128
129 %description -n ruby-%{name} -l pl.UTF-8
130 Moduł języka Ruby dla programu ecasound.
131
132 %prep
133 %setup -q
134 %patch0 -p1
135 %patch1 -p1
136
137 %build
138 %{__libtoolize}
139 %{__aclocal}
140 %{__autoconf}
141 %{__automake}
142 CXXFLAGS="%{rpmcflags} -D_REENTRANT %{!?debug:-DNDEBUG} -I/usr/include/ncurses"
143 # disable audiofile - ecasound has native support for wav and raw formats
144 # disable oss       - ecasound works nicely with alsa oss emulation;
145 #                     in case of alsa building conditional, the oss should
146 #                     be enabled
147 # disable arts      - 'not really useful' as said by ecasound author
148 %configure \
149         %{!?with_alsa:--disable-alsa} \
150         %{!?with_arts:--disable-arts} \
151         --disable-audiofile \
152         %{!?with_jack:--disable-jack} \
153         %{?with_alsa:--disable-oss} \
154         --enable-samplerate \
155         --enable-shared \
156         --enable-sys-readline \
157         --enable-pyecasound \
158         --with-largefile \
159         --with-python-includes=%{py_incdir} \
160         --with-python-modules=%{py_libdir}
161
162 %{__make}
163
164 %install
165 rm -rf $RPM_BUILD_ROOT
166 install -d $RPM_BUILD_ROOT%{py_sitedir}
167
168 %{__make} install \
169         DESTDIR=$RPM_BUILD_ROOT \
170         mandir=%{_mandir}
171
172 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
173 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
174 %py_postclean
175 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %post   -p /sbin/ldconfig
181 %postun -p /sbin/ldconfig
182
183 %files
184 %defattr(644,root,root,755)
185 %doc BUGS NEWS README TODO
186 %attr(755,root,root) %{_bindir}/eca*
187 %attr(755,root,root) %{_libdir}/libecasound.so.*.*.*
188 %attr(755,root,root) %ghost %{_libdir}/libecasound.so.20
189 %attr(755,root,root) %{_libdir}/libecasoundc.so.*.*.*
190 %attr(755,root,root) %ghost %{_libdir}/libecasoundc.so.1
191 %attr(755,root,root) %{_libdir}/libkvutils.so.*.*.*
192 %attr(755,root,root) %ghost %{_libdir}/libkvutils.so.4
193 %{_datadir}/ecasound
194 %{_mandir}/man1/eca*.1*
195 %{_mandir}/man5/ecasoundrc.5*
196
197 %files devel
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_bindir}/libecasound-config
200 %attr(755,root,root) %{_bindir}/libecasoundc-config
201 %attr(755,root,root) %{_libdir}/libecasound.so
202 %attr(755,root,root) %{_libdir}/libecasoundc.so
203 %attr(755,root,root) %{_libdir}/libkvutils.so
204 %{_libdir}/libecasound.la
205 %{_libdir}/libecasoundc.la
206 %{_libdir}/libkvutils.la
207 %{_includedir}/kvutils
208 %{_includedir}/libecasound
209 %{_includedir}/libecasoundc
210
211 %files static
212 %defattr(644,root,root,755)
213 %{_libdir}/libecasound.a
214 %{_libdir}/libecasoundc.a
215 %{_libdir}/libkvutils.a
216
217 %files -n python-%{name}
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{py_sitedir}/pyecasound.so
220 %{py_sitedir}/ecacontrol.py[co]
221 %{py_sitedir}/eci.py[co]
222 %{py_sitedir}/pyeca.py[co]
223
224 %if %{with ruby}
225 %files -n ruby-%{name}
226 %defattr(644,root,root,755)
227 %{ruby_sitelibdir}/ecasound.rb
228 %endif
This page took 0.103742 seconds and 3 git commands to generate.