]> git.pld-linux.org Git - packages/ecasound.git/blob - ecasound.spec
- updated to 2.6.0
[packages/ecasound.git] / ecasound.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # without ALSA support (implies without JACK)
4 %bcond_without  jack            # without JACK support
5 %bcond_without  ruby            # without ruby support
6 %bcond_with     arts            # with aRts support
7 #
8 Summary:        Software package for multitrack audio processing
9 Summary(pl.UTF-8):      Oprogramowanie do wielościeżkowego przetwarzania dźwięku
10 Name:           ecasound
11 Version:        2.6.0
12 Release:        1
13 License:        GPL v2+
14 Group:          Applications/Sound
15 Source0:        http://ecasound.seul.org/download/%{name}-%{version}.tar.gz
16 # Source0-md5:  41f9445b9a9c0cde141831cb53d1ef8f
17 Patch0:         %{name}-link.patch
18 Patch1:         %{name}-acam.patch
19 URL:            http://ecasound.seul.org/
20 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9.0}
21 %{?with_arts:BuildRequires:     arts-devel}
22 BuildRequires:  autoconf >= 2.50
23 BuildRequires:  automake >= 1.6.1
24 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
25 BuildRequires:  ladspa-devel
26 BuildRequires:  libsamplerate-devel
27 BuildRequires:  libsndfile-devel >= 1.0.12
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libtool >= 2:1.4d
30 BuildRequires:  python-devel >= 2.2
31 BuildRequires:  python-modules >= 2.2
32 BuildRequires:  readline-devel >= 5.0
33 %if %{with ruby}
34 BuildRequires:  rpmbuild(macros) >= 1.277
35 BuildRequires:  ruby-devel
36 %endif
37 Obsoletes:      libecasound
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Ecasound is a software package designed for multitrack audio
42 processing. It can be used for simple tasks like audio playback,
43 recording and format conversions, as well as for multitrack effect
44 processing, mixing, recording and signal recycling. Ecasound supports
45 a wide range of audio inputs, outputs and effect algorithms. Several
46 open-source audio packages, like for instance ALSA, OSS, mpg123, lame
47 and MikMod, are directly supported. One of the advantages of
48 ecasound's chain-based design is that effects can easily be combined
49 both in series and in parallel. Oscillators and MIDI-CCs can be used
50 for controlling effect parameters. Included user-interfaces are
51 ecasound - a versatile console mode interface, ecawave - a Qt-based
52 X-interface and various command-line utils suitable for batch
53 processing.
54
55 %description -l pl.UTF-8
56 Ecasound jest programem do wielościeżkowej edycji dźwięku, który może
57 być używany tak do prostych zadań typu odtwarzanie i nagrywanie muzyki
58 czy też konwersji pomiędzy formatami plików muzycznych jak i do
59 wielościeżkowego nakładania efektów, miksowania (przenikania,
60 wyciszania), nagrywania i odzyskiwania (w domyśle odszumiania lub
61 wyrzucania zniekształceń) sygnału.
62
63 Ecasound wspiera szeroką gamę źródeł i wyjść dźwięku oraz algorytmów
64 do jego przetwarzania. Ecasound wspiera wiele wolnych (open source)
65 projektów, takich jak ALSA, OSS, mpg123, lame czy też MikMod. Jedną z
66 zalet programu ecasound jest możliwość łańcuchowego (szeregowego) lub
67 równoległego łączenia efektów, które mogą być kontrolowane poprzez
68 oscylatory lub MIDI-CC. Pakiet ten zawiera tekstowy interfejs
69 użytkownika oraz kilka innych narzędzi nadających się do przetwarzania
70 wsadowego. Dostępny jest także graficzny, oparty na Qt interfejs
71 użytkownika - ecawave.
72
73 %package devel
74 Summary:        Header files for ecasound libraries
75 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek ecasound
76 Group:          Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78 %{?with_alsa:Requires:  alsa-lib-devel}
79 %{?with_arts:Requires:  arts-devel}
80 %{?with_jack:Requires:  jack-audio-connection-kit-devel}
81 Requires:       libsamplerate-devel
82 Requires:       libsndfile-devel
83 Requires:       libstdc++-devel
84 Obsoletes:      libecasound-devel
85
86 %description devel
87 Header files for ecasound libraries.
88
89 %description devel -l pl.UTF-8
90 Pliki nagłówkowe bibliotek ecasound.
91
92 %package static
93 Summary:        Static ecasound libraries
94 Summary(pl.UTF-8):      Statyczne biblioteki ecasound
95 Group:          Development/Libraries
96 Requires:       %{name}-devel = %{version}-%{release}
97 Obsoletes:      libecasound-static
98
99 %description static
100 Static ecasound libraries.
101
102 %description static -l pl.UTF-8
103 Statyczne biblioteki ecasound.
104
105 %package -n python-%{name}
106 Summary:        Python module for Ecasound
107 Summary(pl.UTF-8):      Moduł języka Python dla programu ecasound
108 Group:          Libraries/Python
109 Requires:       %{name} = %{version}-%{release}
110 %pyrequires_eq  python-modules
111
112 %description -n python-%{name}
113 Python module for Ecasound.
114
115 %description -n python-%{name} -l pl.UTF-8
116 Moduł języka Python dla programu ecasound.
117
118 %package -n ruby-%{name}
119 Summary:        Ruby module for Ecasound
120 Summary(pl.UTF-8):      Moduł języka Ruby dla programu ecasound
121 Group:          Libraries
122 Requires:       %{name} = %{version}-%{release}
123 %{?ruby_mod_ver_requires_eq}
124
125 %description -n ruby-%{name}
126 Ruby module for Ecasound.
127
128 %description -n ruby-%{name} -l pl.UTF-8
129 Moduł języka Ruby dla programu ecasound.
130
131 %prep
132 %setup -q
133 %patch0 -p1
134 %patch1 -p1
135
136 %build
137 %{__libtoolize}
138 %{__aclocal}
139 %{__autoconf}
140 %{__automake}
141 CXXFLAGS="%{rpmcflags} -D_REENTRANT %{!?debug:-DNDEBUG} -I/usr/include/ncurses"
142 # disable audiofile - ecasound has native support for wav and raw formats
143 # disable oss       - ecasound works nicely with alsa oss emulation;
144 #                     in case of alsa building conditional, the oss should
145 #                     be enabled
146 # disable arts      - 'not really useful' as said by ecasound author
147 %configure \
148         %{!?with_alsa:--disable-alsa} \
149         %{!?with_arts:--disable-arts} \
150         --disable-audiofile \
151         %{!?with_jack:--disable-jack} \
152         %{?with_alsa:--disable-oss} \
153         --enable-samplerate \
154         --enable-shared \
155         --enable-sys-readline \
156         --enable-pyecasound \
157         --with-largefile \
158         --with-python-includes=%{py_incdir} \
159         --with-python-modules=%{py_libdir}
160
161 %{__make}
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165 install -d $RPM_BUILD_ROOT%{py_sitedir}
166
167 %{__make} install \
168         DESTDIR=$RPM_BUILD_ROOT \
169         mandir=%{_mandir}
170
171 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
172 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
173 %py_postclean
174 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %post   -p /sbin/ldconfig
180 %postun -p /sbin/ldconfig
181
182 %files
183 %defattr(644,root,root,755)
184 %doc BUGS NEWS README TODO
185 %attr(755,root,root) %{_bindir}/eca*
186 %attr(755,root,root) %{_libdir}/libecasound.so.*.*.*
187 %attr(755,root,root) %ghost %{_libdir}/libecasound.so.20
188 %attr(755,root,root) %{_libdir}/libecasoundc.so.*.*.*
189 %attr(755,root,root) %ghost %{_libdir}/libecasoundc.so.1
190 %attr(755,root,root) %{_libdir}/libkvutils.so.*.*.*
191 %attr(755,root,root) %ghost %{_libdir}/libkvutils.so.4
192 %{_datadir}/ecasound
193 %{_mandir}/man1/eca*.1*
194 %{_mandir}/man5/ecasoundrc.5*
195
196 %files devel
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_bindir}/libecasound-config
199 %attr(755,root,root) %{_bindir}/libecasoundc-config
200 %attr(755,root,root) %{_libdir}/libecasound.so
201 %attr(755,root,root) %{_libdir}/libecasoundc.so
202 %attr(755,root,root) %{_libdir}/libkvutils.so
203 %{_libdir}/libecasound.la
204 %{_libdir}/libecasoundc.la
205 %{_libdir}/libkvutils.la
206 %{_includedir}/kvutils
207 %{_includedir}/libecasound
208 %{_includedir}/libecasoundc
209
210 %files static
211 %defattr(644,root,root,755)
212 %{_libdir}/libecasound.a
213 %{_libdir}/libecasoundc.a
214 %{_libdir}/libkvutils.a
215
216 %files -n python-%{name}
217 %defattr(644,root,root,755)
218 %attr(755,root,root) %{py_sitedir}/pyecasound.so
219 %{py_sitedir}/ecacontrol.py[co]
220 %{py_sitedir}/eci.py[co]
221 %{py_sitedir}/pyeca.py[co]
222
223 %if %{with ruby}
224 %files -n ruby-%{name}
225 %defattr(644,root,root,755)
226 %{ruby_sitelibdir}/ecasound.rb
227 %endif
This page took 0.105535 seconds and 3 git commands to generate.