]> git.pld-linux.org Git - packages/ecasound.git/blob - ecasound.spec
- mass commit: remove obsolete BR: rpm-pythonprov
[packages/ecasound.git] / ecasound.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # without ALSA support (implies without JACK)
4 %bcond_without  jack            # without JACK support
5 %bcond_without  ruby            # without ruby support
6 %bcond_with     arts            # with aRts support
7 #
8 Summary:        Software package for multitrack audio processing
9 Summary(pl):    Oprogramowanie do wielo¶cie¿kowego przetwarzania d¼wiêku
10 Name:           ecasound
11 Version:        2.3.5
12 Release:        3
13 License:        GPL
14 Group:          Applications/Sound
15 Source0:        http://ecasound.seul.org/download/%{name}-%{version}.tar.gz
16 # Source0-md5:  bbc0c4d12c1d21a7e71fc1bdb9fb0e2b
17 Patch0:         %{name}-link.patch
18 %{?with_alsa:BuildRequires:     alsa-lib-devel}
19 %{?with_arts:BuildRequires:     arts-devel}
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
23 BuildRequires:  ladspa-devel
24 BuildRequires:  libsamplerate-devel
25 BuildRequires:  libsndfile-devel
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtool >= 2:1.4d
28 BuildRequires:  python-devel >= 2.2
29 BuildRequires:  python-modules >= 2.2
30 BuildRequires:  readline-devel >= 4.2
31 %{?with_ruby:BuildRequires:     ruby}
32 Obsoletes:      libecasound
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %if %{with ruby}
36 %define         ruby_sitelibdir %(ruby -r rbconfig -e 'print Config::CONFIG["sitelibdir"]')
37 %endif
38
39 %description
40 Ecasound is a software package designed for multitrack audio
41 processing. It can be used for simple tasks like audio playback,
42 recording and format conversions, as well as for multitrack effect
43 processing, mixing, recording and signal recycling. Ecasound supports
44 a wide range of audio inputs, outputs and effect algorithms. Several
45 open-source audio packages, like for instance ALSA, OSS, mpg123, lame,
46 libaudiofile and MikMod, are directly supported. One of the advantages
47 of ecasound's chain-based design is that effects can easily be
48 combined both in series and in parallel. Oscillators and MIDI-CCs can
49 be used for controlling effect parameters. Included user-interfaces
50 are ecasound - a versatile console mode interface, qtecasound - a
51 Qt-based X-interface and various command-line utils suitable for batch
52 processing.
53
54 %description -l pl
55 Ecasound jest programem do wielo¶cie¿kowej edycji d¼wiêku, który mo¿e
56 byæ u¿ywany tak do prostych zadañ typu odtwarzanie i nagrywanie muzyki
57 czy te¿ konwersji pomiêdzy formatami plików muzycznych jak i do
58 wielo¶cie¿kowego nak³adania efektów, miksowania (przenikania,
59 wyciszania), nagrywania i odzyskiwania (w domy¶le odszumiania lub
60 wyrzucania zniekszta³ceñ) sygna³u.
61
62 Ecasound wspiera szerok± gamê ¼róde³ i wyj¶æ d¼wiêku oraz algorytmów
63 do jego przetwarzania. Ecasound wspiera wiele wolnych (open source)
64 projektów, takich jak ALSA, OSS, mpg123, lame, libaudiofile czy te¿
65 MikMod. Jedn± z zalet programu ecasound jest mo¿liwo¶æ ³añcuchowego
66 (szeregowego) lub równoleg³ego ³±czenia efektów, które mog± byæ
67 kontrolowane poprzez oscylatory lub MIDI-CC. Pakiet ten zawiera
68 tekstowy interfejs u¿ytkownika oraz kilka innych narzêdzi nadaj±cych
69 siê do przetwarzania wsadowego. Dostêpny jest tak¿e graficzny
70 interfejs u¿ytkownika - qtecasound.
71
72 %package devel
73 Summary:        Header files for ecasound libraries
74 Summary(pl):    Pliki nag³ówkowe bibliotek ecasound
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77 %{?with_alsa:Requires:  alsa-lib-devel}
78 %{?with_arts:Requires:  arts-devel}
79 %{?with_jack:Requires:  jack-audio-connection-kit-devel}
80 Requires:       libsamplerate-devel
81 Requires:       libsndfile-devel
82 Requires:       libstdc++-devel
83 Obsoletes:      libecasound-devel
84
85 %description devel
86 Header files for ecasound libraries.
87
88 %description devel -l pl
89 Pliki nag³ówkowe bibliotek ecasound.
90
91 %package static
92 Summary:        Static ecasound libraries
93 Summary(pl):    Statyczne biblioteki ecasound
94 Group:          Development/Libraries
95 Requires:       %{name}-devel = %{version}-%{release}
96 Obsoletes:      libecasound-static
97
98 %description static
99 Static ecasound libraries.
100
101 %description static -l pl
102 Statyczne biblioteki ecasound.
103
104 %package -n python-%{name}
105 Summary:        Python module for Ecasound
106 Summary(pl):    Modu³ jêzyka Python dla programu ecasound
107 Group:          Libraries/Python
108 Requires:       %{name} = %{version}-%{release}
109 %pyrequires_eq  python-modules
110
111 %description -n python-%{name}
112 Python module for Ecasound.
113
114 %description -n python-%{name} -l pl
115 Modu³ jêzyka Python dla programu ecasound.
116
117 %package -n ruby-%{name}
118 Summary:        Ruby module for Ecasound
119 Summary(pl):    Modu³ jêzyka Ruby dla programu ecasound
120 Group:          Libraries
121 Requires:       %{name} = %{version}-%{release}
122 %requires_eq    ruby
123
124 %description -n ruby-%{name}
125 Ruby module for Ecasound.
126
127 %description -n ruby-%{name} -l pl
128 Modu³ jêzyka Ruby dla programu ecasound.
129
130 %prep
131 %setup -q
132 %patch0 -p1
133
134 %build
135 %{__libtoolize}
136 %{__aclocal}
137 %{__autoconf}
138 %{__automake}
139 CXXFLAGS="%{rpmcflags} -D_REENTRANT %{!?debug:-DNDEBUG} -I/usr/include/ncurses"
140 # disable audiofile - ecasound has native support for wav and raw formats
141 # disable oss       - ecasound works nicely with alsa oss emulation;
142 #                     in case of alsa building conditional, the oss should
143 #                     be enabled
144 # disable arts      - 'not really useful' as said by ecasound author
145 %configure \
146         %{!?with_alsa:--disable-alsa} \
147         %{!?with_arts:--disable-arts} \
148         --disable-audiofile \
149         %{!?with_jack:--disable-jack} \
150         %{?with_alsa:--disable-oss} \
151         --enable-samplerate \
152         --enable-shared \
153         --enable-sys-readline \
154         --enable-pyecasound \
155         --with-largefile \
156         --with-python-includes=%{py_incdir} \
157         --with-python-modules=%{py_libdir}
158
159 %{__make}
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163 install -d $RPM_BUILD_ROOT%{py_sitedir}
164
165 %{__make} install \
166         DESTDIR=$RPM_BUILD_ROOT \
167         mandir=%{_mandir}
168
169 install pyecasound/*.py $RPM_BUILD_ROOT%{py_sitedir}
170 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
171 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
172
173 %clean
174 rm -rf $RPM_BUILD_ROOT
175
176 %post   -p /sbin/ldconfig
177 %postun -p /sbin/ldconfig
178
179 %files
180 %defattr(644,root,root,755)
181 %doc BUGS NEWS README TODO
182 %attr(755,root,root) %{_bindir}/eca*
183 %attr(755,root,root) %{_libdir}/lib*.so.*.*
184 %{_datadir}/ecasound
185 %{_mandir}/man1/eca*
186 %{_mandir}/man5/eca*
187
188 %files devel
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_bindir}/*-config
191 %attr(755,root,root) %{_libdir}/lib*.so
192 %{_libdir}/lib*.la
193 %{_includedir}/kvutils
194 %{_includedir}/libecasound
195 %{_includedir}/libecasoundc
196
197 %files static
198 %defattr(644,root,root,755)
199 %{_libdir}/lib*.a
200
201 %files -n python-%{name}
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{py_sitedir}/*.so
204 %{py_sitedir}/*.py[co]
205
206 %if %{with ruby}
207 %files -n ruby-%{name}
208 %defattr(644,root,root,755)
209 %{ruby_sitelibdir}/ecasound.rb
210 %endif
This page took 0.078235 seconds and 3 git commands to generate.