]> git.pld-linux.org Git - packages/ecasound.git/blob - ecasound.spec
- fixed ruby subpackage building
[packages/ecasound.git] / ecasound.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # without ALSA support (implies without JACK)
4 %bcond_without  jack            # without JACK support
5 %bcond_without  ruby            # without ruby support
6 %bcond_with     arts            # with aRts support
7 #
8 Summary:        Software package for multitrack audio processing
9 Summary(pl.UTF-8):      Oprogramowanie do wielościeżkowego przetwarzania dźwięku
10 Name:           ecasound
11 Version:        2.9.1
12 Release:        1
13 License:        GPL v2+
14 Group:          Applications/Sound
15 Source0:        http://ecasound.seul.org/download/%{name}-%{version}.tar.gz
16 # Source0-md5:  13c7be1e4eddc0bbf3792dc17777e465
17 Patch0:         %{name}-link.patch
18 Patch1:         %{name}-acam.patch
19 Patch2:         %{name}-ruby.patch
20 URL:            http://www.eca.cx/ecasound/
21 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9.0}
22 %{?with_arts:BuildRequires:     arts-devel}
23 BuildRequires:  autoconf >= 2.50
24 BuildRequires:  automake >= 1.6.1
25 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
26 BuildRequires:  ladspa-devel
27 BuildRequires:  liblo-devel
28 BuildRequires:  liboil-devel >= 0.3
29 BuildRequires:  libsamplerate-devel
30 BuildRequires:  libsndfile-devel >= 1.0.12
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtool >= 2:1.4d
33 BuildRequires:  lilv-devel >= 0.5.0
34 BuildRequires:  lv2core-devel
35 BuildRequires:  ncurses-devel
36 BuildRequires:  pkgconfig
37 BuildRequires:  python-devel >= 2.2
38 BuildRequires:  python-modules >= 2.2
39 BuildRequires:  readline-devel >= 5.0
40 BuildRequires:  rpm-pythonprov
41 %if %{with ruby}
42 BuildRequires:  rpmbuild(macros) >= 1.277
43 BuildRequires:  ruby-devel
44 %endif
45 Requires:       libsndfile >= 1.0.12
46 Requires:       lilv >= 0.5.0
47 Obsoletes:      libecasound
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Ecasound is a software package designed for multitrack audio
52 processing. It can be used for simple tasks like audio playback,
53 recording and format conversions, as well as for multitrack effect
54 processing, mixing, recording and signal recycling. Ecasound supports
55 a wide range of audio inputs, outputs and effect algorithms. Several
56 open-source audio packages, like for instance ALSA, OSS, mpg123, lame
57 and MikMod, are directly supported. One of the advantages of
58 ecasound's chain-based design is that effects can easily be combined
59 both in series and in parallel. Oscillators and MIDI-CCs can be used
60 for controlling effect parameters. Included user-interfaces are
61 ecasound - a versatile console mode interface, ecawave - a Qt-based
62 X-interface and various command-line utils suitable for batch
63 processing.
64
65 %description -l pl.UTF-8
66 Ecasound jest programem do wielościeżkowej edycji dźwięku, który może
67 być używany tak do prostych zadań typu odtwarzanie i nagrywanie muzyki
68 czy też konwersji pomiędzy formatami plików muzycznych jak i do
69 wielościeżkowego nakładania efektów, miksowania (przenikania,
70 wyciszania), nagrywania i odzyskiwania (w domyśle odszumiania lub
71 wyrzucania zniekształceń) sygnału.
72
73 Ecasound wspiera szeroką gamę źródeł i wyjść dźwięku oraz algorytmów
74 do jego przetwarzania. Ecasound wspiera wiele wolnych (open source)
75 projektów, takich jak ALSA, OSS, mpg123, lame czy też MikMod. Jedną z
76 zalet programu ecasound jest możliwość łańcuchowego (szeregowego) lub
77 równoległego łączenia efektów, które mogą być kontrolowane poprzez
78 oscylatory lub MIDI-CC. Pakiet ten zawiera tekstowy interfejs
79 użytkownika oraz kilka innych narzędzi nadających się do przetwarzania
80 wsadowego. Dostępny jest także graficzny, oparty na Qt interfejs
81 użytkownika - ecawave.
82
83 %package devel
84 Summary:        Header files for ecasound libraries
85 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek ecasound
86 Group:          Development/Libraries
87 Requires:       %{name} = %{version}-%{release}
88 %{?with_alsa:Requires:  alsa-lib-devel}
89 %{?with_arts:Requires:  arts-devel}
90 %{?with_jack:Requires:  jack-audio-connection-kit-devel}
91 Requires:       liblo-devel
92 Requires:       liboil-devel >= 0.3
93 Requires:       libsamplerate-devel
94 Requires:       libsndfile-devel
95 Requires:       libstdc++-devel
96 Requires:       lilv-devel >= 0.5.0
97 Obsoletes:      libecasound-devel
98
99 %description devel
100 Header files for ecasound libraries.
101
102 %description devel -l pl.UTF-8
103 Pliki nagłówkowe bibliotek ecasound.
104
105 %package static
106 Summary:        Static ecasound libraries
107 Summary(pl.UTF-8):      Statyczne biblioteki ecasound
108 Group:          Development/Libraries
109 Requires:       %{name}-devel = %{version}-%{release}
110 Obsoletes:      libecasound-static
111
112 %description static
113 Static ecasound libraries.
114
115 %description static -l pl.UTF-8
116 Statyczne biblioteki ecasound.
117
118 %package -n python-%{name}
119 Summary:        Python module for Ecasound
120 Summary(pl.UTF-8):      Moduł języka Python dla programu ecasound
121 Group:          Libraries/Python
122 Requires:       %{name} = %{version}-%{release}
123 %pyrequires_eq  python-modules
124
125 %description -n python-%{name}
126 Python module for Ecasound.
127
128 %description -n python-%{name} -l pl.UTF-8
129 Moduł języka Python dla programu ecasound.
130
131 %package -n ruby-%{name}
132 Summary:        Ruby module for Ecasound
133 Summary(pl.UTF-8):      Moduł języka Ruby dla programu ecasound
134 Group:          Libraries
135 Requires:       %{name} = %{version}-%{release}
136 %{?ruby_mod_ver_requires_eq}
137
138 %description -n ruby-%{name}
139 Ruby module for Ecasound.
140
141 %description -n ruby-%{name} -l pl.UTF-8
142 Moduł języka Ruby dla programu ecasound.
143
144 %prep
145 %setup -q
146 %patch0 -p1
147 %patch1 -p1
148 %patch2 -p1
149
150 %build
151 %{__libtoolize}
152 %{__aclocal}
153 %{__autoconf}
154 %{__automake}
155 CXXFLAGS="%{rpmcflags} -D_REENTRANT %{!?debug:-DNDEBUG}"
156 # disable audiofile - ecasound has native support for wav and raw formats
157 # disable oss       - ecasound works nicely with alsa oss emulation;
158 #                     in case of alsa building conditional, the oss should
159 #                     be enabled
160 # disable arts      - 'not really useful' as said by ecasound author
161 %configure \
162         %{!?with_alsa:--disable-alsa} \
163         %{!?with_arts:--disable-arts} \
164         --disable-audiofile \
165         %{!?with_jack:--disable-jack} \
166         %{?with_alsa:--disable-oss} \
167         --enable-samplerate \
168         --enable-shared \
169         --enable-sys-readline \
170         --enable-pyecasound \
171         %{?with_ruby:--enable-rubyecasound} \
172         --with-largefile \
173         --with-python-includes=%{py_incdir} \
174         --with-python-modules=%{py_libdir}
175
176 %{__make} \
177         termcap_library_ncurses="-lncurses -ltinfo" \
178         ncurses_library="-lncurses -ltinfo"
179
180 %install
181 rm -rf $RPM_BUILD_ROOT
182 #install -d $RPM_BUILD_ROOT%{py_sitedir}
183
184 %{__make} install \
185         DESTDIR=$RPM_BUILD_ROOT \
186         mandir=%{_mandir}
187
188 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
189 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
190 %py_postclean
191
192 %clean
193 rm -rf $RPM_BUILD_ROOT
194
195 %post   -p /sbin/ldconfig
196 %postun -p /sbin/ldconfig
197
198 %files
199 %defattr(644,root,root,755)
200 # COPYING is licensing note, not GPL/LGPL text
201 %doc AUTHORS BUGS COPYING NEWS README RELNOTES TODO
202 %attr(755,root,root) %{_bindir}/eca*
203 %attr(755,root,root) %{_libdir}/libecasound.so.*.*.*
204 %attr(755,root,root) %ghost %{_libdir}/libecasound.so.24
205 %attr(755,root,root) %{_libdir}/libecasoundc.so.*.*.*
206 %attr(755,root,root) %ghost %{_libdir}/libecasoundc.so.1
207 %attr(755,root,root) %{_libdir}/libkvutils.so.*.*.*
208 %attr(755,root,root) %ghost %{_libdir}/libkvutils.so.10
209 %{_datadir}/ecasound
210 %{_mandir}/man1/eca*.1*
211 %{_mandir}/man5/ecasoundrc.5*
212
213 %files devel
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{_bindir}/libecasound-config
216 %attr(755,root,root) %{_bindir}/libecasoundc-config
217 %attr(755,root,root) %{_libdir}/libecasound.so
218 %attr(755,root,root) %{_libdir}/libecasoundc.so
219 %attr(755,root,root) %{_libdir}/libkvutils.so
220 %{_libdir}/libecasound.la
221 %{_libdir}/libecasoundc.la
222 %{_libdir}/libkvutils.la
223 %{_includedir}/kvutils
224 %{_includedir}/libecasound
225 %{_includedir}/libecasoundc
226
227 %files static
228 %defattr(644,root,root,755)
229 %{_libdir}/libecasound.a
230 %{_libdir}/libecasoundc.a
231 %{_libdir}/libkvutils.a
232
233 %files -n python-%{name}
234 %defattr(644,root,root,755)
235 %{py_sitedir}/ecacontrol.py[co]
236 %{py_sitedir}/eci.py[co]
237 %{py_sitedir}/pyeca.py[co]
238
239 %if %{with ruby}
240 %files -n ruby-%{name}
241 %defattr(644,root,root,755)
242 %{ruby_vendorlibdir}/ecasound.rb
243 %endif
This page took 0.109431 seconds and 3 git commands to generate.