]> git.pld-linux.org Git - packages/ecasound.git/blob - ecasound.spec
- soften build requirements for libtool
[packages/ecasound.git] / ecasound.spec
1
2 #
3 # todo:
4 # - jackit.sf.net
5 #
6
7 #
8 # Conditional build:
9 # _without_alsa - without ALSA support
10 #
11
12 %include        /usr/lib/rpm/macros.python
13
14 Summary:        Software package for multitrack audio processing
15 Summary(pl):    Oprogramowanie do wielo¶cie¿kowego przetwarzania d¼wiêku
16 Name:           ecasound
17 Version:        2.2.0
18 Release:        1
19 License:        GPL
20 Group:          Applications/Sound
21 Source0:        http://ecasound.seul.org/download/%{name}-%{version}.tar.gz
22 Patch0:         %{name}-link.patch
23 %ifnarch sparc sparc64
24 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
25 %endif
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libtool
30 BuildRequires:  python-devel >= 2.2
31 BuildRequires:  python-modules >= 2.2
32 BuildRequires:  readline-devel >= 4.2
33 BuildRequires:  rpm-pythonprov
34 Requires:       lame
35 Requires:       mpg123
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Ecasound is a software package designed for multitrack audio
40 processing. It can be used for simple tasks like audio playback,
41 recording and format conversions, as well as for multitrack effect
42 processing, mixing, recording and signal recycling. Ecasound supports
43 a wide range of audio inputs, outputs and effect algorithms. Several
44 open-source audio packages, like for instance ALSA, OSS, mpg123, lame,
45 libaudiofile and MikMod, are directly supported. One of the advantages
46 of ecasound's chain-based design is that effects can easily be
47 combined both in series and in parallel. Oscillators and MIDI-CCs can
48 be used for controlling effect parameters. Included user-interfaces
49 are ecasound - a versatile console mode interface, qtecasound - a
50 Qt-based X-interface and various command-line utils suitable for batch
51 processing.
52
53 %description -l pl
54 Ecasound jest programem do wielo¶cie¿kowej edycji d¼wiêku, który mo¿e
55 byæ u¿ywany tak do prostych zadañ typu odtwarzanie i nagrywanie muzyki
56 czy te¿ konwersji pomiêdzy formatami plików muzycznych jak i do
57 wielo¶cie¿kowego nak³adania efektów, miksowania (przenikania,
58 wyciszania), nagrywania i odzyskiwania (w domy¶le odszumiania lub
59 wyrzucania zniekszta³ceñ) sygna³u.
60
61 Ecasound wspiera szerok± gamê ¼róde³ i wyj¶æ d¼wiêku oraz algorytmów
62 do jego przetwarzania. Ecasound wspiera wiele wolnych (open source)
63 projektów, takich jak ALSA, OSS, mpg123, lame, libaudiofile czy te¿
64 MikMod. Jedn± z zalet programu ecasound jest mo¿liwo¶æ ³añcuchowego
65 (szeregowego) lub równoleg³ego ³±czenia efektów, które mog± byæ
66 kontrolowane poprzez oscylatory lub MIDI-CC. Pakiet ten zawiera
67 tekstowy interfejs u¿ytkownika oraz kilka innych narzêdzi nadaj±cych
68 siê do przetwarzania wsadowego. Dostêpny jest tak¿e graficzny
69 interfejs u¿ytkownika - qtecasound.
70
71 %package -n python-%{name}
72 Summary:        Python module for Ecasound
73 Summary(pl):    Modu³ jêzyka Python dla programu ecasound
74 Group:          Libraries/Python
75 %pyrequires_eq  python-modules
76
77 %description -n python-%{name}
78 Python module for Ecasound.
79
80 %description -n python-%{name} -l pl
81 Modu³ jêzyka Python dla programu ecasound.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86
87 %build
88 rm -f missing
89 %{__libtoolize}
90 aclocal
91 %{__autoconf}
92 %{__automake}
93 CXXFLAGS="%{rpmcflags} -D_REENTRANT %{!?debug:-DNDEBUG} -I/usr/include/ncurses"
94 # disable audiofile - ecasound has native support for wav and raw formats
95 # disable oss       - ecasound works nicely with alsa oss emulation;
96 #                     in case of alsa building conditional, the oss should
97 #                     be enabled
98 # disable arts      - 'not really useful' as said by ecasound author
99 %configure \
100         --enable-sys-readline \
101         --with-python-includes=%{py_incdir} \
102         --with-python-modules=%{py_libdir} \
103         --disable-audiofile \
104         --disable-arts \
105         %{?_without_alsa:--disable-alsa} \
106         %{!?_without_alsa:--disable-oss}
107
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT%{py_sitedir}
113
114 %{__make} DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
115
116 install pyecasound/*.py $RPM_BUILD_ROOT%{py_sitedir}
117 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
118 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files
124 %defattr(644,root,root,755)
125 %doc BUGS NEWS README TODO
126 %attr(755,root,root) %{_bindir}/eca*
127 %{_datadir}/ecasound
128
129 %{_mandir}/man1/eca*
130 %{_mandir}/man5/eca*
131
132 %files -n python-%{name}
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{py_sitedir}/*.so
135 %{py_sitedir}/*.py[co]
This page took 0.035849 seconds and 3 git commands to generate.