]> git.pld-linux.org Git - packages/ecasound.git/blob - ecasound.spec
- do not override CXXFLAGS.
[packages/ecasound.git] / ecasound.spec
1
2 %define python_sitepkgsdir %(echo `python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`)
3 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
4 %define python_compile python -c "import compileall; compileall.compile_dir('.')"
5
6 Summary:        Software package for multitrack audio processing
7 Summary(pl):    Oprogramowanie do wielo¶cie¿kowego przetwarzania d¼wiêku
8 Name:           ecasound
9 Version:        1.9dev1
10 Release:        2
11 License:        GPL
12 Group:          Applications/Sound
13 Group(de):      Applikationen/Laut
14 Group(pl):      Aplikacje/D¼wiêk
15 Source0:        http://ecasound.seul.org/download/%{name}-%{version}.tar.gz
16 patch0:         %{name}-am_fix.patch
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  ncurses-devel >= 5.0
20 BuildRequires:  readline-devel
21 %ifnarch sparc sparc64
22 BuildRequires:  alsa-lib-devel
23 %endif
24 BuildRequires:  audiofile-devel >= 0.2.0
25 BuildRequires:  python-devel
26 Requires:       lame
27 Requires:       mpg123
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Ecasound is a software package designed for multitrack audio
32 processing. It can be used for simple tasks like audio playback,
33 recording and format conversions, as well as for multitrack effect
34 processing, mixing, recording and signal recycling. Ecasound supports
35 a wide range of audio inputs, outputs and effect algorithms. Several
36 open-source audio packages, like for instance ALSA, OSS, mpg123, lame,
37 libaudiofile and MikMod, are directly supported. One of the advantages
38 of ecasound's chain-based design is that effects can easily be
39 combined both in series and in parallel. Oscillators and MIDI-CCs can
40 be used for controlling effect parameters. Included user-interfaces
41 are ecasound - a versatile console mode interface, qtecasound - a
42 Qt-based X-interface and various command-line utils suitable for batch
43 processing.
44
45 %description -l pl
46 Ecasound jest programem do wielo¶cie¿kowej edycji d¼wiêku, który mo¿e
47 byæ u¿ywany tak do prostych zadañ typu odtwarzanie i nagrywanie muzyki
48 czy te¿ konwersji pomiêdzy formatami plików muzycznych jak i do
49 wielo¶cie¿kowego nak³adania efektów, miksowania (przenikania,
50 wyciszania), nagrywania i odzyskiwania (w domy¶le odszumiania lub
51 wyrzucania zniekszta³ceñ) sygna³u.
52
53 Ecasound wspiera szerok± gamê ¼róde³ i wyj¶æ d¼wiêku oraz algorytmów
54 do jego przetwarzania. Ecasound wspiera wiele wolnych (open source)
55 projektów, takich jak ALSA, OSS, mpg123, lame, libaudiofile czy te¿
56 MikMod. Jedn± z zalet programu ecasound jest mo¿liwo¶æ ³añcuchowego
57 (szeregowego) lub równoleg³ego ³±czenia efektów, które mog± byæ
58 kontrolowane poprzez oscylatory lub MIDI-CC. Pakiet ten zawiera
59 tekstowy interfejs u¿ytkownika oraz kilka innych narzêdzi nadaj±cych
60 siê do przetwarzania wsadowego. Dostêpny jest tak¿e graficzny
61 interfejs u¿ytkownika - qtecasound.
62
63 %package -n libecasound
64 Summary:        Ecasound libraries
65 Summary(pl):    Biblioteki programu ecasound
66 Group:          Development/Libraries
67 Group(de):      Entwicklung/Libraries
68 Group(fr):      Development/Librairies
69 Group(pl):      Programowanie/Biblioteki
70
71 %description -n libecasound
72 Ecasound libraries.
73
74 %description -l pl -n libecasound
75 Biblioteki programu ecasound.
76
77 %package -n libecasound-devel
78 Summary:        Ecasound headers
79 Summary(pl):    Pliki nag³ówkowe bibliotek programu ecasound
80 Group:          Development/Libraries
81 Group(de):      Entwicklung/Libraries
82 Group(fr):      Development/Librairies
83 Group(pl):      Programowanie/Biblioteki
84 Requires:       libecasound = %{version}
85
86 %description -n libecasound-devel
87 Ecasound headers.
88
89 %description -l pl -n libecasound-devel
90 Pliki nag³ówkowe bibliotek programu ecasound.
91
92 %package -n libecasound-static
93 Summary:        Ecasound static libraries
94 Summary(pl):    Biblioteki statyczne programu ecasound
95 Group:          Development/Libraries
96 Group(de):      Entwicklung/Libraries
97 Group(fr):      Development/Librairies
98 Group(pl):      Programowanie/Biblioteki
99 Requires:       libecasound-devel = %{version}
100
101 %description -n libecasound-static
102 Ecasound static libraries.
103
104 %description -l pl -n libecasound-static
105 Biblioteki statyczne programu ecasound.
106
107 %package plugins
108 Summary:        Ecasound plugins (ALSA, Audio File Library, aRts)
109 Summary(pl):    Wtyczki dla programu ecasound (ALSA, Audio File Library, aRts)
110 Group:          Applications/Sound
111 Group(de):      Applikationen/Laut
112 Group(pl):      Aplikacje/D¼wiêk
113 Requires:       ecasound = %{version}
114
115 %description plugins
116 This package contains ecasound plugins, which give support for ALSA,
117 Audio File Library and aRts.
118
119 %description -l pl plugins
120 Pakiet ten zawiera wtyczki dla programu ecasound, które umo¿liwiaj±
121 wspó³pracê z bibliotekami takich projektów jak ALSA, Audio File
122 Library oraz aRts.
123
124 %package -n python-%{name}
125 Summary:        Python module for Ecasound
126 Summary(pl):    Modu³ jêzyka Python dla biblioteki programu ecasound
127 Group:          Development/Languages/Python
128 Group(de):      Entwicklung/Sprachen/Python
129 Group(pl):      Programowanie/Jêzyki/Python
130
131 %description -n python-%{name}
132 Python module for Ecasound library.
133
134 %description -l pl -n python-%{name}
135 Modu³ jêzyka Python dla biblioteki programu ecasound.
136
137 %prep
138 %setup -q
139 %patch -p1
140
141 %build
142 aclocal
143 autoconf
144 automake -a -c
145 CXXFLAGS="%{!?debug:$RPM_OPT_FLAGS -fno-rtti}%{?debug:-O0 -g} -D_REENTRANT"
146 %configure \
147         --enable-sys-readline
148 %{__make}
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152
153 %{__make} DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
154
155 ( cd pyecasound
156   %python_compile_opt
157   %python_compile
158   install *.pyc *.pyo $RPM_BUILD_ROOT%{python_sitepkgsdir}
159 )
160
161
162 %clean
163 rm -rf $RPM_BUILD_ROOT
164
165 %post   -n libecasound -p /sbin/ldconfig
166 %postun -n libecasound -p /sbin/ldconfig
167
168 %files
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_bindir}/ecaconvert
171 %attr(755,root,root) %{_bindir}/ecafixdc
172 %attr(755,root,root) %{_bindir}/ecanormalize
173 %attr(755,root,root) %{_bindir}/ecaplay
174 %attr(755,root,root) %{_bindir}/ecasignalview
175 %attr(755,root,root) %{_bindir}/ecasound
176 %{_mandir}/man1/eca*
177 %{_mandir}/man5/eca*
178
179 %files -n libecasound
180 %defattr(644,root,root,755)
181 %dir %{_datadir}/ecasound
182 %{_datadir}/ecasound/*
183 %attr(755,root,root) %{_libdir}/libkvutils*.so.*.*
184 %attr(755,root,root) %{_libdir}/libecasound*.so.*.*
185
186 %files -n libecasound-devel
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_bindir}/ecasound-config
189 %attr(755,root,root) %{_bindir}/ecasoundc-config
190 %{_includedir}/ecasound/*
191 %{_includedir}/kvutils/*
192 %attr(755,root,root) %{_libdir}/libkvutils.so
193 %attr(755,root,root) %{_libdir}/libkvutils.la
194 %attr(755,root,root) %{_libdir}/libecasound*.so
195 %attr(755,root,root) %{_libdir}/libecasound*.la
196
197 %files -n libecasound-static
198 %defattr(644,root,root,755)
199 %{_libdir}/libkvutils.a
200 %{_libdir}/libecasound.a
201
202 %files plugins
203 %defattr(644,root,root,755)
204 %dir %{_libdir}/ecasound-plugins
205 %attr(755,root,root) %{_libdir}/ecasound-plugins/lib*.so*
206 %{_libdir}/ecasound-plugins/lib*.la
207 %{_libdir}/ecasound-plugins/lib*.a
208
209 %files -n python-%{name}
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{python_sitepkgsdir}/*.so
212 %{python_sitepkgsdir}/*.pyo
213 %{python_sitepkgsdir}/*.pyc
This page took 0.089184 seconds and 3 git commands to generate.