]> git.pld-linux.org Git - packages/ecasound.git/blob - ecasound.spec
5eaa4fdb50de496cbfd939c69c76a4f030f23c74
[packages/ecasound.git] / ecasound.spec
1 #
2 # Conditional build:
3 %{?_without_alsa:%global _without_jack 1}
4 %bcond_without  alsa            # without ALSA support (implies without JACK)
5 %bcond_without  jack            # without JACK support
6 %bcond_with     arts            # with aRts support
7 #
8 %include        /usr/lib/rpm/macros.python
9 Summary:        Software package for multitrack audio processing
10 Summary(pl):    Oprogramowanie do wielo¶cie¿kowego przetwarzania d¼wiêku
11 Name:           ecasound
12 Version:        2.3.0
13 Release:        1
14 License:        GPL
15 Group:          Applications/Sound
16 Source0:        http://ecasound.seul.org/download/%{name}-%{version}.tar.gz
17 # Source0-md5:  fb440a68466c8bd6f7bc8a14adf46ef7
18 Patch0:         %{name}-link.patch
19 %{?with_alsa:BuildRequires:     alsa-lib-devel}
20 %{?with_arts:BuildRequires:     arts-devel}
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
24 BuildRequires:  ladspa-devel
25 BuildRequires:  libsamplerate-devel
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtool >= 2:1.4d
28 BuildRequires:  python-devel >= 2.2
29 BuildRequires:  python-modules >= 2.2
30 BuildRequires:  readline-devel >= 4.2
31 BuildRequires:  rpm-pythonprov
32 Obsoletes:      libecasound
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Ecasound is a software package designed for multitrack audio
37 processing. It can be used for simple tasks like audio playback,
38 recording and format conversions, as well as for multitrack effect
39 processing, mixing, recording and signal recycling. Ecasound supports
40 a wide range of audio inputs, outputs and effect algorithms. Several
41 open-source audio packages, like for instance ALSA, OSS, mpg123, lame,
42 libaudiofile and MikMod, are directly supported. One of the advantages
43 of ecasound's chain-based design is that effects can easily be
44 combined both in series and in parallel. Oscillators and MIDI-CCs can
45 be used for controlling effect parameters. Included user-interfaces
46 are ecasound - a versatile console mode interface, qtecasound - a
47 Qt-based X-interface and various command-line utils suitable for batch
48 processing.
49
50 %description -l pl
51 Ecasound jest programem do wielo¶cie¿kowej edycji d¼wiêku, który mo¿e
52 byæ u¿ywany tak do prostych zadañ typu odtwarzanie i nagrywanie muzyki
53 czy te¿ konwersji pomiêdzy formatami plików muzycznych jak i do
54 wielo¶cie¿kowego nak³adania efektów, miksowania (przenikania,
55 wyciszania), nagrywania i odzyskiwania (w domy¶le odszumiania lub
56 wyrzucania zniekszta³ceñ) sygna³u.
57
58 Ecasound wspiera szerok± gamê ¼róde³ i wyj¶æ d¼wiêku oraz algorytmów
59 do jego przetwarzania. Ecasound wspiera wiele wolnych (open source)
60 projektów, takich jak ALSA, OSS, mpg123, lame, libaudiofile czy te¿
61 MikMod. Jedn± z zalet programu ecasound jest mo¿liwo¶æ ³añcuchowego
62 (szeregowego) lub równoleg³ego ³±czenia efektów, które mog± byæ
63 kontrolowane poprzez oscylatory lub MIDI-CC. Pakiet ten zawiera
64 tekstowy interfejs u¿ytkownika oraz kilka innych narzêdzi nadaj±cych
65 siê do przetwarzania wsadowego. Dostêpny jest tak¿e graficzny
66 interfejs u¿ytkownika - qtecasound.
67
68 %package devel
69 Summary:        Header files for ecasound libraries
70 Summary(pl):    Pliki nag³ówkowe bibliotek ecasound
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}
73 Requires:       libsamplerate-devel
74 Requires:       libstdc++-devel
75 Obsoletes:      libecasound-devel
76
77 %description devel
78 Header files for ecasound libraries.
79
80 %description devel -l pl
81 Pliki nag³ówkowe bibliotek ecasound.
82
83 %package static
84 Summary:        Static ecasound libraries
85 Summary(pl):    Statyczne biblioteki ecasound
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}
88 Obsoletes:      libecasound-static
89
90 %description static
91 Static ecasound libraries.
92
93 %description static -l pl
94 Statyczne biblioteki ecasound.
95
96 %package -n python-%{name}
97 Summary:        Python module for Ecasound
98 Summary(pl):    Modu³ jêzyka Python dla programu ecasound
99 Group:          Libraries/Python
100 %pyrequires_eq  python-modules
101
102 %description -n python-%{name}
103 Python module for Ecasound.
104
105 %description -n python-%{name} -l pl
106 Modu³ jêzyka Python dla programu ecasound.
107
108 %prep
109 %setup -q
110 %patch0 -p1
111
112 %build
113 %{__libtoolize}
114 %{__aclocal}
115 %{__autoconf}
116 %{__automake}
117 CXXFLAGS="%{rpmcflags} -D_REENTRANT %{!?debug:-DNDEBUG} -I/usr/include/ncurses"
118 # disable audiofile - ecasound has native support for wav and raw formats
119 # disable oss       - ecasound works nicely with alsa oss emulation;
120 #                     in case of alsa building conditional, the oss should
121 #                     be enabled
122 # disable arts      - 'not really useful' as said by ecasound author
123 %configure \
124         %{!?with_alsa:--disable-alsa} \
125         %{!?with_arts:--disable-arts} \
126         --disable-audiofile \
127         %{!?with_jack:--disable-jack} \
128         %{?with_alsa:--disable-oss} \
129         --enable-samplerate \
130         --enable-sys-readline \
131         --enable-pyecasound \
132         --with-largefile \
133         --with-python-includes=%{py_incdir} \
134         --with-python-modules=%{py_libdir}
135
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140 install -d $RPM_BUILD_ROOT%{py_sitedir}
141
142 %{__make} install \
143         DESTDIR=$RPM_BUILD_ROOT \
144         mandir=%{_mandir}
145
146 install pyecasound/*.py $RPM_BUILD_ROOT%{py_sitedir}
147 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
148 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post   -p /sbin/ldconfig
154 %postun -p /sbin/ldconfig
155
156 %files
157 %defattr(644,root,root,755)
158 %doc BUGS NEWS README TODO
159 %attr(755,root,root) %{_bindir}/eca*
160 %attr(755,root,root) %{_libdir}/lib*.so.*.*
161 %{_datadir}/ecasound
162 %{_mandir}/man1/eca*
163 %{_mandir}/man5/eca*
164
165 %files devel
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_bindir}/*-config
168 %attr(755,root,root) %{_libdir}/lib*.so
169 %{_libdir}/lib*.la
170 %{_includedir}/kvutils
171 %{_includedir}/libecasound
172 %{_includedir}/libecasoundc
173
174 %files static
175 %defattr(644,root,root,755)
176 %{_libdir}/lib*.a
177
178 %files -n python-%{name}
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{py_sitedir}/*.so
181 %{py_sitedir}/*.py[co]
This page took 0.037937 seconds and 2 git commands to generate.