]> git.pld-linux.org Git - packages/ecasound.git/blob - ecasound.spec
- updated to 2.4.6.1
[packages/ecasound.git] / ecasound.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # without ALSA support (implies without JACK)
4 %bcond_without  jack            # without JACK support
5 %bcond_without  ruby            # without ruby support
6 %bcond_with     arts            # with aRts support
7 #
8 Summary:        Software package for multitrack audio processing
9 Summary(pl.UTF-8):      Oprogramowanie do wielościeżkowego przetwarzania dźwięku
10 Name:           ecasound
11 Version:        2.4.6.1
12 Release:        1
13 License:        GPL v2+
14 Group:          Applications/Sound
15 Source0:        http://ecasound.seul.org/download/%{name}-%{version}.tar.gz
16 # Source0-md5:  2bd968cf94405535928cc04143bb89ee
17 Patch0:         %{name}-link.patch
18 URL:            http://ecasound.seul.org/
19 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9.0}
20 %{?with_arts:BuildRequires:     arts-devel}
21 BuildRequires:  autoconf >= 2.50
22 BuildRequires:  automake >= 1.6.1
23 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
24 BuildRequires:  ladspa-devel
25 BuildRequires:  libsamplerate-devel
26 BuildRequires:  libsndfile-devel >= 1.0.12
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtool >= 2:1.4d
29 BuildRequires:  python-devel >= 2.2
30 BuildRequires:  python-modules >= 2.2
31 BuildRequires:  readline-devel >= 5.0
32 %if %{with ruby}
33 BuildRequires:  rpmbuild(macros) >= 1.277
34 BuildRequires:  ruby-devel
35 %endif
36 Obsoletes:      libecasound
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Ecasound is a software package designed for multitrack audio
41 processing. It can be used for simple tasks like audio playback,
42 recording and format conversions, as well as for multitrack effect
43 processing, mixing, recording and signal recycling. Ecasound supports
44 a wide range of audio inputs, outputs and effect algorithms. Several
45 open-source audio packages, like for instance ALSA, OSS, mpg123, lame
46 and MikMod, are directly supported. One of the advantages of
47 ecasound's chain-based design is that effects can easily be combined
48 both in series and in parallel. Oscillators and MIDI-CCs can be used
49 for controlling effect parameters. Included user-interfaces are
50 ecasound - a versatile console mode interface, ecawave - a Qt-based
51 X-interface and various command-line utils suitable for batch
52 processing.
53
54 %description -l pl.UTF-8
55 Ecasound jest programem do wielościeżkowej edycji dźwięku, który może
56 być używany tak do prostych zadań typu odtwarzanie i nagrywanie muzyki
57 czy też konwersji pomiędzy formatami plików muzycznych jak i do
58 wielościeżkowego nakładania efektów, miksowania (przenikania,
59 wyciszania), nagrywania i odzyskiwania (w domyśle odszumiania lub
60 wyrzucania zniekształceń) sygnału.
61
62 Ecasound wspiera szeroką gamę źródeł i wyjść dźwięku oraz algorytmów
63 do jego przetwarzania. Ecasound wspiera wiele wolnych (open source)
64 projektów, takich jak ALSA, OSS, mpg123, lame czy też MikMod. Jedną z
65 zalet programu ecasound jest możliwość łańcuchowego (szeregowego) lub
66 równoległego łączenia efektów, które mogą być kontrolowane poprzez
67 oscylatory lub MIDI-CC. Pakiet ten zawiera tekstowy interfejs
68 użytkownika oraz kilka innych narzędzi nadających się do przetwarzania
69 wsadowego. Dostępny jest także graficzny, oparty na Qt interfejs
70 użytkownika - ecawave.
71
72 %package devel
73 Summary:        Header files for ecasound libraries
74 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek ecasound
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77 %{?with_alsa:Requires:  alsa-lib-devel}
78 %{?with_arts:Requires:  arts-devel}
79 %{?with_jack:Requires:  jack-audio-connection-kit-devel}
80 Requires:       libsamplerate-devel
81 Requires:       libsndfile-devel
82 Requires:       libstdc++-devel
83 Obsoletes:      libecasound-devel
84
85 %description devel
86 Header files for ecasound libraries.
87
88 %description devel -l pl.UTF-8
89 Pliki nagłówkowe bibliotek ecasound.
90
91 %package static
92 Summary:        Static ecasound libraries
93 Summary(pl.UTF-8):      Statyczne biblioteki ecasound
94 Group:          Development/Libraries
95 Requires:       %{name}-devel = %{version}-%{release}
96 Obsoletes:      libecasound-static
97
98 %description static
99 Static ecasound libraries.
100
101 %description static -l pl.UTF-8
102 Statyczne biblioteki ecasound.
103
104 %package -n python-%{name}
105 Summary:        Python module for Ecasound
106 Summary(pl.UTF-8):      Moduł języka Python dla programu ecasound
107 Group:          Libraries/Python
108 Requires:       %{name} = %{version}-%{release}
109 %pyrequires_eq  python-modules
110
111 %description -n python-%{name}
112 Python module for Ecasound.
113
114 %description -n python-%{name} -l pl.UTF-8
115 Moduł języka Python dla programu ecasound.
116
117 %package -n ruby-%{name}
118 Summary:        Ruby module for Ecasound
119 Summary(pl.UTF-8):      Moduł języka Ruby dla programu ecasound
120 Group:          Libraries
121 Requires:       %{name} = %{version}-%{release}
122 %{?ruby_mod_ver_requires_eq}
123
124 %description -n ruby-%{name}
125 Ruby module for Ecasound.
126
127 %description -n ruby-%{name} -l pl.UTF-8
128 Moduł języka Ruby dla programu ecasound.
129
130 %prep
131 %setup -q
132 %patch0 -p1
133
134 %build
135 %{__libtoolize}
136 %{__aclocal}
137 %{__autoconf}
138 %{__automake}
139 CXXFLAGS="%{rpmcflags} -D_REENTRANT %{!?debug:-DNDEBUG} -I/usr/include/ncurses"
140 # disable audiofile - ecasound has native support for wav and raw formats
141 # disable oss       - ecasound works nicely with alsa oss emulation;
142 #                     in case of alsa building conditional, the oss should
143 #                     be enabled
144 # disable arts      - 'not really useful' as said by ecasound author
145 %configure \
146         %{!?with_alsa:--disable-alsa} \
147         %{!?with_arts:--disable-arts} \
148         --disable-audiofile \
149         %{!?with_jack:--disable-jack} \
150         %{?with_alsa:--disable-oss} \
151         --enable-samplerate \
152         --enable-shared \
153         --enable-sys-readline \
154         --enable-pyecasound \
155         --with-largefile \
156         --with-python-includes=%{py_incdir} \
157         --with-python-modules=%{py_libdir}
158
159 %{__make}
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163 install -d $RPM_BUILD_ROOT%{py_sitedir}
164
165 %{__make} install \
166         DESTDIR=$RPM_BUILD_ROOT \
167         mandir=%{_mandir}
168
169 install pyecasound/*.py $RPM_BUILD_ROOT%{py_sitedir}
170 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
171 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
172 %py_postclean
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %post   -p /sbin/ldconfig
178 %postun -p /sbin/ldconfig
179
180 %files
181 %defattr(644,root,root,755)
182 %doc BUGS NEWS README TODO
183 %attr(755,root,root) %{_bindir}/eca*
184 %attr(755,root,root) %{_libdir}/lib*.so.*.*
185 %{_datadir}/ecasound
186 %{_mandir}/man1/eca*
187 %{_mandir}/man5/eca*
188
189 %files devel
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_bindir}/*-config
192 %attr(755,root,root) %{_libdir}/lib*.so
193 %{_libdir}/lib*.la
194 %{_includedir}/kvutils
195 %{_includedir}/libecasound
196 %{_includedir}/libecasoundc
197
198 %files static
199 %defattr(644,root,root,755)
200 %{_libdir}/lib*.a
201
202 %files -n python-%{name}
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{py_sitedir}/*.so
205 %{py_sitedir}/*.py[co]
206
207 %if %{with ruby}
208 %files -n ruby-%{name}
209 %defattr(644,root,root,755)
210 %{ruby_sitelibdir}/ecasound.rb
211 %endif
This page took 0.080154 seconds and 3 git commands to generate.