]> git.pld-linux.org Git - packages/ecasound.git/blob - ecasound.spec
- massive attack: adding Source-md5
[packages/ecasound.git] / ecasound.spec
1 #
2 # todo:
3 # - jack-audio-connection-kit support
4 #
5
6 #
7 # Conditional build:
8 # _without_alsa - without ALSA support
9 #
10
11 %include        /usr/lib/rpm/macros.python
12
13 Summary:        Software package for multitrack audio processing
14 Summary(pl):    Oprogramowanie do wielo¶cie¿kowego przetwarzania d¼wiêku
15 Name:           ecasound
16 Version:        2.2.3
17 Release:        1
18 License:        GPL
19 Group:          Applications/Sound
20 Source0:        http://ecasound.seul.org/download/%{name}-%{version}.tar.gz
21 # Source0-md5:  40a3f0213c30b18e1b4e7879faa6b454
22 Patch0:         %{name}-link.patch
23 %ifnarch sparc sparc64
24 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
25 %endif
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  ladspa-devel
29 BuildRequires:  libsamplerate-devel
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libtool >= 2:1.4d
32 BuildRequires:  python-devel >= 2.2
33 BuildRequires:  python-modules >= 2.2
34 BuildRequires:  readline-devel >= 4.2
35 BuildRequires:  rpm-pythonprov
36 Obsoletes:      libecasound
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Ecasound is a software package designed for multitrack audio
41 processing. It can be used for simple tasks like audio playback,
42 recording and format conversions, as well as for multitrack effect
43 processing, mixing, recording and signal recycling. Ecasound supports
44 a wide range of audio inputs, outputs and effect algorithms. Several
45 open-source audio packages, like for instance ALSA, OSS, mpg123, lame,
46 libaudiofile and MikMod, are directly supported. One of the advantages
47 of ecasound's chain-based design is that effects can easily be
48 combined both in series and in parallel. Oscillators and MIDI-CCs can
49 be used for controlling effect parameters. Included user-interfaces
50 are ecasound - a versatile console mode interface, qtecasound - a
51 Qt-based X-interface and various command-line utils suitable for batch
52 processing.
53
54 %description -l pl
55 Ecasound jest programem do wielo¶cie¿kowej edycji d¼wiêku, który mo¿e
56 byæ u¿ywany tak do prostych zadañ typu odtwarzanie i nagrywanie muzyki
57 czy te¿ konwersji pomiêdzy formatami plików muzycznych jak i do
58 wielo¶cie¿kowego nak³adania efektów, miksowania (przenikania,
59 wyciszania), nagrywania i odzyskiwania (w domy¶le odszumiania lub
60 wyrzucania zniekszta³ceñ) sygna³u.
61
62 Ecasound wspiera szerok± gamê ¼róde³ i wyj¶æ d¼wiêku oraz algorytmów
63 do jego przetwarzania. Ecasound wspiera wiele wolnych (open source)
64 projektów, takich jak ALSA, OSS, mpg123, lame, libaudiofile czy te¿
65 MikMod. Jedn± z zalet programu ecasound jest mo¿liwo¶æ ³añcuchowego
66 (szeregowego) lub równoleg³ego ³±czenia efektów, które mog± byæ
67 kontrolowane poprzez oscylatory lub MIDI-CC. Pakiet ten zawiera
68 tekstowy interfejs u¿ytkownika oraz kilka innych narzêdzi nadaj±cych
69 siê do przetwarzania wsadowego. Dostêpny jest tak¿e graficzny
70 interfejs u¿ytkownika - qtecasound.
71
72 %package devel
73 Summary:        Header files for ecasound libraries
74 Summary(pl):    Pliki nag³ówkowe bibliotek ecasound
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}
77 Obsoletes:      libecasound-devel
78
79 %description devel
80 Header files for ecasound libraries.
81
82 %description devel -l pl
83 Pliki nag³ówkowe bibliotek ecasound.
84
85 %package static
86 Summary:        Static ecasound libraries
87 Summary(pl):    Statyczne biblioteki ecasound
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}
90 Obsoletes:      libecasound-static
91
92 %description static
93 Static ecasound libraries.
94
95 %description static -l pl
96 Statyczne biblioteki ecasound.
97
98 %package -n python-%{name}
99 Summary:        Python module for Ecasound
100 Summary(pl):    Modu³ jêzyka Python dla programu ecasound
101 Group:          Libraries/Python
102 %pyrequires_eq  python-modules
103
104 %description -n python-%{name}
105 Python module for Ecasound.
106
107 %description -n python-%{name} -l pl
108 Modu³ jêzyka Python dla programu ecasound.
109
110 %prep
111 %setup -q
112 %patch0 -p1
113
114 %build
115 rm -f missing
116 %{__libtoolize}
117 %{__aclocal}
118 %{__autoconf}
119 %{__automake}
120 CXXFLAGS="%{rpmcflags} -D_REENTRANT %{!?debug:-DNDEBUG} -I/usr/include/ncurses"
121 # disable audiofile - ecasound has native support for wav and raw formats
122 # disable oss       - ecasound works nicely with alsa oss emulation;
123 #                     in case of alsa building conditional, the oss should
124 #                     be enabled
125 # disable arts      - 'not really useful' as said by ecasound author
126 %configure \
127         --enable-sys-readline \
128         --with-python-includes=%{py_incdir} \
129         --with-python-modules=%{py_libdir} \
130         --disable-audiofile \
131         --disable-arts \
132         %{?_without_alsa:--disable-alsa} \
133         %{!?_without_alsa:--disable-oss} \
134         --enable-pyecasound \
135         --enable-samplerate \
136         --with-largefile
137
138 %{__make}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142 install -d $RPM_BUILD_ROOT%{py_sitedir}
143
144 %{__make} DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
145
146 install pyecasound/*.py $RPM_BUILD_ROOT%{py_sitedir}
147 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
148 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post   -p /sbin/ldconfig
154 %postun -p /sbin/ldconfig
155
156 %files
157 %defattr(644,root,root,755)
158 %doc BUGS NEWS README TODO
159 %attr(755,root,root) %{_bindir}/eca*
160 %attr(755,root,root) %{_libdir}/lib*.so.*.*
161
162 %{_datadir}/ecasound
163
164 %{_mandir}/man1/eca*
165 %{_mandir}/man5/eca*
166
167 %files devel
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_bindir}/*-config
170 %attr(755,root,root) %{_libdir}/lib*.so
171 %{_libdir}/lib*.la
172 %{_includedir}/kvutils
173 %{_includedir}/libecasound
174 %{_includedir}/libecasoundc
175
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/lib*.a
179
180 %files -n python-%{name}
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{py_sitedir}/*.so
183 %{py_sitedir}/*.py[co]
This page took 0.126531 seconds and 3 git commands to generate.