]> git.pld-linux.org Git - packages/ebtables.git/blame - ebtables.spec
- release 2
[packages/ebtables.git] / ebtables.spec
CommitLineData
91ae9d30 1#
2# TODO:
3# - initscripts stuff - move save/restore dumps to /etc/sysconfig & more
4# - review llh patch
5#
ee8c1a77 6%define _rel 2
a3a71278 7%define _pre 2
642984f6 8Summary: Ethernet Bridge Tables
c15a9ec1 9Summary(pl.UTF-8): Ethernet Bridge Tables - filtrowanie i translacja adresów dla Ethernetu
642984f6 10Name: ebtables
91ae9d30 11Version: 2.0.8
7dfef2e8 12Release: 0.%{_pre}.%{_rel}
642984f6 13License: GPL
14Group: Networking/Daemons
7dfef2e8 15Source0: http://dl.sourceforge.net/ebtables/%{name}-v%{version}-%{_pre}.tar.gz
a3a71278 16# Source0-md5: 66bcbcb2dcf3b981ad4e86e1720e796e
b7afe0f5 17URL: http://ebtables.sourceforge.net/
7dfef2e8
ER
18BuildRequires: rpmbuild(macros) >= 1.268
19Requires(post,preun): /sbin/chkconfig
20Requires: rc-scripts
642984f6 21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24The ebtables project is the Linux 2.5.x (and above) Link Layer
25firewalling subsystem, a patch for 2.4.x is maintained too. It
26delivers for Linux the functionality of Ethernet frame filtering, all
27kinds of frame NAT (Network Address Translation) and frame matching.
28The ebtables infrastructure is a part of the standard Linux 2.5.x (and
29above) kernels.
30
ecac19ab
JR
31%description -l pl.UTF-8
32Projekt ebtables to podsystem firewallingu na poziomie łącza dla
33Linuksa w wersjach 2.5.x i nowszych (dostępna jest też łata do 2.4.x).
34Dostarcza dla Linuksa funkcjonalność filtrowania ramek ethernetowych,
35wszystkie rodzaje translacji adresów (NAT) dla ramek oraz
36dopasowywanie ramek. Infrastruktura ebtables jest częścią
37standardowych jąder Linuksa w wersjach 2.5.x i nowszych.
b7afe0f5 38
642984f6 39%prep
9f11835a 40%setup -q -n %{name}-v%{version}-%{_pre}
642984f6 41
42%build
7dfef2e8
ER
43%{__make} \
44 CC="%{__cc}"
642984f6 45
46%install
47rm -rf $RPM_BUILD_ROOT
91ae9d30 48
49install -d $RPM_BUILD_ROOT%{_sbindir}
50install -d $RPM_BUILD_ROOT%{_sysconfdir}
ee927896 51install -d $RPM_BUILD_ROOT/etc/sysconfig
91ae9d30 52install -d $RPM_BUILD_ROOT%{_mandir}/man8
53install -d $RPM_BUILD_ROOT%{_libdir}/ebtables
ee927896 54install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
91ae9d30 55
56install ebtables $RPM_BUILD_ROOT%{_sbindir}
57install ebtables-restore $RPM_BUILD_ROOT%{_sbindir}
58install ethertypes $RPM_BUILD_ROOT%{_sysconfdir}
59install ebtables.8 $RPM_BUILD_ROOT%{_mandir}/man8
60install extensions/*.so $RPM_BUILD_ROOT%{_libdir}/ebtables
61install *.so $RPM_BUILD_ROOT%{_libdir}/ebtables
62
63export __iets=`printf %{_sbindir} | sed 's/\\//\\\\\\//g'`
64export __iets2=`printf %{_mysysconfdir} | sed 's/\\//\\\\\\//g'`
65sed -i "s/__EXEC_PATH__/$__iets/g" ebtables-save
66install ebtables-save $RPM_BUILD_ROOT%{_sbindir}
67sed -i "s/__EXEC_PATH__/$__iets/g" ebtables.sysv; sed -i "s/__SYSCONFIG__/$__iets2/g" ebtables.sysv
ee927896 68install ebtables.sysv $RPM_BUILD_ROOT/etc/rc.d/init.d/ebtables
91ae9d30 69sed -i "s/__SYSCONFIG__/$__iets2/g" ebtables-config
ee927896 70install ebtables-config $RPM_BUILD_ROOT/etc/sysconfig
642984f6 71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
91ae9d30 75%post
76/sbin/chkconfig --add ebtables
77
78%preun
79if [ $1 -eq 0 ]; then
7dfef2e8 80 %service ebtables stop
91ae9d30 81 /sbin/chkconfig --del ebtables
82fi
83
642984f6 84%files
85%defattr(644,root,root,755)
ee927896
JB
86%doc ChangeLog INSTALL THANKS
87%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ethertypes
88%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ebtables-config
b8bbfb8b 89%attr(754,root,root) /etc/rc.d/init.d/ebtables
642984f6 90%attr(755,root,root) %{_sbindir}/*
ee927896
JB
91%dir %{_libdir}/ebtables
92%attr(755,root,root) %{_libdir}/ebtables/*.so
93%{_mandir}/man8/ebtables.8*
This page took 0.169185 seconds and 4 git commands to generate.