]> git.pld-linux.org Git - packages/eb.git/blob - eb.spec
51d648d70e24a86700b444ec8fb471d2476f4ff9
[packages/eb.git] / eb.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        Library for accessing CD-ROM books
7 Summary(pl.UTF-8):      Biblioteka dostępu do książek na płytach CD-ROM
8 Name:           eb
9 Version:        4.4.3
10 Release:        5
11 License:        BSD
12 Group:          Libraries
13 Source0:        ftp://ftp.sra.co.jp/pub/misc/eb/%{name}-%{version}.tar.bz2
14 # Source0-md5:  17dd1fade7ba0b82ce6e60f19fcbc823
15 Patch0:         %{name}-link.patch
16 URL:            https://github.com/yasuhirokimura/eb
17 BuildRequires:  autoconf >= 2.54
18 BuildRequires:  automake
19 BuildRequires:  libtool
20 BuildRequires:  zlib-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 EB Library supports to access CD-ROM books of EB, EBG, EBXA, EBXA-C,
25 S-EBXA and EPWING formats. CD-ROM books of those formats are popular
26 in Japan. Since CD-ROM books themseves are stands on the ISO 9660
27 format, you can mount the discs by the same way as other ISO 9660
28 discs.
29
30 %description -l pl.UTF-8
31 Biblioteka EB pozwala na dostęp do książek na płytach CD-ROM w
32 formatach EB, EBG, EBXA, EBXA-C, S-EBXA oraz EPWING. Książki w tych
33 formatach są popularne w Japonii. Ponieważ książki na płytach jako
34 takie są plikami zapisanymi w formacie ISO 9660, można montować takie
35 płyty w taki sam sposób, jak inne płyty ISO 9660.
36
37 %package utils
38 Summary:        Utilities provided by EB library
39 Summary(pl.UTF-8):      Narzędzia dostarczane przez bibliotekę EB
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description utils
44 Utilities provided by EB library.
45
46 %description utils -l pl.UTF-8
47 Narzędzia dostarczane przez bibliotekę EB.
48
49 %package devel
50 Summary:        Header files for EB library
51 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki EB
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54
55 %description devel
56 Header files for EB library.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe biblioteki EB.
60
61 %package static
62 Summary:        Static EB library
63 Summary(pl.UTF-8):      Statyczna biblioteka EB
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static EB library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka EB.
72
73 %package apidocs
74 Summary:        EB API documentation
75 Summary(pl.UTF-8):      Dokumentacja API biblioteki EB
76 Group:          Documentation
77 %if "%{_rpmversion}" >= "4.6"
78 BuildArch:      noarch
79 %endif
80
81 %description apidocs
82 API and internal documentation for EB library.
83
84 %description apidocs -l pl.UTF-8
85 Dokumentacja API biblioteki EB.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90
91 %build
92 %{__libtoolize}
93 %{__aclocal} -I m4
94 %{__autoconf}
95 %{__autoheader}
96 %{__automake}
97 %configure \
98         --enable-samples \
99         --enable-pthread \
100         --enable-ebnet \
101         --enable-ipv6 \
102         --with-pkgdocdir=%{_docdir}/%{name}-apidocs-%{version} \
103         %{!?with_static_libs:--disable-static}
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 %find_lang %{name}
113 %find_lang ebutils
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files -f %{name}.lang
122 %defattr(644,root,root,755)
123 %doc AUTHORS ChangeLog* NEWS README
124 %attr(755,root,root) %{_libdir}/libeb.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libeb.so.16
126
127 %files utils -f ebutils.lang
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_bindir}/ebappendix
130 %attr(755,root,root) %{_bindir}/ebfont
131 %attr(755,root,root) %{_bindir}/ebinfo
132 %attr(755,root,root) %{_bindir}/ebrefile
133 %attr(755,root,root) %{_bindir}/ebstopcode
134 %attr(755,root,root) %{_bindir}/ebunzip
135 %attr(755,root,root) %{_bindir}/ebzip
136 %attr(755,root,root) %{_bindir}/ebzipinfo
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/libeb.so
141 %{_libdir}/libeb.la
142 %{_includedir}/eb
143 %{_sysconfdir}/eb.conf
144 %{_aclocaldir}/eb4.m4
145
146 %if %{with static_libs}
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libeb.a
150 %endif
151
152 %if %{with apidocs}
153 %files apidocs
154 %defattr(644,root,root,755)
155 %doc %{_docdir}/%{name}-apidocs-%{version}
156 %endif
This page took 0.04458 seconds and 2 git commands to generate.