]> git.pld-linux.org Git - packages/eb.git/blob - eb.spec
1adabf4371211ad7ba5a50b4f79bc2d8fc5a375d
[packages/eb.git] / eb.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        Library for accessing CD-ROM books
7 Summary(pl.UTF-8):      Biblioteka dostępu do książek na płytach CD-ROM
8 Name:           eb
9 Version:        4.4.3
10 Release:        3
11 License:        BSD
12 Group:          Libraries
13 Source0:        ftp://ftp.sra.co.jp/pub/misc/eb/%{name}-%{version}.tar.bz2
14 # Source0-md5:  17dd1fade7ba0b82ce6e60f19fcbc823
15 URL:            http://www.sra.co.jp/people/m-kasahr/eb/
16 BuildRequires:  zlib-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 EB Library supports to access CD-ROM books of EB, EBG, EBXA, EBXA-C,
21 S-EBXA and EPWING formats. CD-ROM books of those formats are popular
22 in Japan. Since CD-ROM books themseves are stands on the ISO 9660
23 format, you can mount the discs by the same way as other ISO 9660
24 discs.
25
26 %description -l pl.UTF-8
27 Biblioteka EB pozwala na dostęp do książek na płytach CD-ROM w
28 formatach EB, EBG, EBXA, EBXA-C, S-EBXA oraz EPWING. Książki w tych
29 formatach są popularne w Japonii. Ponieważ książki na płytach jako
30 takie są plikami zapisanymi w formacie ISO 9660, można montować takie
31 płyty w taki sam sposób, jak inne płyty ISO 9660.
32
33 %package utils
34 Summary:        Utilities provided by EB library
35 Summary(pl.UTF-8):      Narzędzia dostarczane przez bibliotekę EB
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description utils
40 Utilities provided by EB library.
41
42 %description utils -l pl.UTF-8
43 Narzędzia dostarczane przez bibliotekę EB.
44
45 %package devel
46 Summary:        Header files for EB library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki EB
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50
51 %description devel
52 Header files for EB library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki EB.
56
57 %package static
58 Summary:        Static EB library
59 Summary(pl.UTF-8):      Statyczna biblioteka EB
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static EB library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka EB.
68
69 %package apidocs
70 Summary:        EB API documentation
71 Summary(pl.UTF-8):      Dokumentacja API biblioteki EB
72 Group:          Documentation
73 %if "%{_rpmversion}" >= "5"
74 BuildArch:      noarch
75 %endif
76
77 %description apidocs
78 API and internal documentation for EB library.
79
80 %description apidocs -l pl.UTF-8
81 Dokumentacja API biblioteki EB.
82
83 %prep
84 %setup -q
85
86 %build
87 %configure \
88         --enable-samples \
89         --enable-pthread \
90         --enable-ebnet \
91         --enable-ipv6 \
92         --with-pkgdocdir=%{_docdir}/%{name}-apidocs-%{version} \
93         %{!?with_static_libs:--disable-static}
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %find_lang %{name}
103 %find_lang ebutils
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   -p /sbin/ldconfig
109 %postun -p /sbin/ldconfig
110
111 %files -f %{name}.lang
112 %defattr(644,root,root,755)
113 %doc AUTHORS ChangeLog* NEWS README
114 %attr(755,root,root) %{_libdir}/libeb.so.*.*.*
115 %attr(755,root,root) %ghost %{_libdir}/libeb.so.16
116
117 %files utils -f ebutils.lang
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_bindir}/ebappendix
120 %attr(755,root,root) %{_bindir}/ebfont
121 %attr(755,root,root) %{_bindir}/ebinfo
122 %attr(755,root,root) %{_bindir}/ebrefile
123 %attr(755,root,root) %{_bindir}/ebstopcode
124 %attr(755,root,root) %{_bindir}/ebunzip
125 %attr(755,root,root) %{_bindir}/ebzip
126 %attr(755,root,root) %{_bindir}/ebzipinfo
127
128 %files devel
129 %defattr(644,root,root,755)
130 %{_sysconfdir}/eb.conf
131 %attr(755,root,root) %{_libdir}/libeb.so
132 %{_libdir}/libeb.la
133 %{_includedir}/eb
134 %{_aclocaldir}/eb4.m4
135
136 %if %{with static_libs}
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/libeb.a
140 %endif
141
142 %if %{with apidocs}
143 %files apidocs
144 %defattr(644,root,root,755)
145 %doc %{_docdir}/%{name}-apidocs-%{version}
146 %endif
This page took 0.061994 seconds and 3 git commands to generate.