]> git.pld-linux.org Git - packages/easytag.git/commitdiff
- initial release
authorMichal Chruszcz <mchruszcz@gmail.com>
Sun, 7 Dec 2003 07:25:21 +0000 (07:25 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    easytag-0.30a.patch -> 1.1
    easytag-0.30b.patch -> 1.1
    easytag-0.30c.patch -> 1.1

easytag-0.30a.patch [new file with mode: 0644]
easytag-0.30b.patch [new file with mode: 0644]
easytag-0.30c.patch [new file with mode: 0644]

diff --git a/easytag-0.30a.patch b/easytag-0.30a.patch
new file mode 100644 (file)
index 0000000..549badd
--- /dev/null
@@ -0,0 +1,142 @@
+diff -ruN easytag-0.30/configure easytag-0.30a/configure
+--- easytag-0.30/configure     Sun Sep  7 11:36:27 2003
++++ easytag-0.30a/configure    Sat Sep 27 20:36:48 2003
+@@ -1,6 +1,6 @@
+ #! /bin/sh
+ # Guess values for system-dependent variables and create Makefiles.
+-# Generated by GNU Autoconf 2.53 for easytag 0.30.
++# Generated by GNU Autoconf 2.53 for easytag 0.30a.
+ #
+ # Copyright 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001, 2002
+ # Free Software Foundation, Inc.
+@@ -412,8 +412,8 @@
+ # Identity of this package.
+ PACKAGE_NAME='easytag'
+ PACKAGE_TARNAME='easytag'
+-PACKAGE_VERSION='0.30'
+-PACKAGE_STRING='easytag 0.30'
++PACKAGE_VERSION='0.30a'
++PACKAGE_STRING='easytag 0.30a'
+ PACKAGE_BUGREPORT=''
+ ac_unique_file="src/easytag.h"
+@@ -918,7 +918,7 @@
+   # Omit some internal or obsolete options to make the list less imposing.
+   # This message is too long to be a string in the A/UX 3.1 sh.
+   cat <<_ACEOF
+-\`configure' configures easytag 0.30 to adapt to many kinds of systems.
++\`configure' configures easytag 0.30a to adapt to many kinds of systems.
+ Usage: $0 [OPTION]... [VAR=VALUE]...
+@@ -984,7 +984,7 @@
+ if test -n "$ac_init_help"; then
+   case $ac_init_help in
+-     short | recursive ) echo "Configuration of easytag 0.30:";;
++     short | recursive ) echo "Configuration of easytag 0.30a:";;
+    esac
+   cat <<\_ACEOF
+@@ -1092,7 +1092,7 @@
+ test -n "$ac_init_help" && exit 0
+ if $ac_init_version; then
+   cat <<\_ACEOF
+-easytag configure 0.30
++easytag configure 0.30a
+ generated by GNU Autoconf 2.53
+ Copyright 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001, 2002
+@@ -1107,7 +1107,7 @@
+ This file contains any messages produced by compilers while
+ running configure, to aid debugging if configure makes a mistake.
+-It was created by easytag $as_me 0.30, which was
++It was created by easytag $as_me 0.30a, which was
+ generated by GNU Autoconf 2.53.  Invocation command line was
+   $ $0 $@
+@@ -1639,7 +1639,7 @@
+ # Define the identity of the package.
+  PACKAGE=easytag
+- VERSION=0.30
++ VERSION=0.30a
+ cat >>confdefs.h <<_ACEOF
+@@ -12653,7 +12653,7 @@
+ } >&5
+ cat >&5 <<_CSEOF
+-This file was extended by easytag $as_me 0.30, which was
++This file was extended by easytag $as_me 0.30a, which was
+ generated by GNU Autoconf 2.53.  Invocation command line was
+   CONFIG_FILES    = $CONFIG_FILES
+@@ -12715,7 +12715,7 @@
+ cat >>$CONFIG_STATUS <<_ACEOF
+ ac_cs_version="\\
+-easytag config.status 0.30
++easytag config.status 0.30a
+ configured by $0, generated by GNU Autoconf 2.53,
+   with options \\"`echo "$ac_configure_args" | sed 's/[\\""\`\$]/\\\\&/g'`\\"
+diff -ruN easytag-0.30/configure.in easytag-0.30a/configure.in
+--- easytag-0.30/configure.in  Sun Sep  7 11:30:52 2003
++++ easytag-0.30a/configure.in Sat Sep 27 20:36:16 2003
+@@ -6,7 +6,7 @@
+ dnl VERSION=0.28
+ AC_PREREQ(2.53)
+-AC_INIT(easytag, 0.30) dnl defines ($PACKAGE, $VERSION)
++AC_INIT(easytag, 0.30a) dnl defines ($PACKAGE, $VERSION)
+ AC_CONFIG_SRCDIR(src/easytag.h)
+ dnl -------------------------------
+ dnl Init automake
+diff -ruN easytag-0.30/easytag.spec easytag-0.30a/easytag.spec
+--- easytag-0.30/easytag.spec  Sun Sep  7 11:36:43 2003
++++ easytag-0.30a/easytag.spec Sat Sep 27 20:36:01 2003
+@@ -1,5 +1,5 @@
+ %define    name      easytag
+-%define    version   0.30
++%define    version   0.30a
+ %define    release   1
+ %define    prefix    /usr
+diff -ruN easytag-0.30/src/scan.c easytag-0.30a/src/scan.c
+--- easytag-0.30/src/scan.c    Sat Sep  6 22:14:57 2003
++++ easytag-0.30a/src/scan.c   Sat Sep 27 20:35:32 2003
+@@ -673,15 +673,6 @@
+     if (!ETFile || !mask) return NULL;
+-    /* Replace characters */
+-    if (CONVERT_UNDERSCORE_AND_P20_INTO_SPACE)
+-    {
+-        Scan_Convert_Underscore_Into_Space(mask);
+-        Scan_Convert_P20_Into_Space(mask);
+-    }
+-    if (CONVERT_SPACE_INTO_UNDERSCORE)
+-        Scan_Convert_Space_Into_Undescore(mask);
+-
+     /*
+      * Parse the codes to generate a list (1rst item = 1rst code)
+@@ -799,6 +790,15 @@
+     // Free the list
+     Scan_Free_File_Rename_List(rename_file_list);
++    /* Replace characters */
++    if (CONVERT_UNDERSCORE_AND_P20_INTO_SPACE)
++    {
++        Scan_Convert_Underscore_Into_Space(filename_new);
++        Scan_Convert_P20_Into_Space(filename_new);
++    }
++    if (CONVERT_SPACE_INTO_UNDERSCORE)
++        Scan_Convert_Space_Into_Undescore(filename_new);
++
+     return filename_new;
+ }
diff --git a/easytag-0.30b.patch b/easytag-0.30b.patch
new file mode 100644 (file)
index 0000000..40b5f47
--- /dev/null
@@ -0,0 +1,270 @@
+diff -ruN easytag-0.30a/configure easytag-0.30b/configure
+--- easytag-0.30a/configure    Sat Oct 18 19:18:41 2003
++++ easytag-0.30b/configure    Sat Oct 18 19:21:15 2003
+@@ -1,6 +1,6 @@
+ #! /bin/sh
+ # Guess values for system-dependent variables and create Makefiles.
+-# Generated by GNU Autoconf 2.53 for easytag 0.30a.
++# Generated by GNU Autoconf 2.53 for easytag 0.30b.
+ #
+ # Copyright 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001, 2002
+ # Free Software Foundation, Inc.
+@@ -412,8 +412,8 @@
+ # Identity of this package.
+ PACKAGE_NAME='easytag'
+ PACKAGE_TARNAME='easytag'
+-PACKAGE_VERSION='0.30a'
+-PACKAGE_STRING='easytag 0.30a'
++PACKAGE_VERSION='0.30b'
++PACKAGE_STRING='easytag 0.30b'
+ PACKAGE_BUGREPORT=''
+ ac_unique_file="src/easytag.h"
+@@ -918,7 +918,7 @@
+   # Omit some internal or obsolete options to make the list less imposing.
+   # This message is too long to be a string in the A/UX 3.1 sh.
+   cat <<_ACEOF
+-\`configure' configures easytag 0.30a to adapt to many kinds of systems.
++\`configure' configures easytag 0.30b to adapt to many kinds of systems.
+ Usage: $0 [OPTION]... [VAR=VALUE]...
+@@ -984,7 +984,7 @@
+ if test -n "$ac_init_help"; then
+   case $ac_init_help in
+-     short | recursive ) echo "Configuration of easytag 0.30a:";;
++     short | recursive ) echo "Configuration of easytag 0.30b:";;
+    esac
+   cat <<\_ACEOF
+@@ -1092,7 +1092,7 @@
+ test -n "$ac_init_help" && exit 0
+ if $ac_init_version; then
+   cat <<\_ACEOF
+-easytag configure 0.30a
++easytag configure 0.30b
+ generated by GNU Autoconf 2.53
+ Copyright 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001, 2002
+@@ -1107,7 +1107,7 @@
+ This file contains any messages produced by compilers while
+ running configure, to aid debugging if configure makes a mistake.
+-It was created by easytag $as_me 0.30a, which was
++It was created by easytag $as_me 0.30b, which was
+ generated by GNU Autoconf 2.53.  Invocation command line was
+   $ $0 $@
+@@ -1639,7 +1639,7 @@
+ # Define the identity of the package.
+  PACKAGE=easytag
+- VERSION=0.30a
++ VERSION=0.30b
+ cat >>confdefs.h <<_ACEOF
+@@ -12653,7 +12653,7 @@
+ } >&5
+ cat >&5 <<_CSEOF
+-This file was extended by easytag $as_me 0.30a, which was
++This file was extended by easytag $as_me 0.30b, which was
+ generated by GNU Autoconf 2.53.  Invocation command line was
+   CONFIG_FILES    = $CONFIG_FILES
+@@ -12715,7 +12715,7 @@
+ cat >>$CONFIG_STATUS <<_ACEOF
+ ac_cs_version="\\
+-easytag config.status 0.30a
++easytag config.status 0.30b
+ configured by $0, generated by GNU Autoconf 2.53,
+   with options \\"`echo "$ac_configure_args" | sed 's/[\\""\`\$]/\\\\&/g'`\\"
+diff -ruN easytag-0.30a/configure.in easytag-0.30b/configure.in
+--- easytag-0.30a/configure.in Sat Oct 18 19:18:41 2003
++++ easytag-0.30b/configure.in Sat Oct 18 19:21:39 2003
+@@ -6,7 +6,7 @@
+ dnl VERSION=0.28
+ AC_PREREQ(2.53)
+-AC_INIT(easytag, 0.30a) dnl defines ($PACKAGE, $VERSION)
++AC_INIT(easytag, 0.30b) dnl defines ($PACKAGE, $VERSION)
+ AC_CONFIG_SRCDIR(src/easytag.h)
+ dnl -------------------------------
+ dnl Init automake
+diff -ruN easytag-0.30a/easytag.spec easytag-0.30b/easytag.spec
+--- easytag-0.30a/easytag.spec Sat Oct 18 19:18:41 2003
++++ easytag-0.30b/easytag.spec Sat Oct 18 19:21:53 2003
+@@ -1,5 +1,5 @@
+ %define    name      easytag
+-%define    version   0.30a
++%define    version   0.30b
+ %define    release   1
+ %define    prefix    /usr
+diff -ruN easytag-0.30a/src/browser.c easytag-0.30b/src/browser.c
+--- easytag-0.30a/src/browser.c        Sat Sep  6 23:03:48 2003
++++ easytag-0.30b/src/browser.c        Sat Oct 18 19:26:44 2003
+@@ -558,7 +558,7 @@
+             switch(button)
+             {
+                 case BUTTON_YES:
+-                    if (Save_Selected_Files_With_Answer()==-1) return;
++                    if (Save_All_Files_With_Answer()==-1) return;
+                     break;
+                 case BUTTON_NO:
+                     break;
+diff -ruN easytag-0.30a/src/easytag.c easytag-0.30b/src/easytag.c
+--- easytag-0.30a/src/easytag.c        Sun Sep  7 01:02:34 2003
++++ easytag-0.30b/src/easytag.c        Sat Oct 18 19:53:01 2003
+@@ -92,8 +92,9 @@
+ void Rename_File      (ET_File *ETFile);
+ gint Save_File        (ET_File *ETFile, gboolean multiple_files);
+ gint Delete_File      (ET_File *ETFile, gboolean multiple_files);
+-gint Save_File_With_Answer             (gboolean multiple_files);
++gint Save_Selected_Files_With_Answer   (void);
+ gint Save_All_Files_With_Answer        (void);
++gint Save_List_Of_Files                (GList *etfilelist);
+ gint Delete_Selected_Files_With_Answer (void);
+ void Display_Usage (void);
+@@ -1247,12 +1248,6 @@
+ /*
+- * Save_File_With_Answer: Function to save single/multiple file(s).
+- *  - multiple_files = TRUE : when saving files, a msgbox appears with ability 
+- *                            to do the same action for all files.
+- *  - multiple_files = FALSE : appears only a msgbox to ak confirmation.
+- */
+-/*
+  * Action when Save button is pressed
+  */
+ void Action_Save_Selected_Files (void)
+@@ -1261,16 +1256,36 @@
+ }
++gint Save_All_Files_With_Answer (void)
++{
++    GList *etfilelist;
++
++    if (!ETFileList) return FALSE;
++    etfilelist = g_list_first(ETFileList);
++    return Save_List_Of_Files(etfilelist);
++}
++
+ gint Save_Selected_Files_With_Answer (void)
+ {
+-    gint   progress_bar_index;
+-    gint   saving_answer;
++    GList *etfilelist;
++
++    etfilelist = ET_File_List_Get_Selection();
++    return Save_List_Of_Files(etfilelist);
++}
++
++/*
++ * Save_List_Of_Files: Function to save a list of files.
++ */
++gint Save_List_Of_Files (GList *etfilelist)
++{
++    gint       progress_bar_index;
++    gint       saving_answer;
++    gint       nb_files_to_save;
++    gchar     *msg;
++    GList     *etfilelist_tmp;
+     ET_File   *etfile_save_position = NULL;
+     File_Tag  *FileTag;
+     File_Name *FileNameNew;
+-    GList *etfilelist;
+-    gint   nb_files_to_save;
+-    gchar *msg;
+     if (!ETFileList) return FALSE;
+@@ -1283,15 +1298,15 @@
+     /* Count the number of files to save */
+     nb_files_to_save = 0;
+-    etfilelist = ET_File_List_Get_Selection();
+-    while (etfilelist)
++    etfilelist_tmp = etfilelist;
++    while (etfilelist_tmp)
+     {
+-        File_Tag  *filetag  = ((ET_File *)etfilelist->data)->FileTag->data;
+-        File_Name *filename = ((ET_File *)etfilelist->data)->FileNameNew->data;
++        File_Tag  *filetag  = ((ET_File *)etfilelist_tmp->data)->FileTag->data;
++        File_Name *filename = ((ET_File *)etfilelist_tmp->data)->FileNameNew->data;
+         if ( (filename && filename->saved==FALSE) || (filetag && filetag->saved==FALSE) )
+             nb_files_to_save++;
+-        etfilelist = etfilelist->next;
++        etfilelist_tmp = etfilelist_tmp->next;
+     }
+     /* Initialize status bar */
+@@ -1312,24 +1327,24 @@
+     Main_Stop_Button_Pressed = 0;
+     gtk_widget_set_sensitive(TBStopButton,TRUE);
+     
+-    etfilelist = ET_File_List_Get_Selection();
+-    while (etfilelist)
++    etfilelist_tmp = etfilelist;
++    while (etfilelist_tmp)
+     {
+-        FileTag     = ((ET_File *)etfilelist->data)->FileTag->data;
+-        FileNameNew = ((ET_File *)etfilelist->data)->FileNameNew->data;
++        FileTag     = ((ET_File *)etfilelist_tmp->data)->FileTag->data;
++        FileNameNew = ((ET_File *)etfilelist_tmp->data)->FileNameNew->data;
+         
+         /* We process only the files not saved */
+         if ( FileTag->saved == FALSE || FileNameNew->saved == FALSE )
+         {
+-            ET_Display_File_Data_To_UI((ET_File *)etfilelist->data);
+-            Browser_List_Select_File((ET_File *)etfilelist->data,FALSE);
++            ET_Display_File_Data_To_UI((ET_File *)etfilelist_tmp->data);
++            Browser_List_Select_File((ET_File *)etfilelist_tmp->data,FALSE);
+             gtk_progress_set_value(GTK_PROGRESS(ProgressBar),++progress_bar_index);
+             /* Needed to refresh status bar */
+             while (gtk_events_pending())
+                 gtk_main_iteration();
+-            saving_answer = Save_File((ET_File *)etfilelist->data,(nb_files_to_save>1)?TRUE:FALSE);
++            saving_answer = Save_File((ET_File *)etfilelist_tmp->data,(nb_files_to_save>1)?TRUE:FALSE);
+             if (saving_answer == -1)
+             {
+@@ -1346,7 +1361,7 @@
+             }
+         }
+-        etfilelist = etfilelist->next;
++        etfilelist_tmp = etfilelist_tmp->next;
+         if (Main_Stop_Button_Pressed == 1 )
+             break;
+         
+@@ -2875,7 +2890,7 @@
+ void Quit_MainWindow_Save_And_Quit (void)
+ {
+     /* Save modified tags */
+-    if (Save_Selected_Files_With_Answer() == -1) return;
++    if (Save_All_Files_With_Answer() == -1) return;
+     Quit_MainWindow_Confirmed();
+ }
+diff -ruN easytag-0.30a/src/easytag.h easytag-0.30b/src/easytag.h
+--- easytag-0.30a/src/easytag.h        Sun Aug 31 15:30:52 2003
++++ easytag-0.30b/src/easytag.h        Sat Oct 18 19:26:48 2003
+@@ -137,6 +137,7 @@
+ void Action_Undo_From_History_List      (void);
+ void Action_Redo_From_History_List      (void);
+ void Action_Delete_Selected_Files       (void);
++gint Save_All_Files_With_Answer         (void);
+ gint Save_Selected_Files_With_Answer    (void);
+ void Action_Main_Stop_Button_Pressed    (void);
diff --git a/easytag-0.30c.patch b/easytag-0.30c.patch
new file mode 100644 (file)
index 0000000..4b581db
--- /dev/null
@@ -0,0 +1,179 @@
+diff -ruN easytag-0.30b/configure easytag-0.30c/configure
+--- easytag-0.30b/configure    Tue Oct 28 01:43:00 2003
++++ easytag-0.30c/configure    Tue Oct 28 01:09:12 2003
+@@ -1,6 +1,6 @@
+ #! /bin/sh
+ # Guess values for system-dependent variables and create Makefiles.
+-# Generated by GNU Autoconf 2.53 for easytag 0.30b.
++# Generated by GNU Autoconf 2.53 for easytag 0.30c.
+ #
+ # Copyright 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001, 2002
+ # Free Software Foundation, Inc.
+@@ -412,8 +412,8 @@
+ # Identity of this package.
+ PACKAGE_NAME='easytag'
+ PACKAGE_TARNAME='easytag'
+-PACKAGE_VERSION='0.30b'
+-PACKAGE_STRING='easytag 0.30b'
++PACKAGE_VERSION='0.30c'
++PACKAGE_STRING='easytag 0.30c'
+ PACKAGE_BUGREPORT=''
+ ac_unique_file="src/easytag.h"
+@@ -918,7 +918,7 @@
+   # Omit some internal or obsolete options to make the list less imposing.
+   # This message is too long to be a string in the A/UX 3.1 sh.
+   cat <<_ACEOF
+-\`configure' configures easytag 0.30b to adapt to many kinds of systems.
++\`configure' configures easytag 0.30c to adapt to many kinds of systems.
+ Usage: $0 [OPTION]... [VAR=VALUE]...
+@@ -984,7 +984,7 @@
+ if test -n "$ac_init_help"; then
+   case $ac_init_help in
+-     short | recursive ) echo "Configuration of easytag 0.30b:";;
++     short | recursive ) echo "Configuration of easytag 0.30c:";;
+    esac
+   cat <<\_ACEOF
+@@ -1092,7 +1092,7 @@
+ test -n "$ac_init_help" && exit 0
+ if $ac_init_version; then
+   cat <<\_ACEOF
+-easytag configure 0.30b
++easytag configure 0.30c
+ generated by GNU Autoconf 2.53
+ Copyright 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001, 2002
+@@ -1107,7 +1107,7 @@
+ This file contains any messages produced by compilers while
+ running configure, to aid debugging if configure makes a mistake.
+-It was created by easytag $as_me 0.30b, which was
++It was created by easytag $as_me 0.30c, which was
+ generated by GNU Autoconf 2.53.  Invocation command line was
+   $ $0 $@
+@@ -1639,7 +1639,7 @@
+ # Define the identity of the package.
+  PACKAGE=easytag
+- VERSION=0.30b
++ VERSION=0.30c
+ cat >>confdefs.h <<_ACEOF
+@@ -12653,7 +12653,7 @@
+ } >&5
+ cat >&5 <<_CSEOF
+-This file was extended by easytag $as_me 0.30b, which was
++This file was extended by easytag $as_me 0.30c, which was
+ generated by GNU Autoconf 2.53.  Invocation command line was
+   CONFIG_FILES    = $CONFIG_FILES
+@@ -12715,7 +12715,7 @@
+ cat >>$CONFIG_STATUS <<_ACEOF
+ ac_cs_version="\\
+-easytag config.status 0.30b
++easytag config.status 0.30c
+ configured by $0, generated by GNU Autoconf 2.53,
+   with options \\"`echo "$ac_configure_args" | sed 's/[\\""\`\$]/\\\\&/g'`\\"
+diff -ruN easytag-0.30b/configure.in easytag-0.30c/configure.in
+--- easytag-0.30b/configure.in Tue Oct 28 01:43:00 2003
++++ easytag-0.30c/configure.in Tue Oct 28 01:09:15 2003
+@@ -6,7 +6,7 @@
+ dnl VERSION=0.28
+ AC_PREREQ(2.53)
+-AC_INIT(easytag, 0.30b) dnl defines ($PACKAGE, $VERSION)
++AC_INIT(easytag, 0.30c) dnl defines ($PACKAGE, $VERSION)
+ AC_CONFIG_SRCDIR(src/easytag.h)
+ dnl -------------------------------
+ dnl Init automake
+diff -ruN easytag-0.30b/easytag.spec easytag-0.30c/easytag.spec
+--- easytag-0.30b/easytag.spec Tue Oct 28 01:43:00 2003
++++ easytag-0.30c/easytag.spec Tue Oct 28 01:09:17 2003
+@@ -1,5 +1,5 @@
+ %define    name      easytag
+-%define    version   0.30b
++%define    version   0.30c
+ %define    release   1
+ %define    prefix    /usr
+diff -ruN easytag-0.30b/src/easytag.c easytag-0.30c/src/easytag.c
+--- easytag-0.30b/src/easytag.c        Tue Oct 28 01:43:00 2003
++++ easytag-0.30c/src/easytag.c        Tue Oct 28 01:40:50 2003
+@@ -1433,6 +1433,9 @@
+     Tag_Area_Set_Sensitive(FALSE);
+     File_Area_Set_Sensitive(FALSE);
++    /* Show msgbox (if needed) to ask confirmation */
++    SF_HideMsgbox_Delete_File = 0;
++    
+     etfilelist = ET_File_List_Get_Selection();
+     while (etfilelist)
+     {
+@@ -1533,7 +1536,7 @@
+         GtkWidget *msgbox = NULL;
+         gint button;
+-        if (CONFIRM_WRITE_TAG && (!multiple_files || (multiple_files & !SF_HideMsgbox_Write_Tag)))
++        if (CONFIRM_WRITE_TAG && !SF_HideMsgbox_Write_Tag)
+         {
+             ET_Display_File_Data_To_UI(ETFile);
+             
+@@ -1556,7 +1559,7 @@
+             gtk_widget_destroy(msgbox);
+         }else
+         {
+-            if (multiple_files && SF_HideMsgbox_Write_Tag)
++            if (SF_HideMsgbox_Write_Tag)
+                 button = SF_ButtonPressed_Write_Tag;
+             else
+                 button = BUTTON_YES;
+@@ -1586,7 +1589,7 @@
+         GtkWidget *msgbox = NULL;
+         gint button;
+-        if (CONFIRM_RENAME_FILE && (!multiple_files || (multiple_files & !SF_HideMsgbox_Rename_File)))
++        if (CONFIRM_RENAME_FILE && !SF_HideMsgbox_Rename_File)
+         {
+             ET_Display_File_Data_To_UI(ETFile);
+@@ -1610,7 +1613,7 @@
+             gtk_widget_destroy(msgbox);
+         }else
+         {
+-            if (multiple_files && SF_HideMsgbox_Rename_File)
++            if (SF_HideMsgbox_Rename_File)
+                 button = SF_ButtonPressed_Rename_File;
+             else
+                 button = BUTTON_YES;
+@@ -1803,7 +1806,7 @@
+     /*
+      * Remove the file
+      */
+-    if (CONFIRM_DELETE_FILE && (!multiple_files || (multiple_files & !SF_HideMsgbox_Delete_File)))
++    if (CONFIRM_DELETE_FILE && !SF_HideMsgbox_Delete_File)
+     {
+         msg = g_strdup_printf(_("Do you really want to delete definitively the file\n'%s' ?"),g_basename(cur_filename) );
+         if (multiple_files)
+@@ -1819,11 +1822,11 @@
+         g_free(msg);
+         SF_ButtonPressed_Delete_File = button = msg_box_run(MSG_BOX(msgbox));
+         if (MSG_BOX(msgbox)->check_button_state)
+-            SF_HideMsgbox_Rename_File = MSG_BOX(msgbox)->check_button_state;
++            SF_HideMsgbox_Delete_File = MSG_BOX(msgbox)->check_button_state;
+         gtk_widget_destroy(msgbox);
+     }else
+     {
+-        if (multiple_files && SF_HideMsgbox_Delete_File)
++        if (SF_HideMsgbox_Delete_File)
+             button = SF_ButtonPressed_Delete_File;
+         else
+             button = BUTTON_YES;
This page took 0.513892 seconds and 4 git commands to generate.