]> git.pld-linux.org Git - packages/e_dbus.git/blob - e_dbus.spec
- simplified setup
[packages/e_dbus.git] / e_dbus.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       0.9.9.050
6
7 Summary:        EFL wrapper for DBus
8 Summary(pl.UTF-8):      Obudowanie EFL dla systemu DBus
9 Name:           e_dbus
10 Version:        0.5.0.050
11 Release:        0.1
12 License:        BSD
13 Group:          Libraries
14 Source0:        http://download.enlightenment.org/snapshots/2008-09-25/%{name}-%{version}.tar.bz2
15 # Source0-md5:  7b1454d165f5cc42dd61d7acdd4719dd
16 URL:            http://enlightenment.org/p.php?p=about/efl
17 BuildRequires:  autoconf >= 2.52
18 BuildRequires:  automake >= 1.6
19 BuildRequires:  dbus-devel >= 0.62
20 BuildRequires:  ecore-devel >= %{ecore_ver}
21 BuildRequires:  libtool
22 BuildRequires:  pkgconfig
23 Obsoletes:      ecore-dbus
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %undefine       __cxx
27
28 %description
29 EFL wrapper for DBus.
30
31 %description -l pl.UTF-8
32 Obudowanie EFL dla systemu DBus.
33
34 %package devel
35 Summary:        Header files for e_dbus library
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki e_dbus
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description devel
41 Header files for e_dbus library.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe biblioteki e_dbus.
45
46 %package static
47 Summary:        Static e_dbus library
48 Summary(pl.UTF-8):      Statyczna biblioteka e_dbus
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static e_dbus library.
54
55 %description static -l pl.UTF-8
56 Statyczna biblioteka e_dbus.
57
58 %prep
59 %setup -q
60
61 %build
62 %{__libtoolize}
63 %{__aclocal}
64 %{__autoconf}
65 %{__autoheader}
66 %{__automake}
67 %configure \
68         %{!?with_static_libs:--disable-static}
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files
84 %defattr(644,root,root,755)
85 %doc AUTHORS COPYING README
86 %attr(755,root,root) %{_bindir}/e-notify-send
87 %attr(755,root,root) %{_bindir}/e_dbus_hal
88 %attr(755,root,root) %{_bindir}/e_dbus_nm
89 %attr(755,root,root) %{_bindir}/e_dbus_notification_daemon
90 %attr(755,root,root) %{_bindir}/e_dbus_notify
91 %attr(755,root,root) %{_bindir}/e_dbus_test
92 %attr(755,root,root) %{_bindir}/e_dbus_test_client
93 %attr(755,root,root) %{_libdir}/libedbus.so.*.*.*
94 %attr(755,root,root) %ghost %{_libdir}/libedbus.so.0
95 %attr(755,root,root) %{_libdir}/libehal.so.*.*.*
96 %attr(755,root,root) %ghost %{_libdir}/libehal.so.0
97 %attr(755,root,root) %{_libdir}/libenm.so.*.*.*
98 %attr(755,root,root) %ghost %{_libdir}/libenm.so.0
99 %attr(755,root,root) %{_libdir}/libenotify.so.*.*.*
100 %attr(755,root,root) %ghost %{_libdir}/libenotify.so.0
101
102 %files devel
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_libdir}/libedbus.so
105 %attr(755,root,root) %{_libdir}/libehal.so
106 %attr(755,root,root) %{_libdir}/libenm.so
107 %attr(755,root,root) %{_libdir}/libenotify.so
108 %{_libdir}/libedbus.la
109 %{_libdir}/libehal.la
110 %{_libdir}/libenm.la
111 %{_libdir}/libenotify.la
112 %{_includedir}/E_DBus.h
113 %{_includedir}/E_Hal.h
114 %{_includedir}/E_Nm.h
115 %{_includedir}/E_Notification_Daemon.h
116 %{_includedir}/E_Notify.h
117 %{_pkgconfigdir}/edbus.pc
118 %{_pkgconfigdir}/ehal.pc
119 %{_pkgconfigdir}/enm.pc
120 %{_pkgconfigdir}/enotify.pc
121
122 %if %{with static_libs}
123 %files static
124 %defattr(644,root,root,755)
125 %{_libdir}/libedbus.a
126 %{_libdir}/libehal.a
127 %{_libdir}/libenm.a
128 %{_libdir}/libenotify.a
129 %endif
This page took 0.079093 seconds and 4 git commands to generate.