]> git.pld-linux.org Git - packages/e_dbus.git/blob - e_dbus.spec
- small clean up
[packages/e_dbus.git] / e_dbus.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       0.9.9.043
6
7 Summary:        Ecore DBus Library
8 Summary(pl.UTF-8):      Biblioteka Ecore DBus
9 Name:           e_dbus
10 Version:        0.5.0.043
11 Release:        1
12 License:        BSD
13 Group:          Libraries
14 Source0:        http://download.enlightenment.org/snapshots/2008-05-19/%{name}-%{version}.tar.bz2
15 # Source0-md5:  68a80552d85b800079387e1008166db4
16 URL:            http://enlightenment.org/p.php?p=about/libs/eet
17 BuildRequires:  autoconf
18 BuildRequires:  automake >= 1.4
19 BuildRequires:  dbus-devel >= 0.62
20 BuildRequires:  ecore-devel >= %{ecore_ver}
21 BuildRequires:  libtool
22 BuildRequires:  pkgconfig
23 Obsoletes:      ecore-dbus
24 #Conflicts:     ecore-libs ??
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %undefine       __cxx
28
29 %description
30 Ecore DBus Library.
31
32 % description -l pl.UTF-8
33 Biblioteka Ecore DBus.
34
35 %package devel
36 Summary:        Header files for e_dbus library
37 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki e_dbus
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Header files for e_dbus library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki e_dbus.
46
47 %package static
48 Summary:        Static Eet library
49 Summary(pl.UTF-8):      Statyczna biblioteka Eet
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static e_dbus library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka e_dbus.
58
59 %prep
60 %setup -q
61
62 %build
63 %{__libtoolize}
64 %{__aclocal}
65 %{__autoconf}
66 %{__autoheader}
67 %{__automake}
68 %configure \
69         %{!?with_static_libs:--disable-static}
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files
85 %defattr(644,root,root,755)
86 %doc AUTHORS COPYING ChangeLog NEWS README
87 %attr(755,root,root) %{_bindir}/e*
88 %attr(755,root,root) %{_libdir}/libe*.so.*
89
90 %files devel
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_libdir}/*.so
93 %{_libdir}/libe*.la
94 %{_pkgconfigdir}/e*.pc
95 %{_includedir}/E_*.h
96
97 %if %{with static_libs}
98 %files static
99 %defattr(644,root,root,755)
100 %{_libdir}/lib*.a
101 %endif
This page took 0.064372 seconds and 4 git commands to generate.