]> git.pld-linux.org Git - packages/e_dbus.git/blob - e_dbus.spec
- updated to 20080813 snap
[packages/e_dbus.git] / e_dbus.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         _snap   20080813
6 %define         ecore_ver       0.9.9.044
7
8 Summary:        EFL wrapper for DBus
9 Summary(pl.UTF-8):      Obudowanie EFL dla systemu DBus
10 Name:           e_dbus
11 Version:        0.5.0.044
12 Release:        0.%{_snap}.1
13 License:        BSD
14 Group:          Libraries
15 Source0:        %{name}-%{version}-%{_snap}.tar.bz2
16 # Source0-md5:  0032035e32600672febe16d000b4e2ca
17 URL:            http://enlightenment.org/p.php?p=about/efl
18 BuildRequires:  autoconf >= 2.52
19 BuildRequires:  automake >= 1.6
20 BuildRequires:  dbus-devel >= 0.62
21 BuildRequires:  ecore-devel >= %{ecore_ver}
22 BuildRequires:  libtool
23 BuildRequires:  pkgconfig
24 Obsoletes:      ecore-dbus
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %undefine       __cxx
28
29 %description
30 EFL wrapper for DBus.
31
32 %description -l pl.UTF-8
33 Obudowanie EFL dla systemu DBus.
34
35 %package devel
36 Summary:        Header files for e_dbus library
37 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki e_dbus
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Header files for e_dbus library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki e_dbus.
46
47 %package static
48 Summary:        Static e_dbus library
49 Summary(pl.UTF-8):      Statyczna biblioteka e_dbus
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static e_dbus library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka e_dbus.
58
59 %prep
60 %setup -q -n %{name}-%{version}-%{_snap}
61
62 %build
63 %{__libtoolize}
64 %{__aclocal}
65 %{__autoconf}
66 %{__autoheader}
67 %{__automake}
68 %configure \
69         %{!?with_static_libs:--disable-static}
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files
85 %defattr(644,root,root,755)
86 %doc AUTHORS COPYING README
87 %attr(755,root,root) %{_bindir}/e-notify-send
88 %attr(755,root,root) %{_bindir}/e_dbus_hal
89 %attr(755,root,root) %{_bindir}/e_dbus_nm
90 %attr(755,root,root) %{_bindir}/e_dbus_notification_daemon
91 %attr(755,root,root) %{_bindir}/e_dbus_notify
92 %attr(755,root,root) %{_bindir}/e_dbus_test
93 %attr(755,root,root) %{_bindir}/e_dbus_test_client
94 %attr(755,root,root) %{_libdir}/libedbus.so.*.*.*
95 %attr(755,root,root) %ghost %{_libdir}/libedbus.so.0
96 %attr(755,root,root) %{_libdir}/libehal.so.*.*.*
97 %attr(755,root,root) %ghost %{_libdir}/libehal.so.0
98 %attr(755,root,root) %{_libdir}/libenm.so.*.*.*
99 %attr(755,root,root) %ghost %{_libdir}/libenm.so.0
100 %attr(755,root,root) %{_libdir}/libenotify.so.*.*.*
101 %attr(755,root,root) %ghost %{_libdir}/libenotify.so.0
102
103 %files devel
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_libdir}/libedbus.so
106 %attr(755,root,root) %{_libdir}/libehal.so
107 %attr(755,root,root) %{_libdir}/libenm.so
108 %attr(755,root,root) %{_libdir}/libenotify.so
109 %{_libdir}/libedbus.la
110 %{_libdir}/libehal.la
111 %{_libdir}/libenm.la
112 %{_libdir}/libenotify.la
113 %{_includedir}/E_DBus.h
114 %{_includedir}/E_Hal.h
115 %{_includedir}/E_Nm.h
116 %{_includedir}/E_Notification_Daemon.h
117 %{_includedir}/E_Notify.h
118 %{_pkgconfigdir}/edbus.pc
119 %{_pkgconfigdir}/ehal.pc
120 %{_pkgconfigdir}/enm.pc
121 %{_pkgconfigdir}/enotify.pc
122
123 %if %{with static_libs}
124 %files static
125 %defattr(644,root,root,755)
126 %{_libdir}/libedbus.a
127 %{_libdir}/libehal.a
128 %{_libdir}/libenm.a
129 %{_libdir}/libenotify.a
130 %endif
This page took 0.064924 seconds and 3 git commands to generate.