]> git.pld-linux.org Git - packages/e3.git/blob - e3.spec
fixed a small typo
[packages/e3.git] / e3.spec
1 Summary:        Tiny editor
2 Summary(pl):    Mikroedytorek
3 Name:           e3
4 Version:        1.61
5 Release:        6
6 License:        GPL
7 Group:          Applications/Editors
8 Source0:        http://www.sax.de/~adlibit/%{name}-%{version}.tar.gz
9 Source1:        %{name}-editor.sh
10 Patch0:         %{name}-short_jump.patch
11 Patch1:         %{name}-%{version}-Polish_letters.patch
12 URL:            http://www.sax.de/~adlibit/
13 BuildRequires:  perl
14 %ifarch %{ix86}
15 BuildRequires:  nasm
16 %endif
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define no_install_post_strip 1
20
21 %description
22 e3 is a text micro editor with a code size less than 10000 bytes.
23 Except for 'undo' and 'syntax highlighting', e3 supports all of the
24 basic functions one expects. If you have installed the stream editor
25 'sed' or 'ex' you can use these tools as sub-processes, getting the
26 full power of regular expressions. e3 can use Wordstar-, EMACS-, Pico,
27 Nedit or vi-like key bindings, whichever the user chooses. e3 is
28 designed to be INDEPENDENT OF LIBC OR ANY OTHER library.
29
30 %description -l pl
31 e3 jest mikroskopijnym wrêcz edytorem tekstu, jego rozmiar nie
32 przekracza 10000 bajtów. Wspiera on wszystkie podstawowe funkcje,
33 jakich mo¿na oczekiwaæ od edytora, z wyj±tkiem pod¶wietlania sk³adni i
34 cofania dokonanych zmian (undo). Jesli chcesz skorzystaæ z potêgi
35 wyra¿eñ regularnych, to e3 mo¿e wywo³aæ zewnêtrzny edytor strumieni
36 ('sed' lub 'ex'). e3 potrafi emulowaæ ustawienia klawiszy Wordstara,
37 EMACSA, Pico, Nedit oraz vi. e3 nie jest zale¿ny od ¿adnej biblioteki
38 (wliczaj±c glibc).
39
40 %prep
41 %setup -q
42 %patch0 -p1
43 %patch1 -p1
44 # gzexe makes problems
45 # we gain 3K only
46 perl -pi -e 's/^.*gzexe e3.*$//' Makefile
47
48 %build
49 %ifarch %{ix86}
50 %{__make}
51 %endif
52 %{__cc} %{rpmcflags} %{rpmldflags} -DLIBDIR=\"%{_libdir}\" e3c/e3.c -o e3c.bin
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}}  
57 %ifarch %{ix86}
58 install e3 $RPM_BUILD_ROOT%{_bindir}/e3
59 %else
60 ln -sf e3c $RPM_BUILD_ROOT%{_bindir}/e3
61 %endif
62
63 install e3c.bin $RPM_BUILD_ROOT%{_bindir}/e3c
64
65 install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/e3-editor.sh
66 install e3.man $RPM_BUILD_ROOT%{_mandir}/man1/e3.1
67 install e3c/e3c.man $RPM_BUILD_ROOT%{_mandir}/man1/e3c.1
68
69 install e3c/*.{hlp,res} $RPM_BUILD_ROOT%{_libdir}
70
71 for i in ws em pi vi ne; do
72         ln -sf e3 $RPM_BUILD_ROOT%{_bindir}/e3${i}
73 done
74
75 for i in emacs vi pico ne ws; do
76         ln -sf e3-editor.sh $RPM_BUILD_ROOT%{_bindir}/e3-$i
77 done
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %attr(755,root,root) %{_bindir}/*
85 %{_mandir}/man1/*
86 %{_libdir}/*
This page took 0.079445 seconds and 3 git commands to generate.