]> git.pld-linux.org Git - packages/e3.git/blob - e3.spec
- rel 4
[packages/e3.git] / e3.spec
1 Summary:        Tiny editor
2 Summary(pl):    Mikroedytorek
3 Name:           e3
4 Version:        1.61
5 Release:        5
6 License:        GPL
7 Group:          Applications/Editors
8 Group(de):      Applikationen/Editors
9 Group(pl):      Aplikacje/Edytory
10 Group(pt):      Aplicações/Editores
11 Source0:        http://www.sax.de/~adlibit/%{name}-%{version}.tar.gz
12 Source1:        %{name}-editor.sh
13 Patch0:         %{name}-short_jump.patch
14 Patch1:         %{name}-%{version}-Polish_letters.patch
15 URL:            http://www.sax.de/~adlibit/
16 BuildRequires:  perl
17 %ifarch %{ix86}
18 BuildRequires:  nasm
19 %endif
20 BuildRequires:  uClibc-devel
21 BuildRequires:  uClibc-static
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define no_install_post_strip 1
25
26 %define embed_path      /usr/lib/embed
27 %define embed_cc        %{_arch}-uclibc-cc
28 %define embed_cflags    %{rpmcflags} -Os
29
30 %description
31 e3 is a text micro editor with a code size less than 10000 bytes.
32 Except for 'undo' and 'syntax highlighting', e3 supports all of the
33 basic functions one expects. If you have installed the stream editor
34 'sed' or 'ex' you can use these tools as sub-processes, getting the
35 full power of regular expressions.  e3 can use Wordstar-, EMACS-,
36 Pico, Nedit or vi-like key bindings, whichever the user chooses.
37 e3 is designed to be INDEPENDENT OF LIBC OR ANY OTHER library.
38
39 %description -l pl
40 e3 jest mikroskopijnym wrêcz edytorem tekstu, jego rozmiar nie
41 przekracza 10000 bajtów. Wspiera on wszystkie podstawowe funkcje,
42 jakich mo¿na oczekiwaæ od edytora, z wyj±tkiem pod¶wietlania sk³adni
43 i cofania dokonanych zmian (undo). Jesli chcesz skorzystaæ z potêgi
44 wyra¿eñ regularnych, to e3 mo¿e wywo³aæ zewnêtrzny edytor strumieni
45 ('sed' lub 'ex'). e3 potrafi emulowaæ ustawienia klawiszy Wordstara,
46 EMACSA, Pico, Nedit oraz vi. e3 nie jest zale¿ny od ¿adnej biblioteki
47 (wliczaj±c glibc).
48
49 %package embed
50 Summary:        e3 for bootdisk
51 Group:          Applications/Editors
52 Group(de):      Applikationen/Editors
53 Group(pl):      Aplikacje/Edytory
54 Group(pt):      Aplicações/Editores
55
56 %description embed
57 e3 for bootdisk.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62 %patch1 -p1
63 # gzexe makes problems
64 # we gain 3K only
65 perl -pi -e 's/^.*gzexe e3.*$//' Makefile
66
67 %build
68 %ifarch %{ix86}
69 %{__make}
70 %endif
71 %{embed_cc} %{embed_cflags} -DLIBDIR=\"%{_libdir}\" e3c/e3.c -o e3c.shared
72 %{embed_cc} %{embed_cflags} -DLIBDIR=\"%{_libdir}\" -static e3c/e3.c -o e3c.static
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT%{embed_path}/{static,shared,%{_libdir}} \
77         $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}}
78
79 %ifarch %{ix86}
80 install e3 $RPM_BUILD_ROOT%{embed_path}/static/e3
81 install e3 $RPM_BUILD_ROOT%{embed_path}/shared/e3
82 install e3 $RPM_BUILD_ROOT%{_bindir}/e3
83 %else
84 ln -sf e3c $RPM_BUILD_ROOT%{embed_path}/static/e3
85 ln -sf e3c $RPM_BUILD_ROOT%{embed_path}/shared/e3
86 ln -sf e3c $RPM_BUILD_ROOT%{_bindir}/e3
87 %endif
88
89 install e3c.static $RPM_BUILD_ROOT%{embed_path}/static/e3c
90 install e3c.shared $RPM_BUILD_ROOT%{embed_path}/shared/e3c
91 install e3c.static $RPM_BUILD_ROOT%{_bindir}/e3c
92
93 install %{SOURCE1} $RPM_BUILD_ROOT%{embed_path}/shared/editor.sh
94 install %{SOURCE1} $RPM_BUILD_ROOT%{embed_path}/static/editor.sh
95 install e3.man $RPM_BUILD_ROOT%{_mandir}/man1/e3.1
96 install e3c/e3c.man $RPM_BUILD_ROOT%{_mandir}/man1/e3c.1
97
98 install e3c/*.{hlp,res} $RPM_BUILD_ROOT%{_libdir}
99 install e3c/*.{hlp,res} $RPM_BUILD_ROOT%{embed_path}%{_libdir}
100
101 for i in ws em pi vi ne; do
102         ln -sf e3 $RPM_BUILD_ROOT%{_bindir}/e3${i}
103         ln -sf e3 $RPM_BUILD_ROOT%{embed_path}/static/e3${i}
104         ln -sf e3 $RPM_BUILD_ROOT%{embed_path}/shared/e3${i}
105 done
106
107 for i in emacs vi pico ne ws; do
108         ln -sf editor.sh $RPM_BUILD_ROOT%{embed_path}/static/$i
109         ln -sf editor.sh $RPM_BUILD_ROOT%{embed_path}/shared/$i
110 done
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %files
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_bindir}/*
118 %{_mandir}/man1/*
119 %{embed_path}%{_libdir}/*
120
121 %files embed
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{embed_path}/s*/*
124 %{embed_path}%{_libdir}/*
This page took 0.358129 seconds and 3 git commands to generate.