]> git.pld-linux.org Git - packages/e2fsprogs.git/commitdiff
- build static version blkid, using uClibc - for allow detect root=label and
authorundefine <undefine@pld-linux.org>
Thu, 3 Jan 2008 18:40:04 +0000 (18:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  root=uuid by our initrd

Changed files:
    e2fsprogs.spec -> 1.167

e2fsprogs.spec

index d0806ef93c479c361d0d9f3c94ecd550e8062fee..d0ab7de5c466837ae16399c21c8e84f38c9cca2d 100644 (file)
@@ -3,6 +3,12 @@
 %bcond_with    allstatic       # link everything statically
 %bcond_without static          # link e2fsck dynamically with libc
 %bcond_without nls             # build without NLS
+%bcond_without initrd          # don't build initrd version
+%bcond_without uClibc          # link initrd version with static glibc instead of uClibc
+#
+%ifarch sparc64 sparc
+%undefine       with_uClibc
+%endif
 #
 Summary:       Utilities for managing the second extended (ext2) filesystem
 Summary(cs.UTF-8):     Nástroje pro správu souborových systémů typu ext2
@@ -53,6 +59,15 @@ BuildRequires:       glibc-static
 BuildRequires: libselinux-static
 BuildRequires: libsepol-static
 %endif
+%if %{with initrd}
+       %if %{with uClibc}
+               %ifarch ppc
+BuildRequires:  uClibc-static >= 2:0.9.29
+               %else
+BuildRequires:  uClibc-static >= 2:0.9.26
+               %endif
+       %endif
+%endif
 Requires(post,postun): /sbin/ldconfig
 Requires:      fsck = %{version}-%{release}
 Requires:      libcom_err = %{version}-%{release}
@@ -61,6 +76,9 @@ Obsoletes:    e2fsprogs-evms
 Obsoletes:     libext2fs2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# changing CFLAGS in the middle confuses confcache
+%undefine       configure_cache
+
 %description
 The e2fsprogs package contains a number of utilities for creating,
 checking, modifying and correcting any inconsistencies in second
@@ -525,6 +543,19 @@ Check and repair a Linux file system.
 %description -n fsck -l pl.UTF-8
 Sprawdzenie i naprawa linuksowego systemu plików.
 
+%package initrd
+Summary:       blkid - initrd version
+Summary(pl.UTF-8):     blkid - wersja dla initrd
+Group: Base
+
+%description initrd
+This package includes a blkid utility to recognize partitions by label or uuid
+- staticaly linked for initrd.
+
+%description initrd -l pl.UTF-8
+Pakiet ten zawiera narzędzie blkid do rozpozywania partycji przez etykietke lub
+uuid - statycznie skonsolidowane na potrzeby initrd.
+
 %prep
 %setup -q
 %patch0 -p1
@@ -545,6 +576,23 @@ cp -f /usr/share/automake/config.sub .
 %{__gettextize}
 %{__aclocal}
 %{__autoconf}
+
+%if %{with initrd}
+%configure \
+       %{?with_uClibc:CC="%{_target_cpu}-uclibc-gcc"} \
+       ac_cv_lib_dl_dlopen=no \
+       --with-ccopts="-Os" \
+       --with-ldopts="-static" \
+       --disable-elf-shlibs \
+       --disable-selinux \
+       --disable-nls
+
+%{__make} -j1 libs
+%{__make} progs
+mv -f misc/blkid initrd-blkid
+%{__make} clean
+%endif
+
 %configure \
        --with-root-prefix="" \
        %{!?with_nls:--disable-nls} \
@@ -607,6 +655,8 @@ echo '.so mke2fs.8' > $RPM_BUILD_ROOT%{_mandir}/pl/man8/mkfs.ext3.8
 rm -f $RPM_BUILD_ROOT%{_mandir}/README.e2fsprogs-non-english-man-pages
 touch $RPM_BUILD_ROOT%{_sysconfdir}/blkid.tab
 
+%{?with_initrd:install initrd-blkid $RPM_BUILD_ROOT/sbin/initrd-blkid}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -747,3 +797,9 @@ rm -rf $RPM_BUILD_ROOT
 %lang(ja) %{_mandir}/ja/man8/fsck.8*
 %lang(ko) %{_mandir}/ko/man8/fsck.8*
 %lang(pl) %{_mandir}/pl/man8/fsck.8*
+
+%if %{with initrd}
+%files initrd
+%defattr(644,root,root,755)
+%attr(755,root,root) /sbin/initrd-blkid
+%endif
This page took 0.036703 seconds and 4 git commands to generate.