]> git.pld-linux.org Git - packages/e2fsprogs.git/commitdiff
- up to 1.42.2 but unfortunately doesn't build with initrd
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 27 May 2012 21:18:07 +0000 (21:18 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    e2fsprogs-diet.patch -> 1.11
    e2fsprogs.spec -> 1.242

e2fsprogs-diet.patch
e2fsprogs.spec

index 3e5db000f4ba74dd69a6003b2f7d40c0a2fe128e..3f49954f0098ac3f5775b261df8e19b755c1615d 100644 (file)
        BLKID_CMT=#
        AC_MSG_RESULT([Disabling private blkid library])
  else
-@@ -853,7 +853,7 @@
-   AC_SEARCH_LIBS([blkid_probe_all], [blkid])
- fi
- dnl
--AC_CHECK_FUNCS(chflags getrusage llseek lseek64 open64 fstat64 ftruncate64 getmntinfo strtoull strcasecmp srandom jrand48 fchown mallinfo fdatasync strnlen strptime strdup sysconf pathconf posix_memalign memalign valloc __secure_getenv prctl mmap utime setresuid setresgid usleep nanosleep getdtablesize getrlimit blkid_probe_get_topology mbstowcs)
-+AC_CHECK_FUNCS(chflags getrusage llseek lseek64 open64 fstat64 stat64 ftruncate64 getmntinfo strtoull strcasecmp srandom jrand48 fchown mallinfo fdatasync strnlen strptime strdup sysconf pathconf posix_memalign memalign valloc __secure_getenv prctl mmap utime setresuid setresgid usleep nanosleep getdtablesize getrlimit blkid_probe_get_topology mbstowcs)
- dnl
- dnl Check to see if -lsocket is required (solaris) to make something
- dnl that uses socket() to compile; this is needed for the UUID library
-diff -ur e2fsprogs-1.41.3/misc/util.c e2fsprogs-1.41.3-diet/misc/util.c
---- e2fsprogs-1.41.3/misc/util.c       2008-10-07 16:22:39.000000000 +0200
-+++ e2fsprogs-1.41.3-diet/misc/util.c  2009-03-17 22:01:31.000000000 +0100
-@@ -79,7 +79,7 @@
- void check_plausibility(const char *device)
+@@ -988,6 +988,7 @@
+       setresgid
+       setresuid
+       srandom
++      stat64
+       strcasecmp
+       strdup
+       strnlen
+--- e2fsprogs-1.42.2/lib/ext2fs/unix_io.c~     2012-03-18 19:18:33.000000000 +0100
++++ e2fsprogs-1.42.2/lib/ext2fs/unix_io.c      2012-03-30 18:55:04.613560295 +0200
+@@ -888,7 +888,7 @@
+                             unsigned long long count)
  {
-       int val;
--#ifdef HAVE_OPEN64
-+#ifdef HAVE_STAT64
-       struct stat64 s;
+       struct unix_private_data *data;
+-      __uint64_t      range[2];
++      u_int64_t       range[2];
+       int             ret;
  
-       val = stat64(device, &s);
-
---- e2fsprogs-1.41.11/misc/mke2fs.c.orig       2010-03-15 05:13:56.000000000 +0100
-+++ e2fsprogs-1.41.11/misc/mke2fs.c    2010-05-09 20:44:41.178938422 +0200
-@@ -1927,7 +1927,7 @@
-       int ret;
-       int blocksize;
-       __u64 blocks;
--      __uint64_t range[2];
-+      uint64_t range[2];
+       EXT2_CHECK_MAGIC(channel, EXT2_ET_MAGIC_IO_CHANNEL);
+@@ -897,8 +897,8 @@
  
-       blocks = fs->super->s_blocks_count;
-       blocksize = EXT2_BLOCK_SIZE(fs->super);
+       if (channel->flags & CHANNEL_FLAGS_BLOCK_DEVICE) {
+ #ifdef BLKDISCARD
+-              range[0] = (__uint64_t)(block) * channel->block_size;
+-              range[1] = (__uint64_t)(count) * channel->block_size;
++              range[0] = (u_int64_t)(block) * channel->block_size;
++              range[1] = (u_int64_t)(count) * channel->block_size;
+               ret = ioctl(data->dev, BLKDISCARD, &range);
+ #else
index 52a51a64a3807fa280423e2dafecd1709a501d55..bdb870752c5bf3d2bb960ba349fc0448280ee745 100644 (file)
@@ -47,12 +47,12 @@ Summary(uk.UTF-8):  Утиліти для роботи з файловою сис
 Summary(zh_CN.UTF-8):  管理第二扩展(ext2)文件系统的工具。
 Summary(zh_TW.UTF-8):  用於管理 ext2 檔案系統的工具程式。
 Name:          e2fsprogs
-Version:       1.41.14
-Release:       4
+Version:       1.42.2
+Release:       0.1
 License:       GPL v2 (with LGPL v2 and BSD parts)
 Group:         Applications/System
 Source0:       http://downloads.sourceforge.net/e2fsprogs/%{name}-%{version}.tar.gz
-# Source0-md5: 05f70470aea2ef7efbb0845b2b116720
+# Source0-md5: 04f4561a54ad0419248316a00c016baa
 Source1:       e2compr-0.4.texinfo.gz
 # Source1-md5: c3c59ff37e49d8759abb1ef95a8d3abf
 Source2:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
@@ -797,6 +797,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) /sbin/e2image
 %attr(755,root,root) /sbin/e2label
 %attr(755,root,root) /sbin/e2undo
+%attr(755,root,root) /sbin/e4defrag
 %attr(755,root,root) /sbin/fsck.ext2
 %attr(755,root,root) /sbin/fsck.ext3
 %attr(755,root,root) /sbin/fsck.ext4
@@ -829,6 +830,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man8/e2image.8*
 %{_mandir}/man8/e2label.8*
 %{_mandir}/man8/e2undo.8*
+%{_mandir}/man8/e4defrag.8*
 %{_mandir}/man8/filefrag.8*
 %{_mandir}/man8/fsck.ext2.8*
 %{_mandir}/man8/fsck.ext3.8*
This page took 0.203506 seconds and 4 git commands to generate.