]> git.pld-linux.org Git - packages/e-uae.git/blob - e-uae.spec
- disable scsi emulation by default due to GPL vs CDDL conflict
[packages/e-uae.git] / e-uae.spec
1 #
2 # Conditional build:
3 %bcond_with     capsimage       # use capsimage for .IPF, .RAW and .CTR disk image support
4 %bcond_with     scsi            # SCSI devices emulation (uses libscg: cdrtools <= 2.01.01a08 or result is non-distributable)
5
6 Summary:        Unix Amiga Emulator
7 Summary(pl.UTF-8):      Uniksowy emulator Amigi
8 Name:           e-uae
9 Version:        0.8.29
10 %define subver  WIP4
11 Release:        0.%{subver}.0.1
12 License:        GPL v2
13 Group:          Applications/Emulators
14 Source0:        http://www.rcdrummond.net/uae/e-uae-%{version}-%{subver}/%{name}-%{version}-%{subver}.tar.bz2
15 # Source0-md5:  cbfd7e3d7a1b323331afbb92ea7ff4f0
16 Source1:        uae.desktop
17 Source2:        uae.png
18 Patch0:         %{name}-format.patch
19 Patch1:         %{name}-ucontext.patch
20 Patch2:         %{name}-system-libscg.patch
21 URL:            http://www.rcdrummond.net/uae/
22 BuildRequires:  OpenGL-GLU-devel
23 BuildRequires:  SDL-devel >= 1.2.0
24 BuildRequires:  alsa-lib-devel
25 BuildRequires:  autoconf >= 2.55
26 BuildRequires:  automake >= 1:1.7
27 %if %{with scsi}
28 BuildRequires:  cdrtools-devel >= 2:2.01
29 #BuildRequires: cdrtools-devel <= 2:2.01.01a09
30 %endif
31 BuildRequires:  gtk+2-devel >= 2.0.0
32 %{?with_capsimage:BuildRequires:        libcapsimage-devel}
33 BuildRequires:  pkgconfig
34 BuildRequires:  xorg-lib-libX11-devel
35 BuildRequires:  xorg-lib-libXext-devel
36 BuildRequires:  xorg-lib-libXxf86dga-devel
37 BuildRequires:  xorg-lib-libXxf86vm-devel
38 BuildRequires:  xorg-lib-libxkbfile-devel
39 BuildRequires:  zlib-devel
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 This is a version of UAE, the Ubiquitous Amiga Emulator, with an
44 emulation core based on WinUAE 0.8.27. It attempts to bring many of
45 the great features of WinUAE to non-Windows platforms. This version
46 now finally has a name, E-UAE, since that's what everybody was calling
47 it anyway. The 'E' can stand for anything you fancy. Experimental,
48 extreme, exciting, egalitarian, eggplant, ...
49
50 %description -l pl.UTF-8
51 To jest wersja UAE (Ubiquitous Amiga Emulator - wszędobylskiego
52 emulatora Amigi) z rdzeniem emulatora opartym na WinUAE 0.8.27. Jest
53 to próba przeniesienia wielu wspaniałych możliwości WinUAE na
54 platformy inne niż Windows. Ta wersja ma wreszcie nazwę - E-UAE - jako
55 że właśnie tak wszyscy ją nazywali. "E" może oznaczać co tylko chcemy.
56 Eksperymentalny, ekstremalny, ekscytujący, egalitarny...
57
58 %package sdl
59 Summary:        Unix Amiga Emulator, SDL version
60 Summary(pl.UTF-8):      Uniksowy emulator Amigi, wersja SDL
61 Group:          Applications/Emulators
62
63 %description sdl
64 This is a version of UAE, the Ubiquitous Amiga Emulator, with an
65 emulation core based on WinUAE 0.8.27. It attempts to bring many of
66 the great features of WinUAE to non-Windows platforms. This version
67 now finally has a name, E-UAE, since that's what everybody was calling
68 it anyway. The 'E' can stand for anything you fancy. Experimental,
69 extreme, exciting, egalitarian, eggplant, ...
70
71 This version uses SDL as audio and video output.
72
73 %description sdl -l pl.UTF-8
74 To jest wersja UAE (Ubiquitous Amiga Emulator - wszędobylskiego
75 emulatora Amigi) z rdzeniem emulatora opartym na WinUAE 0.8.27. Jest
76 to próba przeniesienia wielu wspaniałych możliwości WinUAE na
77 platformy inne niż Windows. Ta wersja ma wreszcie nazwę - E-UAE - jako
78 że właśnie tak wszyscy ją nazywali. "E" może oznaczać co tylko chcemy.
79 Eksperymentalny, ekstremalny, ekscytujący, egalitarny...
80
81 Ta wersja używa SDL jako wyjścia dźwięk i obrazu.
82
83 %prep
84 %setup -q -n %{name}-%{version}-%{subver}
85 %patch0 -p1
86 %patch1 -p1
87 %patch2 -p1
88
89 %build
90 %{__aclocal} -I m4
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 CONFOPTS=`cat` << EOF
95         --enable-action-replay
96         --enable-aga
97         --enable-audio
98         --enable-autoconfig
99         --enable-bsdsock
100         --enable-bsdsock-new
101         --enable-cd32
102         --enable-cdtv
103         --enable-compatible-cpu
104         --enable-cycle-exact-cpu
105         --enable-enforcer
106         --enable-fdi
107         --enable-scsi-device%{!?with_scsi:=no}
108         --enable-threads
109         --enable-ui
110         --with-caps%{!?with_capsimage:=no}
111 EOF
112
113 %configure \
114         $CONFOPTS \
115         --disable-dga           \
116         --disable-vidmode       \
117         --without-alsa          \
118         --with-sdl              \
119         --with-sdl-gfx          \
120         --with-sdl-gl           \
121         --with-sdl-sound
122 %{__make} -j1
123 %{__mv} src/uae e-uae-sdl
124 %{__make} clean
125
126 %configure \
127         $CONFOPTS \
128         --enable-dga            \
129         --enable-vidmode        \
130         --with-alsa             \
131         --without-sdl           \
132         --without-sdl-gfx       \
133         --without-sdl-sound     \
134         --with-x
135 %{__make} -j1
136 %{__mv} src/uae e-uae
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140 install -d $RPM_BUILD_ROOT{%{_bindir},%{_desktopdir},%{_pixmapsdir}}
141
142 install e-uae* $RPM_BUILD_ROOT%{_bindir}
143 sed %{SOURCE1} -e 's/uae/e-uae/' -e 's/UAE/E-UAE/' \
144         > $RPM_BUILD_ROOT%{_desktopdir}/e-uae.desktop
145 sed %{SOURCE1} -e 's/uae/e-uae-sdl/' -e 's/UAE/E-UAE SDL/' \
146         > $RPM_BUILD_ROOT%{_desktopdir}/e-uae-sdl.desktop
147 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/e-uae.png
148 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/e-uae-sdl.png
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %files
154 %defattr(644,root,root,755)
155 %doc ChangeLog README docs/*
156 %attr(755,root,root) %{_bindir}/e-uae
157 %{_desktopdir}/e-uae.desktop
158 %{_pixmapsdir}/e-uae.png
159
160 %files sdl
161 %defattr(644,root,root,755)
162 %doc ChangeLog README docs/*
163 %attr(755,root,root) %{_bindir}/e-uae-sdl
164 %{_desktopdir}/e-uae-sdl.desktop
165 %{_pixmapsdir}/e-uae-sdl.png
This page took 0.055281 seconds and 3 git commands to generate.