]> git.pld-linux.org Git - packages/dx.git/blob - dx.spec
- build at most in C++14 mode; release 25
[packages/dx.git] / dx.spec
1 Summary:        Excellent tool for making visualization of data
2 Summary(pl.UTF-8):      Doskonałe narzędzie do wizualizacji danych
3 Name:           dx
4 Version:        4.4.4
5 Release:        25
6 License:        IPL
7 Group:          Applications/Science
8 Source0:        http://opendx.npaci.edu/source/%{name}-%{version}.tar.gz
9 # Source0-md5:  6da0c4cd21d3c08f97b7662e3aee5b7b
10 Source1:        http://opendx.npaci.edu/source/%{name}samples-4.4.0.tar.gz
11 # Source1-md5:  e8f43722ca0a66282608bded7c0e4f93
12 Source2:        %{name}.desktop
13 Patch0:         %{name}-DESTDIR.patch
14 Patch1:         %{name}-nolibs.patch
15 Patch2:         %{name}samples-DESTDIR.patch
16 Patch3:         %{name}samples-unused_bin.patch
17 Patch4:         %{name}-include.patch
18 Patch5:         %{name}-ac.patch
19 Patch6:         %{name}-ImageMagic.patch
20 Patch7:         %{name}-open.patch
21 Patch8:         %{name}-gcc43.patch
22 Patch9:         format-security.patch
23 Patch10:        %{name}-narrowing.patch
24 Patch11:        %{name}-conversion.patch
25 URL:            http://www.opendx.org/
26 BuildRequires:  ImageMagick-devel >= 1:6.2.4.0
27 BuildRequires:  OpenGL-GLU-devel
28 BuildRequires:  OpenGL-devel
29 BuildRequires:  autoconf >= 2.57
30 BuildRequires:  automake
31 BuildRequires:  bison
32 BuildRequires:  cdflib-devel
33 BuildRequires:  flex
34 BuildRequires:  hdf-devel
35 BuildRequires:  libjpeg-devel
36 BuildRequires:  libtiff-devel
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  libtool
39 BuildRequires:  motif-devel
40 BuildRequires:  netcdf-devel
41 BuildRequires:  rpm-build >= 4.6
42 BuildRequires:  rpmbuild(macros) >= 1.752
43 BuildRequires:  xorg-lib-libICE-devel
44 BuildRequires:  xorg-lib-libSM-devel
45 BuildRequires:  xorg-lib-libX11-devel
46 BuildRequires:  xorg-lib-libXext-devel
47 BuildRequires:  xorg-lib-libXinerama-devel
48 BuildRequires:  xorg-lib-libXmu-devel
49 BuildRequires:  xorg-lib-libXp-devel
50 BuildRequires:  xorg-lib-libXpm-devel
51 BuildRequires:  xorg-lib-libXt-devel
52 Requires:       %{name}-libs = %{version}-%{release}
53 Requires:       openssh-clients
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %define         specflags_ia32  -fomit-frame-pointer
57 %define         skip_post_check_so      libDXL.so.*
58
59 %description
60 OpenDX is a uniquely powerful, full-featured software package for the
61 visualization of scientific, engineering and analytical data: Its open
62 system design is built on a standard interface environments. And its
63 sophisticated data model provides users with great flexibility in
64 creating visualizations.
65
66 %description -l pl.UTF-8
67 OpenDX jest w pełni funkcjonalnym, o unikalnych możliwościach,
68 pakietem do wizualizacji danych naukowych, inżynierskich i
69 analitycznych. Został zaprojektowany w sposób otwarty, w oparciu o
70 standardowe środowiska interfejsów. Jego przemyślany model danych daje
71 użytkownikom dużą elastyczność w tworzeniu wizualizacji.
72
73 %package libs
74 Summary:        OpenDX shared libraries
75 Summary(pl.UTF-8):      Biblioteki współdzielone OpenDX
76 Group:          Libraries
77
78 %description libs
79 OpenDX shared libraries.
80
81 %description libs -l pl.UTF-8
82 Biblioteki współdzielone OpenDX.
83
84 %package devel
85 Summary:        OpenDX development files
86 Summary(pl.UTF-8):      Pliki nagłówkowe OpenDX
87 Group:          Development/Libraries
88 Requires:       %{name}-libs = %{version}-%{release}
89
90 %description devel
91 OpenDX development files.
92
93 %description devel -l pl.UTF-8
94 Pliki nagłówkowe OpenDX oraz inne pliki, potrzebne do budowania.
95
96 %package static
97 Summary:        OpenDX static libraries
98 Summary(pl.UTF-8):      Biblioteki statyczne OpenDX
99 Group:          Development/Libraries
100 Requires:       %{name}-devel = %{version}-%{release}
101
102 %description static
103 OpenDX static libraries.
104
105 %description static -l pl.UTF-8
106 Biblioteki statyczne OpenDX.
107
108 %package doc
109 Summary:        OpenDX documentation
110 Summary(pl.UTF-8):      Dokumentacja OpenDX
111 Group:          Documentation
112 BuildArch:      noarch
113
114 %description doc
115 Online help and html documentation for OpenDX.
116
117 %description doc -l pl.UTF-8
118 Podręczna pomoc oraz dokumentacja html dla OpenDX.
119
120 %package examples
121 Summary:        OpenDX Examples
122 Summary(pl.UTF-8):      Przykłady dla OpenDX
123 Group:          Documentation
124 BuildArch:      noarch
125
126 %description examples
127 Examples for OpenDX.
128
129 %description examples -l pl.UTF-8
130 Przykłady dla OpenDX.
131
132 %prep
133 %setup  -q -a 1
134 #%patch0 -p1
135 %patch1 -p1
136 %patch2 -p0
137 %patch3 -p1
138 %patch4 -p1
139 %patch5 -p1
140 %patch6 -p1
141 %patch7 -p1
142 %patch8 -p1
143 %patch9 -p1
144 %patch10 -p1
145 %patch11 -p1
146
147 %build
148 %if "%{_ver_ge '%{cxx_version}' '11.0'}" == "1"
149 # lower C++ standard because C++17 std::byte conflicts with local "byte" define
150 export CXXFLAGS="%{rpmcxxflags} -std=c++14"
151 %endif
152 %{__libtoolize}
153 %{__aclocal} -I m4
154 %{__autoheader}
155 %{__autoconf}
156 %{__automake}
157 CPPFLAGS="%{rpmcppflags} -I/usr/include/cdf"
158 %configure \
159         --prefix=%{_datadir} \
160         --enable-shared \
161         --enable-static \
162         --disable-dependency-tracking \
163         --enable-smp-linux \
164         --enable-new-keylayout \
165         --without-javadx \
166         --with-rsh=%{_bindir}/ssh
167
168 cd %{name}samples-4.4.0
169 %{__aclocal}
170 %{__autoheader}
171 %{__autoconf}
172 %{__automake}
173 %configure \
174         --prefix=%{_examplesdir} \
175         --without-javadx
176 cd ..
177
178 %{__make} -j1
179
180 %{__make} -j1 -C %{name}samples-4.4.0
181
182 %install
183 rm -rf $RPM_BUILD_ROOT
184
185 %{__make} install \
186         DESTDIR=$RPM_BUILD_ROOT
187
188 %{__make} -C %{name}samples-4.4.0 install \
189         DESTDIR=$RPM_BUILD_ROOT
190
191 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir},%{_mandir},%{_desktopdir},%{_pixmapsdir}}
192 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
193
194 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
195 cp -p src/uipp/ui/icon50.xpm $RPM_BUILD_ROOT%{_pixmapsdir}/dx.xpm
196 %{__mv} $RPM_BUILD_ROOT%{_datadir}/bin/dx $RPM_BUILD_ROOT%{_bindir}
197 %{__mv} $RPM_BUILD_ROOT%{_datadir}/dx/man/manl $RPM_BUILD_ROOT%{_mandir}
198 %{__mv} $RPM_BUILD_ROOT%{_datadir}/dx/include/* $RPM_BUILD_ROOT%{_includedir}
199 %{__mv} $RPM_BUILD_ROOT%{_datadir}/dx/lib_linux $RPM_BUILD_ROOT%{_libdir}/dx
200 %{__mv} $RPM_BUILD_ROOT%{_datadir}/dx/bin_linux $RPM_BUILD_ROOT%{_libdir}/dx
201 %{__mv} $RPM_BUILD_ROOT%{_examplesdir}/dx/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
202 ln -s %{_libdir}/dx $RPM_BUILD_ROOT%{_datadir}/dx/lib_linux
203 ln -s %{_libdir}/dx/bin_linux $RPM_BUILD_ROOT%{_datadir}/dx
204 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{bin,dx/{bin/dx,man,include,doc}}
205
206 %clean
207 rm -rf $RPM_BUILD_ROOT
208
209 %files
210 %defattr(644,root,root,755)
211 %doc doc/README*
212 %attr(755,root,root) %{_bindir}/dx
213 %dir %{_datadir}/dx
214 %attr(755,root,root) %{_datadir}/dx/bin
215 %{_datadir}/dx/bin_linux
216 %{_datadir}/dx/fonts
217 %{_datadir}/dx/lib
218 %{_datadir}/dx/lib_linux
219 %{_datadir}/dx/ui
220 # FIXME: should be dx(1)
221 %{_mandir}/manl/dx.l*
222 %{_desktopdir}/dx.desktop
223 %{_pixmapsdir}/dx.xpm
224
225 %files libs
226 %defattr(644,root,root,755)
227 %dir %{_libdir}/dx
228 %dir %{_libdir}/dx/bin_linux
229 %attr(755,root,root) %{_libdir}/dx/bin_linux/*
230 %attr(755,root,root) %{_libdir}/dx/libDX*.so.*
231
232 %files devel
233 %defattr(644,root,root,755)
234 %attr(755,root,root) %{_libdir}/dx/libDX*.so
235 %{_includedir}/dx
236 %{_includedir}/dxconfig.h
237 %{_includedir}/dxl.h
238 %{_includedir}/dxstereo.h
239 %{_libdir}/dx/libDX*.la
240 %{_libdir}/dx/arch.mak
241
242 %files static
243 %defattr(644,root,root,755)
244 %{_libdir}/dx/libDX*.a
245
246 %files doc
247 %defattr(644,root,root,755)
248 %{_datadir}/dx/help
249 %{_datadir}/dx/html
250
251 %files examples
252 %defattr(644,root,root,755)
253 %{_examplesdir}/%{name}-%{version}
This page took 0.057462 seconds and 3 git commands to generate.