]> git.pld-linux.org Git - packages/dwarves.git/blob - dwarves.spec
- cmake options to use optflags and don't hide build commands
[packages/dwarves.git] / dwarves.spec
1 Summary:        Dwarf Tools
2 Summary(pl.UTF-8):      Narzędzia Dwarf
3 Name:           dwarves
4 Version:        1.0
5 Release:        1
6 License:        GPL v2
7 Group:          Development/Tools
8 URL:            http://oops.ghostprotocols.net:81/blog
9 Source0:        http://userweb.kernel.org/~acme/%{name}-%{version}.tar.bz2
10 # Source0-md5:  d23bbf3a7fd6f084883c1071dd921267
11 BuildRequires:  cmake
12 BuildRequires:  elfutils-devel
13 BuildRequires:  rpmbuild(macros) >= 1.293
14 Requires:       %{name}-libs = %{version}-%{release}
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 dwarves is a set of tools that use the DWARF debugging information
19 inserted in ELF binaries by compilers such as GCC, used by well known
20 debuggers such as GDB, and more recent ones such as systemtap.
21
22 Utilities in the dwarves suite include pahole, that can be used to
23 find alignment holes in structs and classes in languages such as C,
24 C++, but not limited to these, and other information such as CPU
25 cacheline alignment, helping pack those structures to achieve more
26 cache hits, codiff, a diff like tool to compare the effects changes in
27 source code generate on the resulting binaries, pfunct, that can be
28 used to find all sorts of information about functions, inlines,
29 decisions made by the compiler about inlining, etc.
30
31 %description -l pl.UTF-8
32 dwarves to zestaw narzędzi wykorzystujących informacje dla debuggera
33 w formacie DWARF umieszczane w binariach ELF przez kompilatory takie
34 jak GCC, używane przez dobrze znane debuggery takie jak GDB czy nowsze
35 takie jak systemtap.
36
37 Narzędzia ze zestawie dwarves zawierają pahole (do wyszukiwania dziur
38 wyrównań w strukturach i klasach w językach takich jak C czy C++ oraz
39 uzyskiwania innych informacji takich jak wyrównanie linii cache'a CPU,
40 co pomaga przy pakowaniu struktur dla osiągnięcia lepszej wydajności),
41 codiff (narzędzie podobne do diffa do porównywania wpływu zmian w
42 kodzie źródłowym na pliki wynikowe), pfunct (do znajdowania różnego
43 rodzaju informacji o funkcjach, funkcjach inline, decyzjach
44 dotyczących inline podejmowanych przez kompilator itp.).
45
46 %package libs
47 Summary:        DWARF processing library
48 Summary(pl.UTF-8):      Biblioteka do przetwarzania informacji DWARF
49 Group:          Libraries
50
51 %description libs
52 DWARF processing library.
53
54 %description libs -l pl.UTF-8
55 Biblioteka do przetwarzania informacji DWARF.
56
57 %package devel
58 Summary:        DWARF processing library development files
59 Summary(pl.UTF-8):      Pliki programistyczne biblioteki do przetwarzania informacji DWARF
60 Group:          Development/Libraries
61 Requires:       %{name}-libs = %{version}-%{release}
62
63 %description devel
64 DWARF processing library development files.
65
66 %description devel -l pl.UTF-8
67 Pliki programistyczne biblioteki do przetwarzania informacji DWARF.
68
69 %prep
70 %setup -q -c
71
72 %build
73 %cmake \
74         -D__LIB=%{_lib} \
75         -DCMAKE_BUILD_TYPE="None" \
76         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
77         -DCMAKE_VERBOSE_MAKEFILE=1 \
78         .
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so*
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   libs -p /sbin/ldconfig
93 %postun libs -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc README.ctracer
98 %attr(755,root,root) %{_bindir}/*
99 %{_datadir}/dwarves
100
101 %files libs
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_libdir}/libdwarves*.so.*.*.*
104 %attr(755,root,root) %ghost %{_libdir}/libdwarves*.so.?
105
106 %files devel
107 %defattr(644,root,root,755)
108 %doc MANIFEST README
109 %attr(755,root,root) %{_libdir}/libdwarves*.so
110 %{_includedir}/dwarves*.h
This page took 0.058944 seconds and 3 git commands to generate.