]> git.pld-linux.org Git - packages/dwarves.git/blob - dwarves.spec
- BR: rpm-pythonprov
[packages/dwarves.git] / dwarves.spec
1 Summary:        Dwarf Tools
2 Summary(pl.UTF-8):      Narzędzia Dwarf
3 Name:           dwarves
4 Version:        1.0
5 Release:        1
6 License:        GPL v2
7 Group:          Development/Tools
8 Source0:        http://userweb.kernel.org/~acme/%{name}-%{version}.tar.bz2
9 # Source0-md5:  d23bbf3a7fd6f084883c1071dd921267
10 URL:            http://oops.ghostprotocols.net:81/blog
11 BuildRequires:  cmake
12 BuildRequires:  elfutils-devel
13 BuildRequires:  rpm-pythonprov
14 BuildRequires:  rpmbuild(macros) >= 1.293
15 Requires:       %{name}-libs = %{version}-%{release}
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 dwarves is a set of tools that use the DWARF debugging information
20 inserted in ELF binaries by compilers such as GCC, used by well known
21 debuggers such as GDB, and more recent ones such as systemtap.
22
23 Utilities in the dwarves suite include pahole, that can be used to
24 find alignment holes in structs and classes in languages such as C,
25 C++, but not limited to these, and other information such as CPU
26 cacheline alignment, helping pack those structures to achieve more
27 cache hits, codiff, a diff like tool to compare the effects changes in
28 source code generate on the resulting binaries, pfunct, that can be
29 used to find all sorts of information about functions, inlines,
30 decisions made by the compiler about inlining, etc.
31
32 %description -l pl.UTF-8
33 dwarves to zestaw narzędzi wykorzystujących informacje dla debuggera
34 w formacie DWARF umieszczane w binariach ELF przez kompilatory takie
35 jak GCC, używane przez dobrze znane debuggery takie jak GDB czy nowsze
36 takie jak systemtap.
37
38 Narzędzia ze zestawie dwarves zawierają pahole (do wyszukiwania dziur
39 wyrównań w strukturach i klasach w językach takich jak C czy C++ oraz
40 uzyskiwania innych informacji takich jak wyrównanie linii cache'a CPU,
41 co pomaga przy pakowaniu struktur dla osiągnięcia lepszej wydajności),
42 codiff (narzędzie podobne do diffa do porównywania wpływu zmian w
43 kodzie źródłowym na pliki wynikowe), pfunct (do znajdowania różnego
44 rodzaju informacji o funkcjach, funkcjach inline, decyzjach
45 dotyczących inline podejmowanych przez kompilator itp.).
46
47 %package libs
48 Summary:        DWARF processing library
49 Summary(pl.UTF-8):      Biblioteka do przetwarzania informacji DWARF
50 Group:          Libraries
51
52 %description libs
53 DWARF processing library.
54
55 %description libs -l pl.UTF-8
56 Biblioteka do przetwarzania informacji DWARF.
57
58 %package devel
59 Summary:        DWARF processing library development files
60 Summary(pl.UTF-8):      Pliki programistyczne biblioteki do przetwarzania informacji DWARF
61 Group:          Development/Libraries
62 Requires:       %{name}-libs = %{version}-%{release}
63
64 %description devel
65 DWARF processing library development files.
66
67 %description devel -l pl.UTF-8
68 Pliki programistyczne biblioteki do przetwarzania informacji DWARF.
69
70 %prep
71 %setup -q -c
72
73 %build
74 %cmake \
75         -D__LIB=%{_lib} \
76         -DCMAKE_BUILD_TYPE="None" \
77         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
78         -DCMAKE_VERBOSE_MAKEFILE=ON \
79         -DCMAKE_CXX_COMPILER_WORKS=1 \
80         -DCMAKE_CXX_COMPILER="%{__cc}" \
81         .
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so*
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   libs -p /sbin/ldconfig
96 %postun libs -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc README.ctracer
101 %attr(755,root,root) %{_bindir}/*
102 %{_datadir}/dwarves
103
104 %files libs
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_libdir}/libdwarves*.so.*.*.*
107 %attr(755,root,root) %ghost %{_libdir}/libdwarves*.so.?
108
109 %files devel
110 %defattr(644,root,root,755)
111 %doc MANIFEST README
112 %attr(755,root,root) %{_libdir}/libdwarves*.so
113 %{_includedir}/dwarves*.h
This page took 0.066959 seconds and 3 git commands to generate.