]> git.pld-linux.org Git - packages/dvdrip.git/blob - dvdrip.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/dvdrip.git] / dvdrip.spec
1 # Conditional build:
2 %bcond_with     tests   # perform "make test" (needs working, not busy /dev/audio!)
3 #
4 Summary:        Video::DVDRip Perl module
5 Summary(cs.UTF-8):      Modul Video::DVDRip pro Perl
6 Summary(da.UTF-8):      Perlmodul Video::DVDRip
7 Summary(de.UTF-8):      Video::DVDRip Perl Modul
8 Summary(es.UTF-8):      Módulo de Perl Video::DVDRip
9 Summary(fr.UTF-8):      Module Perl Video::DVDRip
10 Summary(it.UTF-8):      Modulo di Perl Video::DVDRip
11 Summary(ja.UTF-8):      Video::DVDRip Perl モジュール
12 Summary(ko.UTF-8):      Video::DVDRip 펄 모줄
13 Summary(nb.UTF-8):      Perlmodul Video::DVDRip
14 Summary(pl.UTF-8):      Moduł Perla Video::DVDRip
15 Summary(pt.UTF-8):      Módulo de Perl Video::DVDRip
16 Summary(pt_BR.UTF-8):   Módulo Perl Video::DVDRip
17 Summary(ru.UTF-8):      Модуль для Perl Video::DVDRip
18 Summary(sv.UTF-8):      Video::DVDRip Perlmodul
19 Summary(uk.UTF-8):      Модуль для Perl Video::DVDRip
20 Summary(zh_CN.UTF-8):   Video::DVDRip Perl 模块
21 Name:           dvdrip
22 Version:        0.98.11
23 Release:        1
24 # same as perl
25 License:        GPL v1+ or Artistic
26 Group:          Development/Languages/Perl
27 Source0:        http://www.exit1.org/dvdrip/dist/%{name}-%{version}.tar.gz
28 # Source0-md5:  6dfa4199d451757a37eea233a07da4c0
29 Patch0:         %{name}-locale_path.patch
30 URL:            http://www.exit1.org/dvdrip/
31 BuildRequires:  perl-AnyEvent
32 BuildRequires:  perl-Event
33 BuildRequires:  perl-Event-RPC
34 BuildRequires:  perl-Event-ExecFlow
35 BuildRequires:  perl-Gtk2-Ex-FormFactory
36 BuildRequires:  perl-devel >= 1:5.8.0
37 BuildRequires:  perl-libintl >= 1.16
38 BuildRequires:  rpm-perlprov >= 4.1-13
39 Requires:       ImageMagick
40 Requires:       perl-libintl >= 1.16
41 Requires:       transcode
42 Suggests:       ffmpeg
43 Suggests:       mplayer
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %define         _noautoreq      'perl(Video::DVDRip::Task)'
47
48 %description
49 dvd::rip is a Perl GTK+ based DVD copy program build on top of a low
50 level DVD Ripping API, which uses the Linux Video Stream Processing
51 Tool transcode, written by Thomas Oestreich.
52
53 %description -l en.UTF-8
54 dvd::rip is a Perl GTK+ based DVD copy program build on top of a low
55 level DVD Ripping API, which uses the Linux Video Stream Processing
56 Tool transcode, written by Thomas Östreich.
57
58 %description -l pl.UTF-8
59 dvd::rip jest opartym na GTK+ programem w Perlu do kopiowania DVD,
60 zbudowanym w oparciu o niskopoziomowe API DVD Ripping, które z kolei
61 korzysta z transcode - linuksowego narzędzia do obróbki strumieni
62 obrazu, napisanego przez Thomasa Östreicha.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67
68 %build
69 export SKIP_UNPACK_REQUIRED_MODULES=1
70 %{__perl} Makefile.PL \
71         INSTALLDIRS=vendor
72 %{__make} -j1 \
73         CC="%{__cc}" \
74         CFLAGS="%{rpmcflags}"
75
76 %{?with_tests:%{__make} test}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %{__make} install \
82         DESTDIR=$RPM_BUILD_ROOT
83 mv $RPM_BUILD_ROOT%{perl_vendorlib}/LocaleData $RPM_BUILD_ROOT%{_datadir}/locale
84
85 %find_lang video.%{name}
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files -f video.%{name}.lang
91 %defattr(644,root,root,755)
92 %doc Changes Credits README TODO
93 %attr(755,root,root) %{_bindir}/*
94 %{perl_vendorlib}/Video
95 %{_mandir}/man1/*
96 %{_mandir}/man3/Video*
This page took 0.065641 seconds and 4 git commands to generate.