]> git.pld-linux.org Git - packages/dvdrip.git/blob - dvdrip.spec
- initial PLD spec
[packages/dvdrip.git] / dvdrip.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Video-DVDRip module for perl
3 Name:           perl-Video-DVDRip
4 Version:        0.44
5 Release:        0.1
6 Copyright:      distributable
7 Group:          Development/Languages/Perl
8 Source0:        http://www.exit1.org/dvdrip/dist/Video-DVDRip-%{version}.tar.gz
9 URL:            http://www.exit1.org/dvdrip/
10 BuildRequires:  perl >= 5.6
11 BuildRequires:  rpm-perlprov >= 3.0.3-16
12 BuildRequires:  perl-gtk
13 BuildRequires:  gdk-pixbuf-devel
14 Requires:       transcode
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 dvd::rip is a Perl Gtk+ based DVD copy program build on top of a low
19 level DVD Ripping API, which uses the Linux Video Stream Processing
20 Tool transcode, written by Thomas Ã–streich.
21
22 %prep
23 %setup -q -n Video-DVDRip-%{version}
24
25 %build
26 CFLAGS="%{rpmcflags}" perl Makefile.PL
27 %{__make}
28 %{__make} test
29
30 %install
31 rm -rf $RPM_BUILD_ROOT
32
33 eval `perl '-V:installarchlib'`
34 install -d $RPM_BUILD_ROOT/$installarchlib
35 %{__make} PREFIX=$RPM_BUILD_ROOT%{_prefix} install
36
37 find $RPM_BUILD_ROOT%{_prefix} -type f -print |
38         sed "s@^$RPM_BUILD_ROOT@@g" |
39         grep -v perllocal.pod |
40         grep -v "\.packlist" > Video-DVDRip-%{version}-filelist
41 if [ "$(cat Video-DVDRip-%{version}-filelist)X" = "X" ] ; then
42     echo "ERROR: EMPTY FILE LIST"
43     exit -1
44 fi
45
46 %files -f Video-DVDRip-%{version}-filelist
47 %defattr(644,root,root,755)
This page took 0.085647 seconds and 4 git commands to generate.