]> git.pld-linux.org Git - packages/dumb.git/blob - dumb.spec
- build -fPIC for x86_64
[packages/dumb.git] / dumb.spec
1 # TODO
2 # - build shared lib
3 # - do we need debug version of libraires/headers?
4 Summary:        DUMB - Dedicated Universal Music Bastardisation
5 Summary(pl.UTF-8):      DUMB - Dedicated Universal Music Bastardisation
6 Name:           dumb
7 Version:        0.9.3
8 Release:        3
9 License:        GPL-like
10 Group:          Development/Libraries
11 Source0:        http://dl.sourceforge.net/dumb/%{name}-%{version}.tar.gz
12 # Source0-md5:  f48da5b990aa8aa822d3b6a951baf5c2
13 URL:            http://dumb.sourceforge.net/
14 BuildRequires:  allegro-devel
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         specflags_ia32          -fomit-frame-pointer
18 %define         specflags_x86_64        -fPIC
19
20 %description
21 DUMB - Dedicated Universal Music Bastardisation library.
22
23 %description -l pl.UTF-8
24 Biblioteka DUMB - Dedicated Universal Music Bastardisation.
25
26 %package devel
27 Summary:        Header files for dumb
28 Summary(pl.UTF-8):      Pliki nagłówkowe dla dumb
29 Group:          Development/Libraries
30 Requires:       %{name}-static = %{version}-%{release}
31 # for libaldmb
32 #Requires:      allegro-devel
33
34 %description devel
35 dumb header files.
36
37 %description devel -l pl.UTF-8
38 Pliki nagłówkowe dla dumb.
39
40 %package static
41 Summary:        Static libraries for dumb
42 Summary(pl.UTF-8):      Statyczne biblioteki dla dumb
43 Group:          Development/Libraries
44 Requires:       %{name}-devel = %{version}-%{release}
45
46 %description static
47 dumb static libraries.
48
49 %description static -l pl.UTF-8
50 Biblioteki statyczne dla dumb.
51
52 %prep
53 %setup -q
54
55 %build
56 cat <<EOF > make/config.txt
57 include make/unix.inc
58 ALL_TARGETS := core core-examples core-headers
59 ALL_TARGETS += allegro allegro-examples allegro-headers
60 PREFIX := /usr
61 EOF
62
63 %{__make} all \
64         CC="%{__cc}" \
65         LDFLAGS="%{rpmldflags}" \
66         OFLAGS="%{rpmcflags}" \
67         DBGFLAGS="-DDEBUGMODE=1 %{rpmcflags}"
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT{%{_includedir},%{_libdir},%{_bindir}}
72
73 %{__make} install \
74         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
75         LIB_INSTALL_PATH=$RPM_BUILD_ROOT%{_libdir}
76
77 %{__make} install \
78         DEBUGMODE=1 \
79         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
80         LIB_INSTALL_PATH=$RPM_BUILD_ROOT%{_libdir}
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc *.txt docs/*
88 %attr(755,root,root) %{_bindir}/dumb*
89
90 %files devel
91 %defattr(644,root,root,755)
92 %{_includedir}/dumb.h
93 %{_includedir}/aldumb.h
94
95 %files static
96 %defattr(644,root,root,755)
97 %{_libdir}/libdumb.a
98 %{_libdir}/libdumbd.a
99 %{_libdir}/libaldmb.a
100 %{_libdir}/libaldmd.a
This page took 1.831337 seconds and 3 git commands to generate.