]> git.pld-linux.org Git - packages/dtc.git/blobdiff - dtc-python.patch
- updated to 1.4.7
[packages/dtc.git] / dtc-python.patch
diff --git a/dtc-python.patch b/dtc-python.patch
new file mode 100644 (file)
index 0000000..d2ef468
--- /dev/null
@@ -0,0 +1,19 @@
+--- dtc-1.4.7/pylibfdt/Makefile.pylibfdt.orig  2018-07-23 05:00:50.000000000 +0200
++++ dtc-1.4.7/pylibfdt/Makefile.pylibfdt       2018-08-24 20:25:46.505442238 +0200
+@@ -8,7 +8,7 @@
+ define run_setup
+       SOURCES="$(1)" CPPFLAGS="$(CPPFLAGS)" OBJDIR="$(PYLIBFDT_objdir)"
+       VERSION="$(dtc_version)"
+-      $(PYLIBFDT_objdir)/setup.py --quiet $(2)
++      $(PYLIBFDT_objdir)/setup.py $(2)
+ endef
+ $(PYMODULE): $(PYLIBFDT_srcs)
+@@ -19,6 +19,6 @@
+ install_pylibfdt: $(PYMODULE)
+       $(VECHO) INSTALL-PYLIB; \
+       $(call run_setup, $(PYLIBFDT_srcs), \
+-              install $(if $(SETUP_PREFIX),--prefix=$(SETUP_PREFIX)))
++              install --optimize=2 $(if $(SETUP_PREFIX),--prefix=$(SETUP_PREFIX)) $(if $(DESTDIR),--root=$(DESTDIR)))
+ PYLIBFDT_cleanfiles = libfdt_wrap.c libfdt.py libfdt.pyc _libfdt.so
This page took 0.682953 seconds and 4 git commands to generate.