]> git.pld-linux.org Git - packages/dtc.git/blame - dtc.spec
- non-parallel install as well
[packages/dtc.git] / dtc.spec
CommitLineData
f18f0eaf 1#
6861f1fc 2# Conditional build:
2b797ed5 3%bcond_without python # Python module
6861f1fc 4%bcond_without verbose # verbose build (V=1)
cff8604d 5
6861f1fc 6Summary: The Device Tree Compiler
cff8604d 7Summary(pl.UTF-8): Kompilator drzewiastej struktury urządzeń
6861f1fc 8Name: dtc
668ea320 9Version: 1.5.0
fffeac36
JB
10Release: 1
11License: GPL v2+ (dtc), GPL v2+ or BSD (fdt library)
6861f1fc 12Group: Libraries
cc076a48 13Source0: https://www.kernel.org/pub/software/utils/dtc/%{name}-%{version}.tar.xz
668ea320 14# Source0-md5: 1e7f54238d991b81c54fb5aabf71ff23
2b797ed5 15Patch0: %{name}-python.patch
cc076a48 16URL: http://www.devicetree.org/Device_Tree_Compiler
4ecc89ea 17BuildRequires: bison
18BuildRequires: flex
cc076a48
JB
19BuildRequires: tar >= 1:1.22
20BuildRequires: xz
2b797ed5
JB
21%if %{with python}
22BuildRequires: python-devel >= 2
23BuildRequires: swig-python
24%endif
fad8e447 25Requires: libfdt = %{version}-%{release}
cff8604d 26Obsoletes: dtc-doc < 1.3.0-2
6861f1fc
ER
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%{?debug:%define with_verbose 1}
30
31%description
32The Device Tree Compiler, dtc, takes as input a device-tree in a given
33format and outputs a device-tree in another format. Typically, the
34input format is "dts", a human readable source format, and creates a
35"dtb", or binary format as output.
36
b14054e0 37%description -l pl.UTF-8
38Kompilator drzewiastej struktury urządzeń, dtc, przyjmuje na wejściu
39dane w jednym formacie by na wyjściu wyprodukować strukturę danych w
40innym. Najczęściej format wejściowy to "dts", intuicyjny i łatwy w
41odczycie (tzw. human readable), natomiast wyjściowy to "dtb" lub
42inaczej format binarny.
43
fad8e447
JR
44%package -n libfdt
45Summary: Device tree library
46Summary(pl.UTF-8): Biblioteka drzewiastej struktury urządzeń
fffeac36 47License: GPL v2+ or BSD
fad8e447 48Group: Libraries
cff8604d 49Obsoletes: dtc-doc < 1.3.0-2
fad8e447
JR
50# does not require base. see README.license
51
52%description -n libfdt
53Device tree library.
54
55%description -n libfdt -l pl.UTF-8
56Biblioteka drzewiastej struktury urządzeń.
57
58%package -n libfdt-devel
6861f1fc
ER
59Summary: Header files for fdt library
60Summary(pl.UTF-8): Pliki nagłówkowe biblioteki fdt
fffeac36 61License: GPL v2+ or BSD
6861f1fc 62Group: Development/Libraries
fad8e447
JR
63Requires: libfdt = %{version}-%{release}
64Obsoletes: dtc-devel
cff8604d 65Obsoletes: dtc-doc < 1.3.0-2
6861f1fc 66
fad8e447 67%description -n libfdt-devel
6861f1fc
ER
68Header files for fdt library.
69
fad8e447 70%description -n libfdt-devel -l pl.UTF-8
6861f1fc
ER
71Pliki nagłówkowe biblioteki fdt.
72
fad8e447 73%package -n libfdt-static
6861f1fc
ER
74Summary: Static fdt library
75Summary(pl.UTF-8): Statyczna biblioteka fdt
fffeac36 76License: GPL v2+ or BSD
6861f1fc 77Group: Development/Libraries
fad8e447
JR
78Requires: libfdt-devel = %{version}-%{release}
79Obsoletes: dtc-static
6861f1fc 80
fad8e447 81%description -n libfdt-static
6861f1fc
ER
82Static fdt library.
83
fad8e447 84%description -n libfdt-static -l pl.UTF-8
6861f1fc
ER
85Statyczna biblioteka fdt.
86
2b797ed5
JB
87%package -n python-libfdt
88Summary: Python binding for fdt library
89Summary(pl.UTF-8): Wiązanie Pythona do biblioteki fdt
90License: GPL v2+ or BSD
91Group: Libraries/Python
92
93%description -n python-libfdt
94Python binding for fdt library.
95
96%description -n python-libfdt -l pl.UTF-8
97Wiązanie Pythona do biblioteki fdt.
98
6861f1fc 99%prep
cc076a48 100%setup -q
2b797ed5 101%patch0 -p1
6861f1fc
ER
102
103%build
6a971399 104%{__make} -j1 \
6861f1fc
ER
105 %{?with_verbose:V=1} \
106 CC="%{__cc}" \
2b797ed5
JB
107 CFLAGS="%{rpmcflags} -fPIC" \
108 %{!?with_python:NO_PYTHON=1}
6861f1fc
ER
109
110%install
111rm -rf $RPM_BUILD_ROOT
6a971399 112
b16cce73 113%{__make} -j1 install \
cff8604d 114 DESTDIR=$RPM_BUILD_ROOT \
6861f1fc
ER
115 %{?with_verbose:V=1} \
116 PREFIX=%{_prefix} \
2b797ed5
JB
117 LIBDIR=%{_libdir} \
118 %{!?with_python:NO_PYTHON=1} \
119 SETUP_PREFIX=%{_prefix}
120
121%if %{with python}
122%py_postclean
123%endif
6861f1fc
ER
124
125%clean
126rm -rf $RPM_BUILD_ROOT
127
f18f0eaf 128%post -n libfdt -p /sbin/ldconfig
cff8604d 129%postun -n libfdt -p /sbin/ldconfig
fad8e447 130
6861f1fc
ER
131%files
132%defattr(644,root,root,755)
cc076a48 133%doc README README.license
fad8e447 134%attr(755,root,root) %{_bindir}/convert-dtsv0
6861f1fc 135%attr(755,root,root) %{_bindir}/dtc
fad8e447 136%attr(755,root,root) %{_bindir}/dtdiff
cc076a48
JB
137%attr(755,root,root) %{_bindir}/fdtdump
138%attr(755,root,root) %{_bindir}/fdtget
2b797ed5 139%attr(755,root,root) %{_bindir}/fdtoverlay
cc076a48 140%attr(755,root,root) %{_bindir}/fdtput
fad8e447
JR
141
142%files -n libfdt
143%defattr(644,root,root,755)
144%attr(755,root,root) %{_libdir}/libfdt-%{version}.so
145%attr(755,root,root) %ghost %{_libdir}/libfdt.so.1
6861f1fc 146
fad8e447 147%files -n libfdt-devel
6861f1fc 148%defattr(644,root,root,755)
cff8604d 149%doc TODO Documentation/manual.txt
fad8e447 150%attr(755,root,root) %{_libdir}/libfdt.so
6861f1fc
ER
151%{_includedir}/fdt.h
152%{_includedir}/libfdt.h
cc076a48 153%{_includedir}/libfdt_env.h
6861f1fc 154
fad8e447 155%files -n libfdt-static
6861f1fc
ER
156%defattr(644,root,root,755)
157%{_libdir}/libfdt.a
2b797ed5
JB
158
159%if %{with python}
160%files -n python-libfdt
161%defattr(644,root,root,755)
162%attr(755,root,root) %{py_sitedir}/_libfdt.so
668ea320 163%{py_sitedir}/libfdt.py[co]
2b797ed5
JB
164%{py_sitedir}/libfdt-%{version}-py*.egg-info
165%endif
This page took 1.406668 seconds and 4 git commands to generate.