]> git.pld-linux.org Git - packages/dtc.git/blame - dtc.spec
- updated to 1.4.4
[packages/dtc.git] / dtc.spec
CommitLineData
f18f0eaf 1#
6861f1fc
ER
2# Conditional build:
3%bcond_without verbose # verbose build (V=1)
cff8604d 4
6861f1fc 5Summary: The Device Tree Compiler
cff8604d 6Summary(pl.UTF-8): Kompilator drzewiastej struktury urządzeń
6861f1fc 7Name: dtc
e4aed906 8Version: 1.4.4
fffeac36
JB
9Release: 1
10License: GPL v2+ (dtc), GPL v2+ or BSD (fdt library)
6861f1fc 11Group: Libraries
cc076a48 12Source0: https://www.kernel.org/pub/software/utils/dtc/%{name}-%{version}.tar.xz
e4aed906 13# Source0-md5: 290318bab4d9e61e7fb7426b4666ad4d
cc076a48 14URL: http://www.devicetree.org/Device_Tree_Compiler
4ecc89ea 15BuildRequires: bison
16BuildRequires: flex
cc076a48
JB
17BuildRequires: tar >= 1:1.22
18BuildRequires: xz
fad8e447 19Requires: libfdt = %{version}-%{release}
cff8604d 20Obsoletes: dtc-doc < 1.3.0-2
6861f1fc
ER
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%{?debug:%define with_verbose 1}
24
25%description
26The Device Tree Compiler, dtc, takes as input a device-tree in a given
27format and outputs a device-tree in another format. Typically, the
28input format is "dts", a human readable source format, and creates a
29"dtb", or binary format as output.
30
b14054e0 31%description -l pl.UTF-8
32Kompilator drzewiastej struktury urządzeń, dtc, przyjmuje na wejściu
33dane w jednym formacie by na wyjściu wyprodukować strukturę danych w
34innym. Najczęściej format wejściowy to "dts", intuicyjny i łatwy w
35odczycie (tzw. human readable), natomiast wyjściowy to "dtb" lub
36inaczej format binarny.
37
fad8e447
JR
38%package -n libfdt
39Summary: Device tree library
40Summary(pl.UTF-8): Biblioteka drzewiastej struktury urządzeń
fffeac36 41License: GPL v2+ or BSD
fad8e447 42Group: Libraries
cff8604d 43Obsoletes: dtc-doc < 1.3.0-2
fad8e447
JR
44# does not require base. see README.license
45
46%description -n libfdt
47Device tree library.
48
49%description -n libfdt -l pl.UTF-8
50Biblioteka drzewiastej struktury urządzeń.
51
52%package -n libfdt-devel
6861f1fc
ER
53Summary: Header files for fdt library
54Summary(pl.UTF-8): Pliki nagłówkowe biblioteki fdt
fffeac36 55License: GPL v2+ or BSD
6861f1fc 56Group: Development/Libraries
fad8e447
JR
57Requires: libfdt = %{version}-%{release}
58Obsoletes: dtc-devel
cff8604d 59Obsoletes: dtc-doc < 1.3.0-2
6861f1fc 60
fad8e447 61%description -n libfdt-devel
6861f1fc
ER
62Header files for fdt library.
63
fad8e447 64%description -n libfdt-devel -l pl.UTF-8
6861f1fc
ER
65Pliki nagłówkowe biblioteki fdt.
66
fad8e447 67%package -n libfdt-static
6861f1fc
ER
68Summary: Static fdt library
69Summary(pl.UTF-8): Statyczna biblioteka fdt
fffeac36 70License: GPL v2+ or BSD
6861f1fc 71Group: Development/Libraries
fad8e447
JR
72Requires: libfdt-devel = %{version}-%{release}
73Obsoletes: dtc-static
6861f1fc 74
fad8e447 75%description -n libfdt-static
6861f1fc
ER
76Static fdt library.
77
fad8e447 78%description -n libfdt-static -l pl.UTF-8
6861f1fc
ER
79Statyczna biblioteka fdt.
80
81%prep
cc076a48 82%setup -q
6861f1fc
ER
83
84%build
85%{__make} \
86 %{?with_verbose:V=1} \
87 CC="%{__cc}" \
fad8e447 88 CFLAGS="%{rpmcflags} -fPIC"
6861f1fc
ER
89
90%install
91rm -rf $RPM_BUILD_ROOT
92%{__make} install \
cff8604d 93 DESTDIR=$RPM_BUILD_ROOT \
6861f1fc
ER
94 %{?with_verbose:V=1} \
95 PREFIX=%{_prefix} \
cff8604d 96 LIBDIR=%{_libdir}
6861f1fc
ER
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
f18f0eaf 101%post -n libfdt -p /sbin/ldconfig
cff8604d 102%postun -n libfdt -p /sbin/ldconfig
fad8e447 103
6861f1fc
ER
104%files
105%defattr(644,root,root,755)
cc076a48 106%doc README README.license
fad8e447 107%attr(755,root,root) %{_bindir}/convert-dtsv0
6861f1fc 108%attr(755,root,root) %{_bindir}/dtc
fad8e447 109%attr(755,root,root) %{_bindir}/dtdiff
cc076a48
JB
110%attr(755,root,root) %{_bindir}/fdtdump
111%attr(755,root,root) %{_bindir}/fdtget
112%attr(755,root,root) %{_bindir}/fdtput
fad8e447
JR
113
114%files -n libfdt
115%defattr(644,root,root,755)
116%attr(755,root,root) %{_libdir}/libfdt-%{version}.so
117%attr(755,root,root) %ghost %{_libdir}/libfdt.so.1
6861f1fc 118
fad8e447 119%files -n libfdt-devel
6861f1fc 120%defattr(644,root,root,755)
cff8604d 121%doc TODO Documentation/manual.txt
fad8e447 122%attr(755,root,root) %{_libdir}/libfdt.so
6861f1fc
ER
123%{_includedir}/fdt.h
124%{_includedir}/libfdt.h
cc076a48 125%{_includedir}/libfdt_env.h
6861f1fc 126
fad8e447 127%files -n libfdt-static
6861f1fc
ER
128%defattr(644,root,root,755)
129%{_libdir}/libfdt.a
This page took 0.117926 seconds and 4 git commands to generate.