]> git.pld-linux.org Git - packages/dssi.git/blob - dssi.spec
- autotools BRs
[packages/dssi.git] / dssi.spec
1 Summary:        Disposable Soft Synth Interface specification
2 Summary(pl.UTF-8):      Specyfikacja Disposable Soft Synth Interface
3 Name:           dssi
4 Version:        1.0.0
5 Release:        1
6 License:        LGPL v2.1
7 Group:          Development/Libraries
8 Source0:        http://dl.sourceforge.net/dssi/%{name}-%{version}.tar.gz
9 # Source0-md5:  bc4c50f9f9b3cd13019718266f8f15af
10 Patch0:         %{name}-qt_test.patch
11 URL:            http://dssi.sourceforge.net/
12 BuildRequires:  alsa-lib-devel >= 0.9
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  jack-audio-connection-kit-devel
16 BuildRequires:  ladspa-devel >= 1.0
17 BuildRequires:  liblo-devel >= 0.12
18 BuildRequires:  libsamplerate-devel
19 BuildRequires:  libsndfile-devel
20 BuildRequires:  libsndfile-devel
21 BuildRequires:  libtool
22 BuildRequires:  pkgconfig
23 BuildRequires:  qt-devel >= 3.3
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %undefine       __cxx
27
28 %description
29 DSSI (pronounced "dizzy") is an API for audio plugins, with particular
30 application for software synthesis plugins with native user
31 interfaces. DSSI is an open specification developed for use in Linux
32 audio applications, although portable to other platforms. It may be
33 thought of as LADSPA-for-instruments, or something comparable to VSTi.
34
35 DSSI consists of a C language API for use by plugins and hosts, based
36 on the LADSPA API, and an OSC (Open Sound Control) API for use in user
37 interface to host communications. The DSSI specification consists of
38 an RFC which describes the background for the proposal and defines the
39 OSC part of the specification, and a documented header file which
40 defines the C API.
41
42 %description -l pl.UTF-8
43 DSSI (wymawiane "dizzy") to API dla wtyczek dźwiękowych z
44 zastosowaniem szczególnie dla wtyczek syntezy programowej z natywnymi
45 interfejsami użytkownika. DSSI to otwarta specyfikacja stworzona do
46 używania w linuksowych aplikacjach dźwiękowych, ale przenośna na inne
47 platformy. Można ją określić jako LADSPA dla instrumentów lub coś
48 porównywalnego do VSTi.
49
50 DSSI składa się z API języka C do użytku przez wtyczki i hosty, oparte
51 o API LADSPA oraz API OSC (Open Sound Control) do użytku w
52 interfejsach użytkownika do komunikacji z hostem. Specyfikacja DSSI
53 składa się z RFC opisującego tło propozycji i definiującego część OSC
54 specyfikacji oraz udokumentowanego pliku nagłówkowego definiującego
55 API C.
56
57 %package devel
58 Summary:        DSSI development files
59 Summary(pl.UTF-8):      Pliki nagłówkowe DSSI
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       alsa-lib-devel >= 0.9
63 Requires:       ladspa-devel >= 1.0
64 Obsoletes:      dssi < 1.0.0
65
66 %description devel
67 DSSI development files.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe DSSI.
71
72 %package host-jack
73 Summary:        A simple JACK/ALSA-sequencer plugin host
74 Summary(pl.UTF-8):      Prosty host wtyczek sekwencera JACK/ALSA
75 Group:          Applications/Sound
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       liblo >= 0.12
78
79 %description host-jack
80 A simple JACK/ALSA-sequencer plugin host.
81
82 %description host-jack -l pl.UTF-8
83 Prosty host wtyczek sekwencera JACK/ALSA.
84
85 %package examples
86 Summary:        Example DSSI plugins
87 Summary(pl.UTF-8):      Przykładowe wtyczki DSSI
88 Group:          Applications/Sound
89 Requires:       %{name} = %{version}-%{release}
90
91 %description examples
92 Example DSSI plugins.
93
94 %description examples -l pl.UTF-8
95 Przykładowe wtyczki DSSI
96
97 %prep
98 %setup -q
99 %patch0 -p1
100
101 %build
102 %{__libtoolize}
103 %{__aclocal}
104 %{__autoconf}
105 %{__autoheader}
106 %{__automake}
107
108 CFLAGS="$CFLAGS -I%{_includedir}/qt"
109 CPPFLAGS="$CPPFLAGS -I%{_includedir}/qt"
110 export QTDIR=%{_prefix}
111 %configure
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 rm -f $RPM_BUILD_ROOT%{_libdir}/dssi/*.la
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(644,root,root,755)
127 %doc ChangeLog README doc/TODO doc/*.txt
128 %attr(755,root,root) %{_bindir}/dssi_osc_send
129 %attr(755,root,root) %{_bindir}/dssi_osc_update
130 %dir %{_libdir}/dssi
131 %{_mandir}/man1/dssi*
132
133 %files devel
134 %defattr(644,root,root,755)
135 %{_includedir}/dssi.h
136 %{_pkgconfigdir}/dssi.pc
137
138 %files host-jack
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_bindir}/jack-dssi-host
141 %{_mandir}/man1/jack-dssi-host.*
142
143 %files examples
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_bindir}/karplong
146 %attr(755,root,root) %{_bindir}/less_trivial_synth
147 %attr(755,root,root) %{_bindir}/trivial_sampler
148 %attr(755,root,root) %{_bindir}/trivial_synth
149 %attr(755,root,root) %{_libdir}/dssi/*.so
150 %dir %{_libdir}/dssi/less_trivial_synth
151 %attr(755,root,root) %{_libdir}/dssi/less_trivial_synth/*_qt
152 %dir %{_libdir}/dssi/trivial_sampler
153 %attr(755,root,root) %{_libdir}/dssi/trivial_sampler/*_qt
This page took 0.059382 seconds and 4 git commands to generate.