]> git.pld-linux.org Git - packages/dssi.git/blob - dssi.spec
- release 3
[packages/dssi.git] / dssi.spec
1 Summary:        Disposable Soft Synth Interface specification
2 Summary(pl.UTF-8):      Specyfikacja Disposable Soft Synth Interface
3 Name:           dssi
4 Version:        1.0.0
5 Release:        3
6 License:        LGPL v2.1
7 Group:          Development/Libraries
8 Source0:        http://dl.sourceforge.net/dssi/%{name}-%{version}.tar.gz
9 # Source0-md5:  bc4c50f9f9b3cd13019718266f8f15af
10 Patch0:         %{name}-qt_test.patch
11 Patch1:         %{name}-lib64.patch
12 URL:            http://dssi.sourceforge.net/
13 BuildRequires:  alsa-lib-devel >= 0.9
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  jack-audio-connection-kit-devel
17 BuildRequires:  ladspa-devel >= 1.0
18 BuildRequires:  liblo-devel >= 0.12
19 BuildRequires:  libsamplerate-devel
20 BuildRequires:  libsndfile-devel
21 BuildRequires:  libsndfile-devel
22 BuildRequires:  libtool
23 BuildRequires:  pkgconfig
24 BuildRequires:  qt-devel >= 3.3
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 DSSI (pronounced "dizzy") is an API for audio plugins, with particular
29 application for software synthesis plugins with native user
30 interfaces. DSSI is an open specification developed for use in Linux
31 audio applications, although portable to other platforms. It may be
32 thought of as LADSPA-for-instruments, or something comparable to VSTi.
33
34 DSSI consists of a C language API for use by plugins and hosts, based
35 on the LADSPA API, and an OSC (Open Sound Control) API for use in user
36 interface to host communications. The DSSI specification consists of
37 an RFC which describes the background for the proposal and defines the
38 OSC part of the specification, and a documented header file which
39 defines the C API.
40
41 %description -l pl.UTF-8
42 DSSI (wymawiane "dizzy") to API dla wtyczek dźwiękowych z
43 zastosowaniem szczególnie dla wtyczek syntezy programowej z natywnymi
44 interfejsami użytkownika. DSSI to otwarta specyfikacja stworzona do
45 używania w linuksowych aplikacjach dźwiękowych, ale przenośna na inne
46 platformy. Można ją określić jako LADSPA dla instrumentów lub coś
47 porównywalnego do VSTi.
48
49 DSSI składa się z API języka C do użytku przez wtyczki i hosty, oparte
50 o API LADSPA oraz API OSC (Open Sound Control) do użytku w
51 interfejsach użytkownika do komunikacji z hostem. Specyfikacja DSSI
52 składa się z RFC opisującego tło propozycji i definiującego część OSC
53 specyfikacji oraz udokumentowanego pliku nagłówkowego definiującego
54 API C.
55
56 %package devel
57 Summary:        DSSI development files
58 Summary(pl.UTF-8):      Pliki nagłówkowe DSSI
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       alsa-lib-devel >= 0.9
62 Requires:       ladspa-devel >= 1.0
63 Obsoletes:      dssi < 1.0.0
64
65 %description devel
66 DSSI development files.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe DSSI.
70
71 %package host-jack
72 Summary:        A simple JACK/ALSA-sequencer plugin host
73 Summary(pl.UTF-8):      Prosty host wtyczek sekwencera JACK/ALSA
74 Group:          Applications/Sound
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       liblo >= 0.12
77
78 %description host-jack
79 A simple JACK/ALSA-sequencer plugin host.
80
81 %description host-jack -l pl.UTF-8
82 Prosty host wtyczek sekwencera JACK/ALSA.
83
84 %package examples
85 Summary:        Example DSSI plugins
86 Summary(pl.UTF-8):      Przykładowe wtyczki DSSI
87 Group:          Applications/Sound
88 Requires:       %{name} = %{version}-%{release}
89
90 %description examples
91 Example DSSI plugins.
92
93 %description examples -l pl.UTF-8
94 Przykładowe wtyczki DSSI
95
96 %prep
97 %setup -q
98 %patch0 -p1
99 %if "%{_lib}" == "lib64"
100 %patch1 -p1
101 %endif
102
103 %build
104 %{__libtoolize}
105 %{__aclocal}
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109
110 CFLAGS="$CFLAGS -I%{_includedir}/qt"
111 CPPFLAGS="$CPPFLAGS -I%{_includedir}/qt"
112 export QTDIR=%{_prefix}
113 %configure
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 rm -f $RPM_BUILD_ROOT%{_libdir}/dssi/*.la
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files
128 %defattr(644,root,root,755)
129 %doc ChangeLog README doc/TODO doc/*.txt
130 %attr(755,root,root) %{_bindir}/dssi_osc_send
131 %attr(755,root,root) %{_bindir}/dssi_osc_update
132 %dir %{_libdir}/dssi
133 %{_mandir}/man1/dssi*
134
135 %files devel
136 %defattr(644,root,root,755)
137 %{_includedir}/dssi.h
138 %{_pkgconfigdir}/dssi.pc
139
140 %files host-jack
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_bindir}/jack-dssi-host
143 %{_mandir}/man1/jack-dssi-host.*
144
145 %files examples
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_bindir}/karplong
148 %attr(755,root,root) %{_bindir}/less_trivial_synth
149 %attr(755,root,root) %{_bindir}/trivial_sampler
150 %attr(755,root,root) %{_bindir}/trivial_synth
151 %attr(755,root,root) %{_libdir}/dssi/*.so
152 %dir %{_libdir}/dssi/less_trivial_synth
153 %attr(755,root,root) %{_libdir}/dssi/less_trivial_synth/*_qt
154 %dir %{_libdir}/dssi/trivial_sampler
155 %attr(755,root,root) %{_libdir}/dssi/trivial_sampler/*_qt
This page took 0.193739 seconds and 4 git commands to generate.