]> git.pld-linux.org Git - packages/dssi.git/blob - dssi.spec
- broken configure test for qt library removed
[packages/dssi.git] / dssi.spec
1 Summary:        Disposable Soft Synth Interface specification
2 Summary(pl.UTF-8):      Specyfikacja Disposable Soft Synth Interface
3 Name:           dssi
4 Version:        1.0.0
5 Release:        1
6 License:        LGPL v2.1
7 Group:          Development/Libraries
8 Source0:        http://dl.sourceforge.net/dssi/%{name}-%{version}.tar.gz
9 # Source0-md5:  bc4c50f9f9b3cd13019718266f8f15af
10 Patch0:         %{name}-qt_test.patch
11 URL:            http://dssi.sourceforge.net/
12 BuildRequires:  qt-devel >= 3.3
13 BuildRequires:  alsa-lib-devel >= 0.9
14 BuildRequires:  jack-audio-connection-kit-devel
15 BuildRequires:  ladspa-devel >= 1.0
16 BuildRequires:  liblo-devel >= 0.12
17 BuildRequires:  libsamplerate-devel
18 BuildRequires:  libsndfile-devel
19 BuildRequires:  libsndfile-devel
20 BuildRequires:  pkgconfig
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %undefine       __cxx
24
25 %description
26 DSSI (pronounced "dizzy") is an API for audio plugins, with particular
27 application for software synthesis plugins with native user
28 interfaces. DSSI is an open specification developed for use in Linux
29 audio applications, although portable to other platforms. It may be
30 thought of as LADSPA-for-instruments, or something comparable to VSTi.
31
32 DSSI consists of a C language API for use by plugins and hosts, based
33 on the LADSPA API, and an OSC (Open Sound Control) API for use in user
34 interface to host communications. The DSSI specification consists of
35 an RFC which describes the background for the proposal and defines the
36 OSC part of the specification, and a documented header file which
37 defines the C API.
38
39 %description -l pl.UTF-8
40 DSSI (wymawiane "dizzy") to API dla wtyczek dźwiękowych z
41 zastosowaniem szczególnie dla wtyczek syntezy programowej z natywnymi
42 interfejsami użytkownika. DSSI to otwarta specyfikacja stworzona do
43 używania w linuksowych aplikacjach dźwiękowych, ale przenośna na inne
44 platformy. Można ją określić jako LADSPA dla instrumentów lub coś
45 porównywalnego do VSTi.
46
47 DSSI składa się z API języka C do użytku przez wtyczki i hosty, oparte
48 o API LADSPA oraz API OSC (Open Sound Control) do użytku w
49 interfejsach użytkownika do komunikacji z hostem. Specyfikacja DSSI
50 składa się z RFC opisującego tło propozycji i definiującego część OSC
51 specyfikacji oraz udokumentowanego pliku nagłówkowego definiującego
52 API C.
53
54 %package devel
55 Summary:        DSSI development files
56 Summary(pl.UTF-8):      Pliki nagłówkowe DSSI
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       alsa-lib-devel >= 0.9
60 Requires:       ladspa-devel >= 1.0
61 Obsoletes:      dssi < 1.0.0
62
63 %description devel
64 DSSI development files.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe DSSI.
68
69 %package host-jack
70 Summary:        A simple JACK/ALSA-sequencer plugin host
71 Summary(pl.UTF-8):      Prosty host wtyczek sekwencera JACK/ALSA
72 Group:          Applications/Sound
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       liblo >= 0.12
75
76 %description host-jack
77 A simple JACK/ALSA-sequencer plugin host.
78
79 %description host-jack -l pl.UTF-8
80 Prosty host wtyczek sekwencera JACK/ALSA.
81
82 %package examples
83 Summary:        Example DSSI plugins
84 Summary(pl.UTF-8):      Przykładowe wtyczki DSSI
85 Group:          Applications/Sound
86 Requires:       %{name} = %{version}-%{release}
87
88 %description examples
89 Example DSSI plugins.
90
91 %description examples -l pl.UTF-8
92 Przykładowe wtyczki DSSI
93
94 %prep
95 %setup -q
96 %patch0 -p1
97
98 %build
99 %{__libtoolize}
100 %{__aclocal}
101 %{__autoconf}
102 %{__autoheader}
103 %{__automake}
104
105 CFLAGS="$CFLAGS -I%{_includedir}/qt"
106 CPPFLAGS="$CPPFLAGS -I%{_includedir}/qt"
107 export QTDIR=%{_prefix}
108 %configure
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 rm -f $RPM_BUILD_ROOT%{_libdir}/dssi/*.la
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 %defattr(644,root,root,755)
124 %doc ChangeLog README doc/TODO doc/*.txt
125 %attr(755,root,root) %{_bindir}/dssi_osc_send
126 %attr(755,root,root) %{_bindir}/dssi_osc_update
127 %dir %{_libdir}/dssi
128 %{_mandir}/man1/dssi*
129
130 %files devel
131 %defattr(644,root,root,755)
132 %{_includedir}/dssi.h
133 %{_pkgconfigdir}/dssi.pc
134
135 %files host-jack
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_bindir}/jack-dssi-host
138 %{_mandir}/man1/jack-dssi-host.*
139
140 %files examples
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_bindir}/karplong
143 %attr(755,root,root) %{_bindir}/less_trivial_synth
144 %attr(755,root,root) %{_bindir}/trivial_sampler
145 %attr(755,root,root) %{_bindir}/trivial_synth
146 %attr(755,root,root) %{_libdir}/dssi/*.so
147 %dir %{_libdir}/dssi/less_trivial_synth
148 %attr(755,root,root) %{_libdir}/dssi/less_trivial_synth/*_qt
149 %dir %{_libdir}/dssi/trivial_sampler
150 %attr(755,root,root) %{_libdir}/dssi/trivial_sampler/*_qt
This page took 0.069649 seconds and 4 git commands to generate.