]> git.pld-linux.org Git - packages/dssi.git/blob - dssi.spec
- updated to 1.1.0
[packages/dssi.git] / dssi.spec
1 Summary:        Disposable Soft Synth Interface specification
2 Summary(pl.UTF-8):      Specyfikacja Disposable Soft Synth Interface
3 Name:           dssi
4 Version:        1.1.0
5 Release:        1
6 License:        LGPL v2.1
7 Group:          Development/Libraries
8 Source0:        http://downloads.sourceforge.net/dssi/%{name}-%{version}.tar.gz
9 # Source0-md5:  dfc850e66fae94e7ec08aebb43d07848
10 Patch0:         %{name}-lib64.patch
11 URL:            http://dssi.sourceforge.net/
12 BuildRequires:  QtGui-devel >= 4.0.1
13 BuildRequires:  alsa-lib-devel >= 0.9
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  jack-audio-connection-kit-devel
17 BuildRequires:  ladspa-devel >= 1.0
18 BuildRequires:  liblo-devel >= 0.12
19 BuildRequires:  libsamplerate-devel
20 BuildRequires:  libsndfile-devel
21 BuildRequires:  libtool
22 BuildRequires:  pkgconfig
23 BuildRequires:  qt4-build >= 4.0.1
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 DSSI (pronounced "dizzy") is an API for audio plugins, with particular
28 application for software synthesis plugins with native user
29 interfaces. DSSI is an open specification developed for use in Linux
30 audio applications, although portable to other platforms. It may be
31 thought of as LADSPA-for-instruments, or something comparable to VSTi.
32
33 DSSI consists of a C language API for use by plugins and hosts, based
34 on the LADSPA API, and an OSC (Open Sound Control) API for use in user
35 interface to host communications. The DSSI specification consists of
36 an RFC which describes the background for the proposal and defines the
37 OSC part of the specification, and a documented header file which
38 defines the C API.
39
40 %description -l pl.UTF-8
41 DSSI (wymawiane "dizzy") to API dla wtyczek dźwiękowych z
42 zastosowaniem szczególnie dla wtyczek syntezy programowej z natywnymi
43 interfejsami użytkownika. DSSI to otwarta specyfikacja stworzona do
44 używania w linuksowych aplikacjach dźwiękowych, ale przenośna na inne
45 platformy. Można ją określić jako LADSPA dla instrumentów lub coś
46 porównywalnego do VSTi.
47
48 DSSI składa się z API języka C do użytku przez wtyczki i hosty, oparte
49 o API LADSPA oraz API OSC (Open Sound Control) do użytku w
50 interfejsach użytkownika do komunikacji z hostem. Specyfikacja DSSI
51 składa się z RFC opisującego tło propozycji i definiującego część OSC
52 specyfikacji oraz udokumentowanego pliku nagłówkowego definiującego
53 API C.
54
55 %package devel
56 Summary:        DSSI development files
57 Summary(pl.UTF-8):      Pliki nagłówkowe DSSI
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       alsa-lib-devel >= 0.9
61 Requires:       ladspa-devel >= 1.0
62 Obsoletes:      dssi < 1.0.0
63
64 %description devel
65 DSSI development files.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe DSSI.
69
70 %package host-jack
71 Summary:        A simple JACK/ALSA-sequencer plugin host
72 Summary(pl.UTF-8):      Prosty host wtyczek sekwencera JACK/ALSA
73 Group:          Applications/Sound
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       liblo >= 0.12
76
77 %description host-jack
78 A simple JACK/ALSA-sequencer plugin host.
79
80 %description host-jack -l pl.UTF-8
81 Prosty host wtyczek sekwencera JACK/ALSA.
82
83 %package examples
84 Summary:        Example DSSI plugins
85 Summary(pl.UTF-8):      Przykładowe wtyczki DSSI
86 Group:          Applications/Sound
87 Requires:       %{name} = %{version}-%{release}
88
89 %description examples
90 Example DSSI plugins.
91
92 %description examples -l pl.UTF-8
93 Przykładowe wtyczki DSSI
94
95 %prep
96 %setup -q
97 %if "%{_lib}" == "lib64"
98 %patch0 -p1
99 %endif
100
101 %build
102 %{__libtoolize}
103 %{__aclocal}
104 %{__autoconf}
105 %{__autoheader}
106 %{__automake}
107
108 %configure
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 %{__rm} $RPM_BUILD_ROOT%{_libdir}/dssi/*.la
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 %defattr(644,root,root,755)
124 %doc ChangeLog README doc/TODO doc/*.txt
125 %attr(755,root,root) %{_bindir}/dssi_analyse_plugin
126 %attr(755,root,root) %{_bindir}/dssi_list_plugins
127 %attr(755,root,root) %{_bindir}/dssi_osc_send
128 %attr(755,root,root) %{_bindir}/dssi_osc_update
129 %dir %{_libdir}/dssi
130 %{_mandir}/man1/dssi*.1*
131
132 %files devel
133 %defattr(644,root,root,755)
134 %{_includedir}/dssi.h
135 %{_pkgconfigdir}/dssi.pc
136
137 %files host-jack
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_bindir}/jack-dssi-host
140 %{_mandir}/man1/jack-dssi-host.1*
141
142 %files examples
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/karplong
145 %attr(755,root,root) %{_bindir}/less_trivial_synth
146 %attr(755,root,root) %{_bindir}/trivial_sampler
147 %attr(755,root,root) %{_bindir}/trivial_synth
148 %attr(755,root,root) %{_libdir}/dssi/*.so
149 %dir %{_libdir}/dssi/less_trivial_synth
150 %attr(755,root,root) %{_libdir}/dssi/less_trivial_synth/*_qt
151 %dir %{_libdir}/dssi/trivial_sampler
152 %attr(755,root,root) %{_libdir}/dssi/trivial_sampler/*_qt
This page took 0.065066 seconds and 4 git commands to generate.