]> git.pld-linux.org Git - packages/dssi.git/blob - dssi.spec
- updated to 1.1.1
[packages/dssi.git] / dssi.spec
1 Summary:        Disposable Soft Synth Interface specification
2 Summary(pl.UTF-8):      Specyfikacja Disposable Soft Synth Interface
3 Name:           dssi
4 Version:        1.1.1
5 Release:        1
6 License:        LGPL v2.1
7 Group:          Development/Libraries
8 Source0:        http://downloads.sourceforge.net/dssi/%{name}-%{version}.tar.gz
9 # Source0-md5:  619ab73c883b02dc37ddb37001591f8b
10 Patch0:         %{name}-lib64.patch
11 URL:            http://dssi.sourceforge.net/
12 BuildRequires:  QtCore-devel >= 4.0.1
13 BuildRequires:  QtGui-devel >= 4.0.1
14 BuildRequires:  alsa-lib-devel >= 0.9
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  jack-audio-connection-kit-devel >= 0.99.14
18 BuildRequires:  ladspa-devel >= 1.0
19 BuildRequires:  liblo-devel >= 0.12
20 BuildRequires:  libsamplerate-devel
21 BuildRequires:  libsndfile-devel
22 BuildRequires:  libtool
23 BuildRequires:  pkgconfig
24 BuildRequires:  qt4-build >= 4.0.1
25 BuildRequires:  xorg-lib-libX11-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 DSSI (pronounced "dizzy") is an API for audio plugins, with particular
30 application for software synthesis plugins with native user
31 interfaces. DSSI is an open specification developed for use in Linux
32 audio applications, although portable to other platforms. It may be
33 thought of as LADSPA-for-instruments, or something comparable to VSTi.
34
35 DSSI consists of a C language API for use by plugins and hosts, based
36 on the LADSPA API, and an OSC (Open Sound Control) API for use in user
37 interface to host communications. The DSSI specification consists of
38 an RFC which describes the background for the proposal and defines the
39 OSC part of the specification, and a documented header file which
40 defines the C API.
41
42 %description -l pl.UTF-8
43 DSSI (wymawiane "dizzy") to API dla wtyczek dźwiękowych z
44 zastosowaniem szczególnie dla wtyczek syntezy programowej z natywnymi
45 interfejsami użytkownika. DSSI to otwarta specyfikacja stworzona do
46 używania w linuksowych aplikacjach dźwiękowych, ale przenośna na inne
47 platformy. Można ją określić jako LADSPA dla instrumentów lub coś
48 porównywalnego do VSTi.
49
50 DSSI składa się z API języka C do użytku przez wtyczki i hosty, oparte
51 o API LADSPA oraz API OSC (Open Sound Control) do użytku w
52 interfejsach użytkownika do komunikacji z hostem. Specyfikacja DSSI
53 składa się z RFC opisującego tło propozycji i definiującego część OSC
54 specyfikacji oraz udokumentowanego pliku nagłówkowego definiującego
55 API C.
56
57 %package devel
58 Summary:        DSSI development files
59 Summary(pl.UTF-8):      Pliki nagłówkowe DSSI
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       alsa-lib-devel >= 0.9
63 Requires:       ladspa-devel >= 1.0
64 Obsoletes:      dssi < 1.0.0
65
66 %description devel
67 DSSI development files.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe DSSI.
71
72 %package host-jack
73 Summary:        A simple JACK/ALSA-sequencer plugin host
74 Summary(pl.UTF-8):      Prosty host wtyczek sekwencera JACK/ALSA
75 Group:          Applications/Sound
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       liblo >= 0.12
78
79 %description host-jack
80 A simple JACK/ALSA-sequencer plugin host.
81
82 %description host-jack -l pl.UTF-8
83 Prosty host wtyczek sekwencera JACK/ALSA.
84
85 %package examples
86 Summary:        Example DSSI plugins
87 Summary(pl.UTF-8):      Przykładowe wtyczki DSSI
88 Group:          Applications/Sound
89 Requires:       %{name} = %{version}-%{release}
90
91 %description examples
92 Example DSSI plugins.
93
94 %description examples -l pl.UTF-8
95 Przykładowe wtyczki DSSI
96
97 %prep
98 %setup -q
99 %if "%{_lib}" == "lib64"
100 %patch0 -p1
101 %endif
102
103 %build
104 %{__libtoolize}
105 %{__aclocal}
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109
110 %configure
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 %{__rm} $RPM_BUILD_ROOT%{_libdir}/dssi/*.la
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files
125 %defattr(644,root,root,755)
126 %doc ChangeLog README doc/TODO doc/*.txt
127 %attr(755,root,root) %{_bindir}/dssi_analyse_plugin
128 %attr(755,root,root) %{_bindir}/dssi_list_plugins
129 %attr(755,root,root) %{_bindir}/dssi_osc_send
130 %attr(755,root,root) %{_bindir}/dssi_osc_update
131 %dir %{_libdir}/dssi
132 %{_mandir}/man1/dssi*.1*
133
134 %files devel
135 %defattr(644,root,root,755)
136 %{_includedir}/dssi.h
137 %{_pkgconfigdir}/dssi.pc
138
139 %files host-jack
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_bindir}/jack-dssi-host
142 %{_mandir}/man1/jack-dssi-host.1*
143
144 %files examples
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_bindir}/karplong
147 %attr(755,root,root) %{_bindir}/less_trivial_synth
148 %attr(755,root,root) %{_bindir}/trivial_sampler
149 %attr(755,root,root) %{_bindir}/trivial_synth
150 %attr(755,root,root) %{_libdir}/dssi/*.so
151 %dir %{_libdir}/dssi/less_trivial_synth
152 %attr(755,root,root) %{_libdir}/dssi/less_trivial_synth/*_qt
153 %dir %{_libdir}/dssi/trivial_sampler
154 %attr(755,root,root) %{_libdir}/dssi/trivial_sampler/*_qt
This page took 0.089372 seconds and 4 git commands to generate.