]> git.pld-linux.org Git - packages/dssi.git/blob - dssi.spec
- qt-devel dependency fixed
[packages/dssi.git] / dssi.spec
1 Summary:        Disposable Soft Synth Interface specification
2 Summary(pl.UTF-8):      Specyfikacja Disposable Soft Synth Interface
3 Name:           dssi
4 Version:        1.0.0
5 Release:        1
6 License:        LGPL v2.1
7 Group:          Development/Libraries
8 Source0:        http://dl.sourceforge.net/dssi/%{name}-%{version}.tar.gz
9 # Source0-md5:  bc4c50f9f9b3cd13019718266f8f15af
10 URL:            http://dssi.sourceforge.net/
11 BuildRequires:  qt-devel >= 3.3
12 BuildRequires:  alsa-lib-devel >= 0.9
13 BuildRequires:  jack-audio-connection-kit-devel
14 BuildRequires:  ladspa-devel >= 1.0
15 BuildRequires:  liblo-devel >= 0.12
16 BuildRequires:  libsamplerate-devel
17 BuildRequires:  libsndfile-devel
18 BuildRequires:  libsndfile-devel
19 BuildRequires:  pkgconfig
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %undefine       __cxx
23
24 %description
25 DSSI (pronounced "dizzy") is an API for audio plugins, with particular
26 application for software synthesis plugins with native user
27 interfaces. DSSI is an open specification developed for use in Linux
28 audio applications, although portable to other platforms. It may be
29 thought of as LADSPA-for-instruments, or something comparable to VSTi.
30
31 DSSI consists of a C language API for use by plugins and hosts, based
32 on the LADSPA API, and an OSC (Open Sound Control) API for use in user
33 interface to host communications. The DSSI specification consists of
34 an RFC which describes the background for the proposal and defines the
35 OSC part of the specification, and a documented header file which
36 defines the C API.
37
38 %description -l pl.UTF-8
39 DSSI (wymawiane "dizzy") to API dla wtyczek dźwiękowych z
40 zastosowaniem szczególnie dla wtyczek syntezy programowej z natywnymi
41 interfejsami użytkownika. DSSI to otwarta specyfikacja stworzona do
42 używania w linuksowych aplikacjach dźwiękowych, ale przenośna na inne
43 platformy. Można ją określić jako LADSPA dla instrumentów lub coś
44 porównywalnego do VSTi.
45
46 DSSI składa się z API języka C do użytku przez wtyczki i hosty, oparte
47 o API LADSPA oraz API OSC (Open Sound Control) do użytku w
48 interfejsach użytkownika do komunikacji z hostem. Specyfikacja DSSI
49 składa się z RFC opisującego tło propozycji i definiującego część OSC
50 specyfikacji oraz udokumentowanego pliku nagłówkowego definiującego
51 API C.
52
53 %package devel
54 Summary:        DSSI development files
55 Summary(pl.UTF-8):      Pliki nagłówkowe DSSI
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       alsa-lib-devel >= 0.9
59 Requires:       ladspa-devel >= 1.0
60 Obsoletes:      dssi < 1.0.0
61
62 %description devel
63 DSSI development files.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe DSSI.
67
68 %package host-jack
69 Summary:        A simple JACK/ALSA-sequencer plugin host
70 Summary(pl.UTF-8):      Prosty host wtyczek sekwencera JACK/ALSA
71 Group:          Applications/Sound
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       liblo >= 0.12
74
75 %description host-jack
76 A simple JACK/ALSA-sequencer plugin host.
77
78 %description host-jack -l pl.UTF-8
79 Prosty host wtyczek sekwencera JACK/ALSA.
80
81 %package examples
82 Summary:        Example DSSI plugins
83 Summary(pl.UTF-8):      Przykładowe wtyczki DSSI
84 Group:          Applications/Sound
85 Requires:       %{name} = %{version}-%{release}
86
87 %description examples
88 Example DSSI plugins.
89
90 %description examples -l pl.UTF-8
91 Przykładowe wtyczki DSSI
92
93 %prep
94 %setup -q
95
96 %build
97 CFLAGS="$CFLAGS -I%{_includedir}/qt"
98 CPPFLAGS="$CPPFLAGS -I%{_includedir}/qt"
99 export QTDIR=%{_prefix}
100 %configure
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 rm -f $RPM_BUILD_ROOT%{_libdir}/dssi/*.la
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files
115 %defattr(644,root,root,755)
116 %doc ChangeLog README doc/TODO doc/*.txt
117 %attr(755,root,root) %{_bindir}/dssi_osc_send
118 %attr(755,root,root) %{_bindir}/dssi_osc_update
119 %dir %{_libdir}/dssi
120 %{_mandir}/man1/dssi*
121
122 %files devel
123 %defattr(644,root,root,755)
124 %{_includedir}/dssi.h
125 %{_pkgconfigdir}/dssi.pc
126
127 %files host-jack
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_bindir}/jack-dssi-host
130 %{_mandir}/man1/jack-dssi-host.*
131
132 %files examples
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_bindir}/karplong
135 %attr(755,root,root) %{_bindir}/less_trivial_synth
136 %attr(755,root,root) %{_bindir}/trivial_sampler
137 %attr(755,root,root) %{_bindir}/trivial_synth
138 %attr(755,root,root) %{_libdir}/dssi/*.so
139 %dir %{_libdir}/dssi/less_trivial_synth
140 %attr(755,root,root) %{_libdir}/dssi/less_trivial_synth/*_qt
141 %dir %{_libdir}/dssi/trivial_sampler
142 %attr(755,root,root) %{_libdir}/dssi/trivial_sampler/*_qt
This page took 0.044298 seconds and 4 git commands to generate.