]> git.pld-linux.org Git - packages/dssi.git/blob - dssi.spec
- leave __cxx defined, c++ is used now
[packages/dssi.git] / dssi.spec
1 Summary:        Disposable Soft Synth Interface specification
2 Summary(pl.UTF-8):      Specyfikacja Disposable Soft Synth Interface
3 Name:           dssi
4 Version:        1.0.0
5 Release:        1
6 License:        LGPL v2.1
7 Group:          Development/Libraries
8 Source0:        http://dl.sourceforge.net/dssi/%{name}-%{version}.tar.gz
9 # Source0-md5:  bc4c50f9f9b3cd13019718266f8f15af
10 Patch0:         %{name}-qt_test.patch
11 URL:            http://dssi.sourceforge.net/
12 BuildRequires:  alsa-lib-devel >= 0.9
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  jack-audio-connection-kit-devel
16 BuildRequires:  ladspa-devel >= 1.0
17 BuildRequires:  liblo-devel >= 0.12
18 BuildRequires:  libsamplerate-devel
19 BuildRequires:  libsndfile-devel
20 BuildRequires:  libsndfile-devel
21 BuildRequires:  libtool
22 BuildRequires:  pkgconfig
23 BuildRequires:  qt-devel >= 3.3
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 DSSI (pronounced "dizzy") is an API for audio plugins, with particular
28 application for software synthesis plugins with native user
29 interfaces. DSSI is an open specification developed for use in Linux
30 audio applications, although portable to other platforms. It may be
31 thought of as LADSPA-for-instruments, or something comparable to VSTi.
32
33 DSSI consists of a C language API for use by plugins and hosts, based
34 on the LADSPA API, and an OSC (Open Sound Control) API for use in user
35 interface to host communications. The DSSI specification consists of
36 an RFC which describes the background for the proposal and defines the
37 OSC part of the specification, and a documented header file which
38 defines the C API.
39
40 %description -l pl.UTF-8
41 DSSI (wymawiane "dizzy") to API dla wtyczek dźwiękowych z
42 zastosowaniem szczególnie dla wtyczek syntezy programowej z natywnymi
43 interfejsami użytkownika. DSSI to otwarta specyfikacja stworzona do
44 używania w linuksowych aplikacjach dźwiękowych, ale przenośna na inne
45 platformy. Można ją określić jako LADSPA dla instrumentów lub coś
46 porównywalnego do VSTi.
47
48 DSSI składa się z API języka C do użytku przez wtyczki i hosty, oparte
49 o API LADSPA oraz API OSC (Open Sound Control) do użytku w
50 interfejsach użytkownika do komunikacji z hostem. Specyfikacja DSSI
51 składa się z RFC opisującego tło propozycji i definiującego część OSC
52 specyfikacji oraz udokumentowanego pliku nagłówkowego definiującego
53 API C.
54
55 %package devel
56 Summary:        DSSI development files
57 Summary(pl.UTF-8):      Pliki nagłówkowe DSSI
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       alsa-lib-devel >= 0.9
61 Requires:       ladspa-devel >= 1.0
62 Obsoletes:      dssi < 1.0.0
63
64 %description devel
65 DSSI development files.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe DSSI.
69
70 %package host-jack
71 Summary:        A simple JACK/ALSA-sequencer plugin host
72 Summary(pl.UTF-8):      Prosty host wtyczek sekwencera JACK/ALSA
73 Group:          Applications/Sound
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       liblo >= 0.12
76
77 %description host-jack
78 A simple JACK/ALSA-sequencer plugin host.
79
80 %description host-jack -l pl.UTF-8
81 Prosty host wtyczek sekwencera JACK/ALSA.
82
83 %package examples
84 Summary:        Example DSSI plugins
85 Summary(pl.UTF-8):      Przykładowe wtyczki DSSI
86 Group:          Applications/Sound
87 Requires:       %{name} = %{version}-%{release}
88
89 %description examples
90 Example DSSI plugins.
91
92 %description examples -l pl.UTF-8
93 Przykładowe wtyczki DSSI
94
95 %prep
96 %setup -q
97 %patch0 -p1
98
99 %build
100 %{__libtoolize}
101 %{__aclocal}
102 %{__autoconf}
103 %{__autoheader}
104 %{__automake}
105
106 CFLAGS="$CFLAGS -I%{_includedir}/qt"
107 CPPFLAGS="$CPPFLAGS -I%{_includedir}/qt"
108 export QTDIR=%{_prefix}
109 %configure
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 rm -f $RPM_BUILD_ROOT%{_libdir}/dssi/*.la
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files
124 %defattr(644,root,root,755)
125 %doc ChangeLog README doc/TODO doc/*.txt
126 %attr(755,root,root) %{_bindir}/dssi_osc_send
127 %attr(755,root,root) %{_bindir}/dssi_osc_update
128 %dir %{_libdir}/dssi
129 %{_mandir}/man1/dssi*
130
131 %files devel
132 %defattr(644,root,root,755)
133 %{_includedir}/dssi.h
134 %{_pkgconfigdir}/dssi.pc
135
136 %files host-jack
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_bindir}/jack-dssi-host
139 %{_mandir}/man1/jack-dssi-host.*
140
141 %files examples
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_bindir}/karplong
144 %attr(755,root,root) %{_bindir}/less_trivial_synth
145 %attr(755,root,root) %{_bindir}/trivial_sampler
146 %attr(755,root,root) %{_bindir}/trivial_synth
147 %attr(755,root,root) %{_libdir}/dssi/*.so
148 %dir %{_libdir}/dssi/less_trivial_synth
149 %attr(755,root,root) %{_libdir}/dssi/less_trivial_synth/*_qt
150 %dir %{_libdir}/dssi/trivial_sampler
151 %attr(755,root,root) %{_libdir}/dssi/trivial_sampler/*_qt
This page took 0.080462 seconds and 4 git commands to generate.