]> git.pld-linux.org Git - packages/dss.git/blame - dss.spec
- use our buildflags, fix usinged var comparision error
[packages/dss.git] / dss.spec
CommitLineData
2d53a2fb
ER
1Summary: Darwin Streaming Server
2Name: dss
3Version: 6.0.3
4Release: 0.1
5License: Apple Public Source License
6Group: Applications
7Source0: http://dss.macosforge.org/downloads/DarwinStreamingSrvr%{version}-Source.tar
8# Source0-md5: ca676691db8417d05121699c0ca3d549
720b962c
ER
9Patch0: %{name}.patch
10Patch1: %{name}-x86_64.patch
c08547c4
ER
11Patch2: optflags.patch
12Patch3: compile.patch
2d53a2fb
ER
13URL: http://dss.macosforge.org/
14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16%description
17Darwin Streaming Server lets you stream digital video on the Internet
18using industry-standard Internet protocols RTP and RTSP.
19
20Using Darwin Streaming Server you can serve stored files (video on
21demand) or reflect live broadcasts to thousands of QuickTime 4 or
22later users. With its combination of industry-standard streaming
23protocols and cutting-edge compression technologies, QuickTime
24delivers perfectly synchronized audio and video streams ideal for
25Internet video and live events.
26
27%package Proxy
28Summary: Apple's Darwin Streaming Proxy
29Group: Daemons
30
31%description Proxy
32The Darwin Streaming Proxy is an application specific proxy which
33would normally be run in a border zone or perimeter network. It is
34used to give client machines within a protected network access to
35streaming servers outside that network, in the case when the firewall
36blocks RTSP connections or RTP/UDP data flow. The firewall perimeter
37network is usually configured to allow:
38
39- RTSP connections from within the network, as long as the destination
40 is the proxy
41
42- RTSP connections to outside the network, as long as the source is
43 the proxy
44
45- RTP datagrams to and from the proxy to the inner network
46
47- RTP datagrams to and from the proxy to the outside
48
49%package Utils
50Summary: Apple's Darwin Streaming Server Movie inspection utilities
51Group: Daemons
52
53%description Utils
54- QTBroadcaster Requires a target ip address, a source movie, one or
55 more source hint track ids in movie, and an initial port. Every packet
56 referenced by the hint track(s) is broadcasted to the specified ip
57 address.
58
59- QTFileInfo Requires a movie name. Displays each track id, name,
60 create date, and mod date. If the track is a hint track, additional
61 information is displayed: the total rtp bytes and packets, the average
62 bit rate and packet size, and the total header percentage of the
63 stream.
64
65- QTFileTest Requires a movie name. Parses the Movie Header Atom and
66 displays a trace of the output.
67
68- QTRTPFileTest Requires a movie and a hint track id in the movie.
69 Displays the RTP header (TransmitTime, Cookie, SeqNum, and TimeStamp)
70 for each packet.
71
72- QTRTPGen Requires a movie and a hint track id. Displays the number
73 of packets in each hint track sample and writes the RTP packets to
74 file "track.cache"
75
76- QTSampleLister Requires a movie and a track id. Displays track media
77 sample number, media time, Data offset, and sample size for each
78 sample in the track.
79
80- QTSDPGen Requires a list of 1 or more movies. Displays the SDP
81 information for all of the hinted tracks in each movie. Use -f to save
82 the SDP information to the file [movie].sdp in the same directory as
83 the source movie.
84
85- QTTrackInfo Requires a movie, sample table atom type, and track id.
86 Displays the information in the sample table atom of the specified
87 track. Supports "stco", "stsc", "stsz", "stts" as the atom type.
88
89Example: "./QTTrackInfo -T stco /movies/mystery.mov 3" dumps the chunk
90offset sample table in track 3.
91
92- StreamingLoadTool
93
94%package Samples
95Summary: Apple's Darwin Streaming Samples
96Group: Daemons
97
98%description Samples
99Sample files for the Darwin Streaming Server.
100
101%prep
102%setup -q -n DarwinStreamingSrvr%{version}-Source
720b962c
ER
103%patch0 -p1
104%patch1 -p1
c08547c4
ER
105%patch2 -p1
106%patch3 -p1
2d53a2fb
ER
107
108# patch streamingadminserver.pl
109%{__sed} -i -e "s|/usr/local/|/usr/|g" WebAdmin/src/streamingadminserver.pl
110%{__sed} -i -e "s|/etc/streaming/|/etc/dss/|g" WebAdmin/src/streamingadminserver.pl
111%{__sed} -i -e "s|/var/streaming/logs/|/var/log/dss/|g" WebAdmin/src/streamingadminserver.pl
112%{__sed} -i -e "s|/var/streaming/|/var/dss/|g" WebAdmin/src/streamingadminserver.pl
113%{__sed} -i -e "s|/usr/local/|/usr/|g" WebAdmin/src/streamingadminserver.pl
114
115# patch manpages
116%{__sed} -i -e "s|/Library/QuickTimeStreaming/Config/|/etc/dss/|g" Documentation/man/qtss/*
117%{__sed} -i -e "s|/Library/QuickTimeStreaming/Modules|/usr/lib/dss|g" Documentation/man/qtss/*
118%{__sed} -i -e "s|/Library/QuickTimeStreaming/Movies|/var/dss/movies|g" Documentation/man/qtss/*
119%{__sed} -i -e "s|/Library/QuickTimeStreaming/Playlists|/var/dss/playlists|g" Documentation/man/qtss/*
120%{__sed} -i -e "s|/Library/QuickTimeStreaming/Logs|/var/log/dss|g" Documentation/man/qtss/*
121%{__sed} -i -e "s|/Library/QuickTimeStreaming/Docs|%{_docdir}/%{name}-%{version}|g" Documentation/man/qtss/*
122%{__sed} -i -e "s|QuickTimeStreamingServer|DarwinStreamingServer|g" Documentation/man/qtss/*
123
124cat > defaultPaths.h << EOF
125#define DEFAULTPATHS_DIRECTORY_SEPARATOR "/"
126#define DEFAULTPATHS_ROOT_DIR "%{_localstatedir}/dss/"
127#define DEFAULTPATHS_ETC_DIR "%{_sysconfdir}/dss/"
128#define DEFAULTPATHS_ETC_DIR_OLD "%{_sysconfdir}/"
129#define DEFAULTPATHS_SSM_DIR "%{_libdir}/dss/"
130#define DEFAULTPATHS_LOG_DIR "%{_localstatedir}/log/dss/"
131#define DEFAULTPATHS_PID_DIR "%{_localstatedir}/run/"
132#define DEFAULTPATHS_MOVIES_DIR "%{_localstatedir}/dss/movies/"
133EOF
134
135%build
136export RPM_OPT_FLAGS="%{rpmcflags}"
137export ARCH="%{_target_cpu}"
138export CC="%{__cc}"
139export CXX="%{__cxx}"
140
141jobs=$(echo %{_smp_mflags} | cut -dj -f2)
142./Buildit ${jobs:+--jobs=$jobs}
143
144%install
145rm -rf $RPM_BUILD_ROOT
146./DSS_MakeRoot \
147 $RPM_BUILD_ROOT
148
149%clean
150rm -rf $RPM_BUILD_ROOT
151
152%files
153%defattr(644,root,root,755)
154%doc APPLE_LICENSE ReleaseNotes.txt
This page took 0.651594 seconds and 4 git commands to generate.