]> git.pld-linux.org Git - packages/dspam.git/blob - dspam.spec
- drop unused /var/lib/%{name}/log symlink
[packages/dspam.git] / dspam.spec
1 # TODO:
2 # - support for libdclassify
3 # - oracle driver
4 # - messages from default install of cron with mysql driver Memory fault
5 # - installing dspam and dspam-client on same host causes
6 #   /etc/dspam.conf being owned by both packages and .rpmnew files being
7 #   created. move the config to -libs? -common? patch code to use
8 #   different config for client?
9 #
10 # Conditional build:
11 %bcond_without  mysql   # disable MySQL storage driver
12 %bcond_without  pgsql   # disable PostgreSQL storage driver
13 %bcond_without  sqlite  # disable SQLite3 storage driver
14 %bcond_without  db      # disable BerkeleyDB storage driver
15 %bcond_with     mysql40 # use with mysql 4.0
16 #
17 %include        /usr/lib/rpm/macros.perl
18 Summary:        A library and Mail Delivery Agent for Bayesian spam filtering
19 Summary(pl):    Biblioteka i MDA do bayesowskiego filtrowania spamu
20 Name:           dspam
21 Version:        3.6.5
22 Release:        0.25
23 License:        GPL
24 Group:          Applications/Mail
25 Source0:        http://www.nuclearelephant.com/projects/dspam/sources/%{name}-%{version}.tar.gz
26 # Source0-md5:  da4f0e00633bff49d71fde418caaf14b
27 Patch0:         %{name}-webui.patch
28 Patch1:         %{name}-config.patch
29 Source1:        %{name}.init
30 Source2:        %{name}-apache.conf
31 URL:            http://www.nuclearelephant.com/projects/dspam/
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 BuildRequires:  clamav-devel
35 %{?with_db:BuildRequires:       db-devel}
36 BuildRequires:  libtool
37 %{?with_mysql:BuildRequires:    mysql-devel}
38 BuildRequires:  openldap-devel
39 %{?with_pgsql:BuildRequires:    postgresql-devel}
40 BuildRequires:  rpm-perlprov >= 4.1-13
41 BuildRequires:  rpmbuild(macros) >= 1.268
42 BuildRequires:  sed >= 4.0
43 %{?with_sqlite:BuildRequires:   sqlite3-devel}
44 BuildRequires:  zlib-devel
45 Requires(post,preun):   /sbin/chkconfig
46 Requires:       rc-scripts
47 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         _webapps        /etc/webapps
50 %define         _webapp         %{name}
51
52 %description
53 DSPAM (as in De-Spam) is an open-source project to create a new kind
54 of anti-spam mechanism, and is currently effective as both a
55 server-side agent for UNIX email servers and a developer's library for
56 mail clients, other anti-spam tools, and similar projects requiring
57 drop-in spam filtering.
58
59 The DSPAM agent masquerades as the email server's local delivery agent
60 and filters/learns spams using an advanced Bayesian statistical
61 approach (based on Bayes's theorem of combined probabilities) which
62 provides an administratively maintenance-free, easy-learning Anti-Spam
63 service custom tailored to each individual user's behavior. Advanced
64 because on top of standard Bayesian filtering is also incorporated the
65 use of Chained Tokens, de-obfuscation, and other enhancements. DSPAM
66 works great with Sendmail and Exim, and should work well with any
67 other MTA that supports an external local delivery agent (postfix,
68 qmail, etc.)
69
70 %description -l pl
71 DSPAM (czyli De-Spam) to projekt o otwartych ¼ród³ach maj±cy na celu
72 stworzenie nowego rodzaju mechanizmu antyspamowego. Aktualnie jest
73 efektywny zarówno jako dzia³aj±cy po stronie serwera agent dla
74 uniksowych serwerów pocztowych jak i biblioteka dla programistów
75 klientów pocztowych, innych narzêdzi antyspamowych i innych projektów
76 wymagaj±cych filtrowania spamu w locie.
77
78 Agent DSPAM zachowuje siê jak lokalny agent dostarczania poczty (MDA)
79 i filtruje/uczy siê spamu przy u¿yciu zaawansowanego bayesowskiego
80 przybli¿enia statystycznego (opartego na twierdzeniu Bayesa o
81 po³±czonych prawdopodobieñstwach), daj±c nie wymagaj±c± obs³ugi
82 administracyjnej, ³atwo ucz±c± siê us³ugê antyspamow± dostosowan± do
83 zachowania ka¿dego u¿ytkownika. Metoda jest zaawansowana poniewa¿ na
84 podstawie standardowego filtrowania bayesowskiego wprowadzono u¿ycie
85 tokenów ³añcuchowych, eliminowanie ukrywanie i inne rozszerzenia.
86 DSPAM dzia³a wspaniale z Sendmailem i Eximem, powinien dzia³aæ dobrze
87 z ka¿dym innym MTA obs³uguj±cym zewnêtrznego agenta MDA (postfiksem,
88 qmailem itd.).
89
90 %package client
91 Summary:        dspam client
92 Summary(pl):    Klient dspam
93 Group:          Applications/Mail
94 # to get the same dspam.conf when both installed
95 Conflicts:      dspam < %{version}-%{release}
96 Conflicts:      dspam > %{version}-%{release}
97
98 %description client
99 dspam client.
100
101 %description client -l pl
102 Klient dspam.
103
104 %package libs
105 Summary:        A library for Bayesian spam filtering
106 Summary(pl):    Biblioteka do bayesowskiego filtrowania spamu
107 Group:          Libraries
108 Requires:       %{name}-driver = %{version}-%{release}
109
110 %description libs
111 DSPAM (as in De-Spam) is an open-source project to create a new kind
112 of anti-spam mechanism, and is currently effective as both a
113 server-side agent for UNIX email servers and a developer's library for
114 mail clients, other anti-spam tools, and similar projects requiring
115 drop-in spam filtering.
116
117 This package contains the library.
118
119 %description libs -l pl
120 DSPAM (czyli De-Spam) to projekt o otwartych ¼ród³ach maj±cy na celu
121 stworzenie nowego rodzaju mechanizmu antyspamowego. Aktualnie jest
122 efektywny zarówno jako dzia³aj±cy po stronie serwera agent dla
123 uniksowych serwerów pocztowych jak i biblioteka dla programistów
124 klientów pocztowych, innych narzêdzi antyspamowych i innych projektów
125 wymagaj±cych filtrowania spamu w locie.
126
127 Ten pakiet zawiera wspomnian± bibliotekê.
128
129 %package devel
130 Summary:        Header files for the DSPAM library
131 Summary(pl):    Pliki nag³ówkowe biblioteki DSPAM
132 Group:          Development/Libraries
133 Requires:       %{name}-libs = %{version}-%{release}
134
135 %description devel
136 DSPAM has had its core engine moved into a separate library, libdspam.
137 This library can be used by developers to provide 'drop-in' spam
138 filtering for their mail client applications, other anti-spam tools,
139 or similar projects.
140
141 %description devel -l pl
142 G³ówny silnik DSPAM zosta³ przeniesiony do oddzielnej biblioteki
143 libdspam, która mo¿e byæ u¿ywana przez programistów do zapewnienia
144 filtrowania spamu w locie dla aplikacji klientów pocztowych, innych
145 narzêdzi antyspamowych i podobnych projektów.
146
147 %package static
148 Summary:        Static DSPAM library
149 Summary(pl):    Statyczna biblioteka DSPAM
150 Group:          Development/Libraries
151 Requires:       %{name}-devel = %{version}-%{release}
152
153 %description static
154 Static DSPAM library.
155
156 %description static -l pl
157 Statyczna biblioteka DSPAM.
158
159 %package driver-hash
160 Summary:        HASH driver for DSPAM
161 Summary(pl):    Sterownik HASH dla DSPAM-a
162 Group:          Libraries
163 Requires(post): sed >= 4.0
164 Requires:       %{name}-libs = %{version}-%{release}
165 Provides:       %{name}-driver = %{version}-%{release}
166
167 %description driver-hash
168 HASH driver for DSPAM.
169
170 %description driver-hash -l pl
171 Sterownik HASH dla DSPAM-a.
172
173 %package driver-db
174 Summary:        DB driver for DSPAM
175 Summary(pl):    Sterownik DB dla DSPAM-a
176 Group:          Libraries
177 Requires(post): sed >= 4.0
178 Requires:       %{name}-libs = %{version}-%{release}
179 Provides:       %{name}-driver = %{version}-%{release}
180
181 %description driver-db
182 DB driver for DSPAM.
183
184 %description driver-db -l pl
185 Sterownik DB dla DSPAM-a.
186
187 %package driver-mysql
188 Summary:        MySQL driver for DSPAM
189 Summary(pl):    Sterownik MySQL dla DSPAM-a
190 Group:          Libraries
191 Requires(post): sed >= 4.0
192 Requires:       %{name}-libs = %{version}-%{release}
193 Provides:       %{name}-driver = %{version}-%{release}
194
195 %description driver-mysql
196 MySQL driver for DSPAM.
197
198 %description driver-mysql -l pl
199 Sterownik MySQL dla DSPAM-a.
200
201 %package driver-pgsql
202 Summary:        PostgreSQL driver for DSPAM
203 Summary(pl):    Sterownik PostgreSQL dla DSPAM-a
204 Group:          Libraries
205 Requires(post): sed >= 4.0
206 Requires:       %{name}-libs = %{version}-%{release}
207 Provides:       %{name}-driver = %{version}-%{release}
208
209 %description driver-pgsql
210 PostgreSQL driver for DSPAM.
211
212 %description driver-pgsql -l pl
213 Sterownik PostgreSQL dla DSPAM-a.
214
215 %package driver-sqlite
216 Summary:        SQLite driver for DSPAM
217 Summary(pl):    Sterownik SQLite dla DSPAM-a
218 Group:          Libraries
219 Requires(post): sed >= 4.0
220 Requires:       %{name}-libs = %{version}-%{release}
221 Provides:       %{name}-driver = %{version}-%{release}
222
223 %description driver-sqlite
224 SQLite driver for DSPAM.
225
226 %description driver-sqlite -l pl
227 Sterownik SQLite dla DSPAM-a.
228
229 %package webui
230 Summary:        DSPAM Web UI
231 Group:          Applications/WWW
232 Requires:       webapps
233 # needs dspam binary
234 Requires:       %{name} = %{version}-%{release}
235
236 %description webui
237 The Web UI (CGI client) can be run from any executable location on a
238 web server, and detects its user's identity from the REMOTE_USER
239 environment variable. This means you'll need to use HTTP password
240 authentication to access the CGI (Any type of authentication will
241 work, so long as Apache supports the module). This is also convenient
242 in that you can set up authentication using almost any existing system
243 you have. The only catch is that you'll need the usernames to match
244 the actual DSPAM usernames used the system. A copy of the shadow
245 password file will suffice for most common installs.
246
247 %prep
248 %setup -q
249 %patch0 -p1
250 %patch1 -p1
251 sed -i -e 's#\-static##g' src/Makefile* src/*/Makefile*
252 %{?with_mysql40:sed -i -e 's#40100#99999#g' src/mysql_drv.c}
253 sed -i -e 's,/usr/local/dspam/bin,/usr/bin,' ./scripts/train.pl
254
255 %build
256 %{__libtoolize}
257 %{__aclocal} -I m4
258 %{__autoconf}
259 %{__automake}
260
261 DRIVERS="
262 hash_drv
263 %{?with_db:libdb4_drv}
264 %{?with_mysql:mysql_drv}
265 %{?with_pgsql:pgsql_drv}
266 %{?with_sqlite:sqlite_drv}
267 "
268 %configure \
269         --disable-dependency-tracking \
270         %{?debug: --enable-debug --enable-bnr-debug --enable-verbose-debug} \
271         --enable-trusted-user-security \
272         --enable-bias \
273         --enable-large-scale \
274         --with-userdir=/var/lib/%{name} \
275         --with-userdir-owner=none \
276         --with-userdir-group=none \
277         --with-dspam-home=/var/lib/%{name} \
278         --with-dspam-home-owner=none \
279         --with-dspam-home-group=none \
280         --with-dspam-owner=none \
281         --with-dspam-group=none \
282         --with-signature-life=14 \
283         --enable-ldap \
284         --enable-clamav \
285         --enable-preferences-extension \
286         --enable-long-usernames \
287         --enable-neural-networking \
288         --enable-virtual-users \
289         --with-storage-driver=$(echo $DRIVERS | tr ' ' ',') \
290 %if %{with mysql}
291         --with-mysql-includes=%{_includedir}/mysql \
292         --with-mysql-libraries=%{_libdir} \
293 %endif
294 %if %{with pgsql}
295         --with-pgsql-includes=%{_includedir}/postgresql \
296         --with-pgsql-libraries=%{_libdir} \
297 %endif
298 %if %{with sqlite}
299         --with-sqlite3-includes=%{_includedir} \
300         --with-sqlite3-libraries=%{_libdir} \
301 %endif
302         --enable-daemon
303
304 # --enable-dclassify-extension needs libdclassify
305
306 %{__make}
307
308 %install
309 rm -rf $RPM_BUILD_ROOT
310 install -d $RPM_BUILD_ROOT{/var/run/dspam,/etc/{rc.d/init.d,sysconfig}} \
311         $RPM_BUILD_ROOT/var/lib/%{name}/data
312
313 %{__make} install \
314         DESTDIR=$RPM_BUILD_ROOT
315
316 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/dspam
317
318 # install devel files
319 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name},/var/{log,lib}/%{name}}
320 install src/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}
321
322 # provide maintenance scripts
323 install -d $RPM_BUILD_ROOT/etc/cron.{daily,weekly}
324 cat > $RPM_BUILD_ROOT/etc/cron.daily/%{name} <<EOF
325 #!/bin/sh
326 exec %{_bindir}/%{name}_clean -s -p
327 EOF
328
329 chmod 755 $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/%{name}
330
331 # fix prefix
332 sed -i -e "s|%{_prefix}/local|%{_prefix}|g" $RPM_BUILD_ROOT%{_bindir}/%{name}_corpus
333
334 # fix purge stuff
335 #install dspam-cron.weekly $RPM_BUILD_ROOT%{_sysconfdir}/cron.weekly/%{name}
336
337 %if %{with mysql}
338 cat > $RPM_BUILD_ROOT/var/lib/%{name}/mysql.data <<EOF
339 _UNCONFIGURED_
340
341 Note!
342
343 This file can only contain 5 lines with the following values:
344
345 HOSTNAME
346 PORT
347 USERNAME
348 PASSWORD
349 DATABASE
350 EOF
351 %endif
352
353 %if %{with pgsql}
354 cat > $RPM_BUILD_ROOT/var/lib/%{name}/pgsql.data <<EOF
355 _UNCONFIGURED_
356
357 Note!
358
359 This file can only contain 5 lines with the following values:
360
361 HOSTNAME
362 PORT
363 USERNAME
364 PASSWORD
365 DATABASE
366 EOF
367 %endif
368
369 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
370 install %{SOURCE2} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
371 install %{SOURCE2} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
372 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
373
374 %post
375 /sbin/chkconfig --add dspam
376 %service dspam restart "dspam daemon"
377
378 %preun
379 if [ "$1" = "0" ]; then
380         %service dspam stop
381         /sbin/chkconfig --del dspam
382 fi
383
384 %clean
385 rm -rf $RPM_BUILD_ROOT
386
387 %post   libs -p /sbin/ldconfig
388 %postun libs -p /sbin/ldconfig
389
390 %post driver-db
391 if [ "$1" = "1" ]; then
392         sed -i -e '/^StorageDriver/s,/.*.so,%{_libdir}/libdb4_drv.so,' /etc/dspam.conf
393 fi
394
395 %post driver-hash
396 if [ "$1" = "1" ]; then
397         sed -i -e '/^StorageDriver/s,/.*\.so,%{_libdir}/libhash_drv.so,' /etc/dspam.conf
398 fi
399
400 %post driver-mysql
401 if [ "$1" = "1" ]; then
402         sed -i -e '/^StorageDriver/s,/.*\.so,%{_libdir}/libmysql_drv.so,' /etc/dspam.conf
403 fi
404
405 %post driver-pgsql
406 if [ "$1" = "1" ]; then
407         sed -i -e '/^StorageDriver/s,/.*\.so,%{_libdir}/libpgsql_drv.so,' /etc/dspam.conf
408 fi
409
410 %post driver-sqlite
411 if [ "$1" = "1" ]; then
412         sed -i -e '/^StorageDriver/s,/.*\.so,%{_libdir}/libsqlite_drv.so,' /etc/dspam.conf
413 fi
414
415 %triggerin webui -- apache1
416 %webapp_register apache %{_webapp}
417
418 %triggerun webui -- apache1
419 %webapp_unregister apache %{_webapp}
420
421 %triggerin webui -- apache < 2.2.0, apache-base
422 %webapp_register httpd %{_webapp}
423
424 %triggerun webui -- apache < 2.2.0, apache-base
425 %webapp_unregister httpd %{_webapp}
426
427 %files
428 %defattr(644,root,root,755)
429 %doc README CHANGELOG RELEASE.NOTES UPGRADING
430 %doc doc/{courier,exim,markov,pop3filter,postfix,qmail,relay,sendmail}.txt
431 %doc scripts/train.pl
432 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dspam.conf
433 %dir %attr(775,root,mail) /var/run/dspam
434 %dir %attr(750,root,mail) /var/lib/%{name}
435 %dir %attr(770,root,mail) /var/lib/%{name}/data
436 %dir %attr(770,root,mail) /var/log/dspam
437 %attr(754,root,root) /etc/rc.d/init.d/dspam
438 %attr(755,root,root) %config(noreplace) /etc/cron.daily/%{name}
439 %attr(755,root,root) %{_bindir}/%{name}
440 %attr(755,root,root) %{_bindir}/%{name}_logrotate
441 %attr(755,root,root) %{_bindir}/%{name}_clean
442 %attr(755,root,root) %{_bindir}/%{name}_corpus
443 %attr(755,root,root) %{_bindir}/%{name}_crc
444 %attr(755,root,root) %{_bindir}/%{name}_dump
445 %attr(755,root,root) %{_bindir}/%{name}_genaliases
446 %attr(755,root,root) %{_bindir}/%{name}_stats
447 %attr(755,root,root) %{_bindir}/%{name}_merge
448 %attr(755,root,root) %{_bindir}/%{name}_2sql
449 %attr(755,root,root) %{_bindir}/%{name}_admin
450 %attr(755,root,root) %{_bindir}/%{name}_train
451 %{_mandir}/man?/%{name}*
452
453 %files client
454 %defattr(644,root,root,755)
455 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dspam.conf
456 %attr(755,root,root) %{_bindir}/%{name}c
457
458 %files libs
459 %defattr(644,root,root,755)
460 %doc README CHANGELOG
461 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
462 %attr(755,root,root) %exclude %{_libdir}/lib*_drv*.so*
463
464 %files devel
465 %defattr(644,root,root,755)
466 %attr(755,root,root) %{_libdir}/lib*.so
467 %attr(755,root,root) %exclude %{_libdir}/lib*_drv*.so*
468 %{_libdir}/lib*.la
469 %{_includedir}/%{name}
470 %{_mandir}/man3/libdspam*
471 %{_pkgconfigdir}/*.pc
472
473 %files static
474 %defattr(644,root,root,755)
475 %{_libdir}/lib*.a
476
477 %files driver-hash
478 %defattr(644,root,root,755)
479 %attr(755,root,root) %{_bindir}/css*
480 %attr(755,root,root) %{_libdir}/libhash_drv*.so*
481
482 %if %{with db}
483 %files driver-db
484 %defattr(644,root,root,755)
485 %attr(755,root,root) %{_libdir}/libdb4_drv*.so*
486 %endif
487
488 %if %{with mysql}
489 %files driver-mysql
490 %defattr(644,root,root,755)
491 %doc doc/mysql_drv.txt src/tools.mysql_drv/*.sql
492 %attr(640,root,mail) %config(noreplace) /var/lib/%{name}/mysql.data
493 %attr(755,root,root) %{_libdir}/libmysql_drv*.so*
494 %endif
495
496 %if %{with pgsql}
497 %files driver-pgsql
498 %defattr(644,root,root,755)
499 %doc doc/pgsql_drv.txt src/tools.pgsql_drv/*.sql
500 %attr(640,root,mail) %config(noreplace) /var/lib/%{name}/pgsql.data
501 %attr(755,root,root) %{_bindir}/%{name}_pg2int8
502 %attr(755,root,root) %{_libdir}/libpgsql_drv*.so*
503 %endif
504
505 %if %{with sqlite}
506 %files driver-sqlite
507 %defattr(644,root,root,755)
508 %doc doc/sqlite_drv.txt
509 %attr(755,root,root) %{_libdir}/libsqlite_drv*.so*
510 %endif
511
512 %files webui
513 %defattr(644,root,root,755)
514 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
515 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
516 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
517 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
518 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/admins
519 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/default.prefs
520 %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/configure.pl
521
522 %dir %{_datadir}/dspam
523 %dir %{_datadir}/dspam/cgi
524 %attr(755,root,root) %{_datadir}/dspam/cgi/*.cgi
525 %{_datadir}/dspam/cgi/templates
526 %{_datadir}/dspam/htdocs
This page took 0.073322 seconds and 4 git commands to generate.