]> git.pld-linux.org Git - packages/dsniff.git/commitdiff
- new/updated
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 8 Nov 2003 22:04:51 +0000 (22:04 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    dsniff-ac.patch -> 1.2
    dsniff-clk_tck.patch -> 1.1
    dsniff-libnet1.patch -> 1.2

dsniff-ac.patch
dsniff-clk_tck.patch [new file with mode: 0644]
dsniff-libnet1.patch

index e2b08a795b77e08c045fca44245e6340709a96fe..a081cccd978bbe394f910b13569a1cc4d17456b8 100644 (file)
@@ -1,5 +1,6 @@
---- dsniff-2.3/configure.in.org        Sun Dec  3 05:16:50 2000
-+++ dsniff-2.3/configure.in    Sun Aug  4 15:07:07 2002
+diff -urN dsniff-2.4.org/configure.in dsniff-2.4/configure.in
+--- dsniff-2.4.org/configure.in        2003-11-08 22:37:23.000000000 +0100
++++ dsniff-2.4/configure.in    2003-11-08 22:38:34.000000000 +0100
 @@ -61,17 +61,17 @@
  needmd5=no
  AC_CHECK_FUNCS(MD5Update, , [needmd5=yes])
 @@ -61,17 +61,17 @@
  needmd5=no
  AC_CHECK_FUNCS(MD5Update, , [needmd5=yes])
diff --git a/dsniff-clk_tck.patch b/dsniff-clk_tck.patch
new file mode 100644 (file)
index 0000000..94cc68a
--- /dev/null
@@ -0,0 +1,38 @@
+diff -urN dsniff-2.4.org/sshow.c dsniff-2.4/sshow.c
+--- dsniff-2.4.org/sshow.c     2003-11-08 22:37:23.000000000 +0100
++++ dsniff-2.4/sshow.c 2003-11-08 22:55:31.000000000 +0100
+@@ -25,6 +25,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <time.h>
+ #include <ctype.h>
+ #include <unistd.h>
+ #include <signal.h>
+@@ -222,7 +223,7 @@
+       if (debug)
+               printf("- %s -> %s: DATA (%s bytes, %.2f seconds)\n",
+                       s_saddr(ts), s_daddr(ts), s_range(plain_range),
+-                      (float)delay / CLK_TCK);
++                      (float)delay / CLOCKS_PER_SEC);
+       if (debug > 1)
+               print_data(&ts->server, cipher_size);
+@@ -270,7 +271,7 @@
+       if (debug)
+               printf("- %s <- %s: DATA (%s bytes, %.2f seconds)\n",
+                      s_saddr(ts), s_daddr(ts), s_range(plain_range),
+-                     (float)delay / CLK_TCK);
++                     (float)delay / CLOCKS_PER_SEC);
+       if (debug > 1)
+               print_data(&ts->client, cipher_size);
+       
+@@ -299,7 +300,7 @@
+       
+       if (session->state == 1 &&
+ #ifdef USE_TIMING
+-          now - get_history(session, 2)->timestamp >= CLK_TCK &&
++          now - get_history(session, 2)->timestamp >= CLOCKS_PER_SEC &&
+ #endif
+           session->protocol == 1 &&
+           (session->history.directions & 7) == 5 &&
index cf3d13d35f061ecf28ba6e9941f5ef5f7652bd12..7076df57a6ace76358c080de854567d46e683ccb 100644 (file)
@@ -1,7 +1,7 @@
-diff -Nur dsniff-2.3.org/arpspoof.c dsniff-2.3/arpspoof.c
---- dsniff-2.3.org/arpspoof.c  2000-11-28 07:43:43.000000000 +0000
-+++ dsniff-2.3/arpspoof.c      2003-07-03 20:04:23.000000000 +0000
-@@ -17,7 +17,7 @@
+diff -urN dsniff-2.4.org/arpspoof.c dsniff-2.4/arpspoof.c
+--- dsniff-2.4.org/arpspoof.c  2003-11-08 22:37:23.000000000 +0100
++++ dsniff-2.4/arpspoof.c      2003-11-08 22:45:50.000000000 +0100
+@@ -19,7 +19,7 @@
  #include <string.h>
  #include <signal.h>
  #include <err.h>
  #include <string.h>
  #include <signal.h>
  #include <err.h>
@@ -9,35 +9,101 @@ diff -Nur dsniff-2.3.org/arpspoof.c dsniff-2.3/arpspoof.c
 +#include <libnet1.h>
  #include <pcap.h>
  
 +#include <libnet1.h>
  #include <pcap.h>
  
- #include "version.h"
-diff -Nur dsniff-2.3.org/decode_portmap.c dsniff-2.3/decode_portmap.c
---- dsniff-2.3.org/decode_portmap.c    2000-12-15 20:13:29.000000000 +0000
-+++ dsniff-2.3/decode_portmap.c        2003-07-03 20:04:23.000000000 +0000
-@@ -15,7 +15,7 @@
- #include <rpc/pmap_prot.h>
+ #include "arp.h"
+diff -urN dsniff-2.4.org/configure.in dsniff-2.4/configure.in
+--- dsniff-2.4.org/configure.in        2003-11-08 22:37:23.000000000 +0100
++++ dsniff-2.4/configure.in    2003-11-08 22:46:09.000000000 +0100
+@@ -204,43 +204,43 @@
+ AC_SUBST(PCAPINC)
+ AC_SUBST(PCAPLIB)
+-dnl Checks for libnet
+-AC_MSG_CHECKING(for libnet)
+-AC_ARG_WITH(libnet,
+-[  --with-libnet=DIR       use libnet in DIR],
++dnl Checks for libnet1
++AC_MSG_CHECKING(for libnet1)
++AC_ARG_WITH(libnet1,
++[  --with-libnet1=DIR       use libnet1 in DIR],
+ [ case "$withval" in
+   yes|no)
+      AC_MSG_RESULT(no)
+      ;;
+   *)
+      AC_MSG_RESULT($withval)
+-     if test -f $withval/include/libnet.h -a -f $withval/lib/libnet.a; then
++     if test -f $withval/include/libnet1.h -a -f $withval/lib/libnet1.a; then
+         owd=`pwd`
+         if cd $withval; then withval=`pwd`; cd $owd; fi
+-      if test -f $withval/bin/libnet-config; then
+-         CFLAGS="$CFLAGS `$withval/bin/libnet-config --defines`"
+-      elif test -f $withval/libnet-config; then
+-         CFLAGS="$CFLAGS `$withval/libnet-config --defines`"
++      if test -f $withval/bin/libnet1-config; then
++         CFLAGS="$CFLAGS `$withval/bin/libnet1-config --defines`"
++      elif test -f $withval/libnet1-config; then
++         CFLAGS="$CFLAGS `$withval/libnet1-config --defines`"
+       else
+-         CFLAGS="$CFLAGS `libnet-config --defines`"
++         CFLAGS="$CFLAGS `libnet1-config --defines`"
+       fi
+       LNETINC="-I$withval/include"
+-      LNETLIB="-L$withval/lib -lnet"
++      LNETLIB="-L$withval/lib -lnet1"
+      else
+-        AC_ERROR(libnet.h or libnet.a not found in $withval)
++        AC_ERROR(libnet1.h or libnet1.a not found in $withval)
+      fi
+      ;;
+   esac ],
+-[ if test -f ${prefix}/include/libnet.h; then
+-     CFLAGS="$CFLAGS `${prefix}/bin/libnet-config --defines`"
++[ if test -f ${prefix}/include/libnet1.h; then
++     CFLAGS="$CFLAGS `${prefix}/bin/libnet1-config --defines`"
+      LNETINC="-I${prefix}/include"
+-     LNETLIB="-L${prefix}/lib -lnet"
+-  elif test -f /usr/include/libnet.h; then
+-     CFLAGS="$CFLAGS `libnet-config --defines`"
+-     LNETLIB="-lnet"
++     LNETLIB="-L${prefix}/lib -lnet1"
++  elif test -f /usr/include/libnet1.h; then
++     CFLAGS="$CFLAGS `libnet1-config --defines`"
++     LNETLIB="-lnet1"
+   else
+      AC_MSG_RESULT(no)
+-     AC_ERROR(libnet not found)
++     AC_ERROR(libnet1 not found)
+   fi
+   AC_MSG_RESULT(yes) ]
+ )
+diff -urN dsniff-2.4.org/decode_portmap.c dsniff-2.4/decode_portmap.c
+--- dsniff-2.4.org/decode_portmap.c    2003-11-08 22:37:23.000000000 +0100
++++ dsniff-2.4/decode_portmap.c        2003-11-08 22:45:50.000000000 +0100
+@@ -16,7 +16,7 @@
  #include <stdio.h>
  #include <stdlib.h>
 -#include <libnet.h>
 +#include <libnet1.h>
  #include <nids.h>
  #include <stdio.h>
  #include <stdlib.h>
 -#include <libnet.h>
 +#include <libnet1.h>
  #include <nids.h>
  #include "rpc.h"
  #include "rpc.h"
- #include "trigger.h"
-diff -Nur dsniff-2.3.org/dnsspoof.c dsniff-2.3/dnsspoof.c
---- dsniff-2.3.org/dnsspoof.c  2003-07-03 19:56:40.000000000 +0000
-+++ dsniff-2.3/dnsspoof.c      2003-07-03 20:04:23.000000000 +0000
-@@ -21,7 +21,7 @@
+diff -urN dsniff-2.4.org/dnsspoof.c dsniff-2.4/dnsspoof.c
+--- dsniff-2.4.org/dnsspoof.c  2003-11-08 22:37:23.000000000 +0100
++++ dsniff-2.4/dnsspoof.c      2003-11-08 22:45:50.000000000 +0100
+@@ -22,7 +22,7 @@
  #include <string.h>
  #include <resolv.h>
  #include <err.h>
 -#include <libnet.h>
 +#include <libnet1.h>
  #include <pcap.h>
  #include <string.h>
  #include <resolv.h>
  #include <err.h>
 -#include <libnet.h>
 +#include <libnet1.h>
  #include <pcap.h>
- #include "slist.h"
  #include "pcaputil.h"
  #include "pcaputil.h"
-diff -Nur dsniff-2.3.org/dsniff.c dsniff-2.3/dsniff.c
---- dsniff-2.3.org/dsniff.c    2000-12-01 21:27:15.000000000 +0000
-+++ dsniff-2.3/dsniff.c        2003-07-03 20:04:23.000000000 +0000
-@@ -18,7 +18,7 @@
+diff -urN dsniff-2.4.org/dsniff.c dsniff-2.4/dsniff.c
+--- dsniff-2.4.org/dsniff.c    2003-11-08 22:37:23.000000000 +0100
++++ dsniff-2.4/dsniff.c        2003-11-08 22:45:51.000000000 +0100
+@@ -19,7 +19,7 @@
  #include <unistd.h>
  #include <signal.h>
  #include <err.h>
  #include <unistd.h>
  #include <signal.h>
  #include <err.h>
@@ -45,10 +111,10 @@ diff -Nur dsniff-2.3.org/dsniff.c dsniff-2.3/dsniff.c
 +#include <libnet1.h>
  #include <nids.h>
  #include <pcap.h>
 +#include <libnet1.h>
  #include <nids.h>
  #include <pcap.h>
- #include "options.h"
-diff -Nur dsniff-2.3.org/filesnarf.c dsniff-2.3/filesnarf.c
---- dsniff-2.3.org/filesnarf.c 2000-12-15 20:16:58.000000000 +0000
-+++ dsniff-2.3/filesnarf.c     2003-07-03 20:04:23.000000000 +0000
+diff -urN dsniff-2.4.org/filesnarf.c dsniff-2.4/filesnarf.c
+--- dsniff-2.4.org/filesnarf.c 2003-11-08 22:37:23.000000000 +0100
++++ dsniff-2.4/filesnarf.c     2003-11-08 22:45:51.000000000 +0100
 @@ -19,7 +19,7 @@
  #include <fcntl.h>
  #include <regex.h>
 @@ -19,7 +19,7 @@
  #include <fcntl.h>
  #include <regex.h>
@@ -58,10 +124,10 @@ diff -Nur dsniff-2.3.org/filesnarf.c dsniff-2.3/filesnarf.c
  #include <nids.h>
  #include <pcap.h>
  
  #include <nids.h>
  #include <pcap.h>
  
-diff -Nur dsniff-2.3.org/macof.c dsniff-2.3/macof.c
---- dsniff-2.3.org/macof.c     2000-11-14 15:50:55.000000000 +0000
-+++ dsniff-2.3/macof.c 2003-07-03 20:04:23.000000000 +0000
-@@ -18,7 +18,7 @@
+diff -urN dsniff-2.4.org/macof.c dsniff-2.4/macof.c
+--- dsniff-2.4.org/macof.c     2003-11-08 22:37:23.000000000 +0100
++++ dsniff-2.4/macof.c 2003-11-08 22:45:51.000000000 +0100
+@@ -20,7 +20,7 @@
  #include <stdio.h>
  #include <string.h>
  #include <err.h>
  #include <stdio.h>
  #include <string.h>
  #include <err.h>
@@ -70,10 +136,10 @@ diff -Nur dsniff-2.3.org/macof.c dsniff-2.3/macof.c
  #include <pcap.h>
  
  #include "version.h"
  #include <pcap.h>
  
  #include "version.h"
-diff -Nur dsniff-2.3.org/mailsnarf.c dsniff-2.3/mailsnarf.c
---- dsniff-2.3.org/mailsnarf.c 2000-11-19 19:39:41.000000000 +0000
-+++ dsniff-2.3/mailsnarf.c     2003-07-03 20:04:23.000000000 +0000
-@@ -18,7 +18,7 @@
+diff -urN dsniff-2.4.org/mailsnarf.c dsniff-2.4/mailsnarf.c
+--- dsniff-2.4.org/mailsnarf.c 2003-11-08 22:37:23.000000000 +0100
++++ dsniff-2.4/mailsnarf.c     2003-11-08 22:45:51.000000000 +0100
+@@ -19,7 +19,7 @@
  #include <time.h>
  #include <regex.h>
  #include <err.h>
  #include <time.h>
  #include <regex.h>
  #include <err.h>
@@ -81,11 +147,11 @@ diff -Nur dsniff-2.3.org/mailsnarf.c dsniff-2.3/mailsnarf.c
 +#include <libnet1.h>
  #include <nids.h>
  #include <pcap.h>
 +#include <libnet1.h>
  #include <nids.h>
  #include <pcap.h>
- #include "pcaputil.h"
-diff -Nur dsniff-2.3.org/msgsnarf.c dsniff-2.3/msgsnarf.c
---- dsniff-2.3.org/msgsnarf.c  2003-07-03 19:56:40.000000000 +0000
-+++ dsniff-2.3/msgsnarf.c      2003-07-03 20:04:23.000000000 +0000
-@@ -17,7 +17,7 @@
+diff -urN dsniff-2.4.org/msgsnarf.c dsniff-2.4/msgsnarf.c
+--- dsniff-2.4.org/msgsnarf.c  2003-11-08 22:37:23.000000000 +0100
++++ dsniff-2.4/msgsnarf.c      2003-11-08 22:45:51.000000000 +0100
+@@ -19,7 +19,7 @@
  #include <string.h>
  #include <regex.h>
  #include <err.h>
  #include <string.h>
  #include <regex.h>
  #include <err.h>
@@ -94,21 +160,21 @@ diff -Nur dsniff-2.3.org/msgsnarf.c dsniff-2.3/msgsnarf.c
  #include <nids.h>
  #include <pcap.h>
  #include <pcaputil.h>
  #include <nids.h>
  #include <pcap.h>
  #include <pcaputil.h>
-diff -Nur dsniff-2.3.org/record.c dsniff-2.3/record.c
---- dsniff-2.3.org/record.c    2003-07-03 19:56:40.000000000 +0000
-+++ dsniff-2.3/record.c        2003-07-03 20:04:23.000000000 +0000
-@@ -19,7 +19,7 @@
+diff -urN dsniff-2.4.org/record.c dsniff-2.4/record.c
+--- dsniff-2.4.org/record.c    2003-11-08 22:37:23.000000000 +0100
++++ dsniff-2.4/record.c        2003-11-08 22:45:51.000000000 +0100
+@@ -21,7 +21,7 @@
  #elif HAVE_DB_H
  #include <db.h>
  #endif
 -#include <libnet.h>
 +#include <libnet1.h>
  #elif HAVE_DB_H
  #include <db.h>
  #endif
 -#include <libnet.h>
 +#include <libnet1.h>
  #include "options.h"
  #include "record.h"
  #include "options.h"
  #include "record.h"
-diff -Nur dsniff-2.3.org/sshmitm.c dsniff-2.3/sshmitm.c
---- dsniff-2.3.org/sshmitm.c   2000-12-17 21:09:43.000000000 +0000
-+++ dsniff-2.3/sshmitm.c       2003-07-03 20:04:23.000000000 +0000
+diff -urN dsniff-2.4.org/sshmitm.c dsniff-2.4/sshmitm.c
+--- dsniff-2.4.org/sshmitm.c   2003-11-08 22:37:23.000000000 +0100
++++ dsniff-2.4/sshmitm.c       2003-11-08 22:45:51.000000000 +0100
 @@ -16,7 +16,7 @@
  #include <sys/wait.h>
  #include <arpa/nameser.h>
 @@ -16,7 +16,7 @@
  #include <sys/wait.h>
  #include <arpa/nameser.h>
@@ -118,58 +184,58 @@ diff -Nur dsniff-2.3.org/sshmitm.c dsniff-2.3/sshmitm.c
  
  #include <err.h>
  #include <errno.h>
  
  #include <err.h>
  #include <errno.h>
-diff -Nur dsniff-2.3.org/tcp_raw.c dsniff-2.3/tcp_raw.c
---- dsniff-2.3.org/tcp_raw.c   2000-11-28 07:48:25.000000000 +0000
-+++ dsniff-2.3/tcp_raw.c       2003-07-03 20:04:23.000000000 +0000
-@@ -12,7 +12,7 @@
- #include <sys/uio.h>
- #include <time.h>
- #include <err.h>
--#include <libnet.h>
-+#include <libnet1.h>
- #include "options.h"
- #include "tcp_raw.h"
-diff -Nur dsniff-2.3.org/tcpkill.c dsniff-2.3/tcpkill.c
---- dsniff-2.3.org/tcpkill.c   2000-11-30 00:39:05.000000000 +0000
-+++ dsniff-2.3/tcpkill.c       2003-07-03 20:04:23.000000000 +0000
-@@ -16,7 +16,7 @@
+diff -urN dsniff-2.4.org/tcpkill.c dsniff-2.4/tcpkill.c
+--- dsniff-2.4.org/tcpkill.c   2003-11-08 22:37:23.000000000 +0100
++++ dsniff-2.4/tcpkill.c       2003-11-08 22:45:51.000000000 +0100
+@@ -17,7 +17,7 @@
  #include <unistd.h>
  #include <string.h>
  #include <err.h>
 -#include <libnet.h>
 +#include <libnet1.h>
  #include <pcap.h>
  #include <unistd.h>
  #include <string.h>
  #include <err.h>
 -#include <libnet.h>
 +#include <libnet1.h>
  #include <pcap.h>
  #include "pcaputil.h"
  #include "pcaputil.h"
- #include "version.h"
-diff -Nur dsniff-2.3.org/tcpnice.c dsniff-2.3/tcpnice.c
---- dsniff-2.3.org/tcpnice.c   2000-11-30 00:39:05.000000000 +0000
-+++ dsniff-2.3/tcpnice.c       2003-07-03 20:04:23.000000000 +0000
-@@ -18,7 +18,7 @@
+diff -urN dsniff-2.4.org/tcpnice.c dsniff-2.4/tcpnice.c
+--- dsniff-2.4.org/tcpnice.c   2003-11-08 22:37:23.000000000 +0100
++++ dsniff-2.4/tcpnice.c       2003-11-08 22:45:51.000000000 +0100
+@@ -17,7 +17,7 @@
  #include <unistd.h>
  #include <string.h>
  #include <err.h>
 -#include <libnet.h>
 +#include <libnet1.h>
  #include <pcap.h>
  #include <unistd.h>
  #include <string.h>
  #include <err.h>
 -#include <libnet.h>
 +#include <libnet1.h>
  #include <pcap.h>
  #include "pcaputil.h"
  #include "pcaputil.h"
- #include "version.h"
-diff -Nur dsniff-2.3.org/trigger.c dsniff-2.3/trigger.c
---- dsniff-2.3.org/trigger.c   2000-11-19 21:44:29.000000000 +0000
-+++ dsniff-2.3/trigger.c       2003-07-03 20:04:23.000000000 +0000
-@@ -12,7 +12,7 @@
- #include <sys/uio.h>
+diff -urN dsniff-2.4.org/tcp_raw.c dsniff-2.4/tcp_raw.c
+--- dsniff-2.4.org/tcp_raw.c   2003-11-08 22:37:23.000000000 +0100
++++ dsniff-2.4/tcp_raw.c       2003-11-08 22:45:51.000000000 +0100
+@@ -14,7 +14,7 @@
+ #include <time.h>
+ #include <err.h>
+-#include <libnet.h>
++#include <libnet1.h>
+ #include "options.h"
+ #include "tcp_raw.h"
+diff -urN dsniff-2.4.org/trigger.c dsniff-2.4/trigger.c
+--- dsniff-2.4.org/trigger.c   2003-11-08 22:37:23.000000000 +0100
++++ dsniff-2.4/trigger.c       2003-11-08 22:45:51.000000000 +0100
+@@ -14,7 +14,7 @@
  #include <stdlib.h>
  #include <err.h>
 -#include <libnet.h>
 +#include <libnet1.h>
  #include <nids.h>
  #include <stdlib.h>
  #include <err.h>
 -#include <libnet.h>
 +#include <libnet1.h>
  #include <nids.h>
  #include "decode.h"
  #include "decode.h"
- #include "magic.h"
-diff -Nur dsniff-2.3.org/urlsnarf.c dsniff-2.3/urlsnarf.c
---- dsniff-2.3.org/urlsnarf.c  2000-12-19 02:53:36.000000000 +0000
-+++ dsniff-2.3/urlsnarf.c      2003-07-03 20:04:23.000000000 +0000
-@@ -21,7 +21,7 @@
+diff -urN dsniff-2.4.org/urlsnarf.c dsniff-2.4/urlsnarf.c
+--- dsniff-2.4.org/urlsnarf.c  2003-11-08 22:37:23.000000000 +0100
++++ dsniff-2.4/urlsnarf.c      2003-11-08 22:45:51.000000000 +0100
+@@ -22,7 +22,7 @@
  #include <regex.h>
  #include <time.h>
  #include <err.h>
  #include <regex.h>
  #include <time.h>
  #include <err.h>
@@ -177,10 +243,10 @@ diff -Nur dsniff-2.3.org/urlsnarf.c dsniff-2.3/urlsnarf.c
 +#include <libnet1.h>
  #include <nids.h>
  #include <pcap.h>
 +#include <libnet1.h>
  #include <nids.h>
  #include <pcap.h>
- #include "pcaputil.h"
-diff -Nur dsniff-2.3.org/webmitm.c dsniff-2.3/webmitm.c
---- dsniff-2.3.org/webmitm.c   2000-12-03 05:13:28.000000000 +0000
-+++ dsniff-2.3/webmitm.c       2003-07-03 20:04:23.000000000 +0000
+diff -urN dsniff-2.4.org/webmitm.c dsniff-2.4/webmitm.c
+--- dsniff-2.4.org/webmitm.c   2003-11-08 22:37:23.000000000 +0100
++++ dsniff-2.4/webmitm.c       2003-11-08 22:45:51.000000000 +0100
 @@ -20,7 +20,7 @@
  
  #include <err.h>
 @@ -20,7 +20,7 @@
  
  #include <err.h>
@@ -190,79 +256,15 @@ diff -Nur dsniff-2.3.org/webmitm.c dsniff-2.3/webmitm.c
  #include <signal.h>
  #include <stdio.h>
  #include <stdlib.h>
  #include <signal.h>
  #include <stdio.h>
  #include <stdlib.h>
-diff -Nur dsniff-2.3.org/webspy.c dsniff-2.3/webspy.c
---- dsniff-2.3.org/webspy.c    2000-11-14 15:51:04.000000000 +0000
-+++ dsniff-2.3/webspy.c        2003-07-03 20:04:23.000000000 +0000
-@@ -21,7 +21,7 @@
+diff -urN dsniff-2.4.org/webspy.c dsniff-2.4/webspy.c
+--- dsniff-2.4.org/webspy.c    2003-11-08 22:37:23.000000000 +0100
++++ dsniff-2.4/webspy.c        2003-11-08 22:45:51.000000000 +0100
+@@ -22,7 +22,7 @@
  #include <string.h>
  #include <err.h>
  #include <X11/Xlib.h>
 -#include <libnet.h>
 +#include <libnet1.h>
  #include <nids.h>
  #include <string.h>
  #include <err.h>
  #include <X11/Xlib.h>
 -#include <libnet.h>
 +#include <libnet1.h>
  #include <nids.h>
- #include "base64.h"
- #include "buf.h"
---- dsniff-2.3.org/configure.in        2003-07-03 19:56:40.000000000 +0000
-+++ dsniff-2.3/configure.in    2003-07-03 20:10:06.000000000 +0000
-@@ -199,9 +199,9 @@
- AC_SUBST(PCAPINC)
- AC_SUBST(PCAPLIB)
  
  
--dnl Checks for libnet
--AC_MSG_CHECKING(for libnet)
--AC_ARG_WITH(libnet,
-+dnl Checks for libnet1
-+AC_MSG_CHECKING(for libnet1)
-+AC_ARG_WITH(libnet1,
- [  --with-libnet=DIR       use libnet in DIR],
- [ case "$withval" in
-   yes|no)
-@@ -209,33 +209,33 @@
-      ;;
-   *)
-      AC_MSG_RESULT($withval)
--     if test -f $withval/include/libnet.h -a -f $withval/lib/libnet.a; then
-+     if test -f $withval/include/libnet1.h -a -f $withval/lib/libnet1.a; then
-         owd=`pwd`
-         if cd $withval; then withval=`pwd`; cd $owd; fi
--      if test -f $withval/bin/libnet-config; then
--         CFLAGS="$CFLAGS `$withval/bin/libnet-config --defines`"
--      elif test -f $withval/libnet-config; then
--         CFLAGS="$CFLAGS `$withval/libnet-config --defines`"
-+      if test -f $withval/bin/libnet1-config; then
-+         CFLAGS="$CFLAGS `$withval/bin/libnet1-config --defines`"
-+      elif test -f $withval/libnet1-config; then
-+         CFLAGS="$CFLAGS `$withval/libnet1-config --defines`"
-       else
--         CFLAGS="$CFLAGS `libnet-config --defines`"
-+         CFLAGS="$CFLAGS `libnet1-config --defines`"
-       fi
-       LNETINC="-I$withval/include"
--      LNETLIB="-L$withval/lib -lnet"
-+      LNETLIB="-L$withval/lib -lnet1"
-      else
--        AC_ERROR(libnet.h or libnet.a not found in $withval)
-+        AC_ERROR(libnet1.h or libnet1.a not found in $withval)
-      fi
-      ;;
-   esac ],
--[ if test -f ${prefix}/include/libnet.h; then
--     CFLAGS="$CFLAGS `${prefix}/bin/libnet-config --defines`"
-+[ if test -f ${prefix}/include/libnet1.h; then
-+     CFLAGS="$CFLAGS `${prefix}/bin/libnet1-config --defines`"
-      LNETINC="-I${prefix}/include"
--     LNETLIB="-L${prefix}/lib -lnet"
--  elif test -f /usr/include/libnet.h; then
--     CFLAGS="$CFLAGS `libnet-config --defines`"
--     LNETLIB="-lnet"
-+     LNETLIB="-L${prefix}/lib -lnet1"
-+  elif test -f /usr/include/libnet1.h; then
-+     CFLAGS="$CFLAGS `libnet1-config --defines`"
-+     LNETLIB="-lnet1"
-   else
-      AC_MSG_RESULT(no)
--     AC_ERROR(libnet not found)
-+     AC_ERROR(libnet1 not found)
-   fi
-   AC_MSG_RESULT(yes) ]
- )
+ #include "base64.h"
This page took 0.183935 seconds and 4 git commands to generate.