]> git.pld-linux.org Git - packages/dshowserver.git/blob - dshowserver.spec
- merged into dhowserver-make.patch
[packages/dshowserver.git] / dshowserver.spec
1 # Conditional build:
2 %bcond_with     static  # static package for use with x86_64 systems
3 #
4
5 %define         svn                     101
6 %define         rel                     0.1
7 Summary:        Win32 CoreAVC H.264 codec helper
8 Summary(pl.UTF-8):      Serwer windowsowego kodeka CoreAVC H.264.
9 Name:           dshowserver
10 Version:        0.1
11 Release:        0.%{svn}.%{rel}
12 License:        GPL
13 Group:          X11/Applications/Multimedia
14 Source0:        %{name}-0.svn%{svn}.tar.bz2
15 # Source0-md5:  9fa17ea92a3d78c34f251a4c56bbd750
16 Patch0:         %{name}-codecspath.patch
17 Patch1:         %{name}-optflags.patch
18 URL:            http://code.google.com/p/coreavc-for-linux/
19 %ifarch %{x8664}
20 BuildRequires:  gcc-multilib
21 %{?with_static:BuildRequires:     glibc-static(i686)}
22 %else
23 %{?with_static:BuildRequires:     glibc-static}
24 %endif
25 BuildRequires:  rpmbuild(macros) >= 1.453
26 BuildRequires:  sed >= 4.0
27 ExclusiveArch:  %{ix86}
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         x8664_flags     -m32
31 %define         specflags_x86_64 %{x8664_flags}
32 %define         specflags_amd64 %{x8664_flags}
33 %define         specflags_ia32e %{x8664_flags}
34
35 %description
36 CoreAVC is a proprietary Windows codec for H.264 video decoding. It is
37 much faster than any currently available open-source codecs. Being
38 multi-threaded, and able to play PAFF streams, it can handle HD
39 H.264/AVC streams that no freely available codecs can. CoreAVC is
40 reasonably priced, but it is Windows only. Dshowserver serves CoreAVC
41 for mythtv, mplayer and xine. Dshowserver can work under 32 or 64 bits
42 linux system. For 64 bits use static binary compiled in 32 bits
43 environement.
44
45 %description -l pl.UTF-8
46 CoreAVC to komercyjny kodek H.264 dla systemu Windows. Jest znacznie
47 szybszy od dowolnego wolnego kodeka. ObsÅ‚ugujac wielowatkowosc moze
48 odtwarzac strumienie zakodowane z uzyciem interlacingu PAFF. Odtwarza
49 strumienie HD H.264/AVC. Kosztuje rozsadnie, ale dostepny jest tylko
50 dla Windows. Dhowserevr implementuje obsluge tego kodeka przez mythtv,
51 mplayer i xine. Dshowserver moze byc uzyty w architekturach x86 i
52 x86_64. Jezeli twoj system jest 64 bitowy. Uzyj statycznych binariow
53 zbudowanych w 32 bitowym srodowisku.
54
55 %package -n registercodec
56 Summary:        Utility to register win32 CoreAVC H.264 codec
57 Summary(pl.UTF-8):      Narzedzie do rejestracji windowsowego kodeka CoreAVC H.264.
58 Group:          X11/Applications/Multimedia
59
60 %description -n registercodec
61 Utility to register win32 CoreAVC H.264 codec for usage with
62 mythtv/mplayer/xine.
63
64 %description -n registercodec -l pl.UTF-8
65 Narzedzie do przeprowadzenia rejestracji komercyjnego kodeka CoreAVC
66 H.264.
67
68 %prep
69 %setup -q -n %{name}-svn%{svn}
70 %patch0 -p1
71 %patch1 -p1
72
73 %if "%{cc_version}" < "3.4"
74 # CC version is arbitary (just to be > 3.3)
75 %{__sed} -i -e 's/-Wno-pointer-sign//;s/-Wdeclaration-after-statement//' {loader,dshowserver}/Makefile
76 %endif
77
78 %build
79 cat << 'EOF' > config.mak
80 override CC = %{__cc}
81 override OPTFLAGS = %{rpmcflags}
82 override LDFLAGS = %{rpmldflags}
83
84 %{?with_static:STATIC = 1}
85
86 AR = ar
87 RANLIB = ranlib
88 OBJDIR = ../objs
89 EOF
90
91 %{__make} -C dshowserver
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
96 install dshowserver/dshowserver $RPM_BUILD_ROOT%{_bindir}/dshowserver
97 install dshowserver/registercodec $RPM_BUILD_ROOT%{_bindir}/registercodec
98 cp -a man/* $RPM_BUILD_ROOT%{_mandir}/man1
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files
104 %defattr(644,root,root,755)
105 %attr(755,root,video) %{_bindir}/dshowserver
106 %{_mandir}/man1/ds*
107
108 %files -n registercodec
109 %defattr(644,root,root,755)
110 %attr(755,root,video) %{_bindir}/registercodec
111 %{_mandir}/man1/re*
This page took 0.058995 seconds and 3 git commands to generate.